Project

General

Profile

Feature #5624

Are Linux jails still needed?

Added by Dru Lavigne over 6 years ago. Updated over 6 years ago.

Status:
Closed: Duplicate
Priority:
Nice to have
Assignee:
John Hixson
Category:
Middleware
Target version:
Estimated time:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:

Description

Now that we have VirtualBox jails that allow users to easily install the distro of their choice, are Linux jails still needed? Removing Linux jails will ease user confusion (experimental, 32-bit only, networking if-fy), simplify documentation, and free developer resources from having to re-generate multiple Linux templates for each release.


Related issues

Is duplicate of FreeNAS - Bug #5419: There Should be only one type of non-Linux JailClosed2014-07-02

History

#1 Updated by Dru Lavigne over 6 years ago

  • Category deleted (38)

#2 Updated by Anonymous over 6 years ago

I don't believe the linux template is useless, even with VirtualBox.

VirtualBox jail is too young to be considered a consistent and solid alternative/substitute to Linux Jail, who works perfectly and doesn't require any complex knowledge of kernel and drivers compiling.

Reading the VirtualBox "How-to" in FreeNAS Forums (http://forums.freenas.org/index.php?threads/virtualbox-in-a-jail-in-freenas.20185) , I believe Linux jail has its public, especially if I don't need VirtualBox for anything else.

#3 Updated by Cyber Jock over 6 years ago

Anderson,

I wrote that guide, and that guide doesn't apply to the pre-built virtualbox template that exists for 9.2.1.6. ;)

I have to side with Dru on this. The Linux jails are a bit of a mess. There are definitely some that use it, but most people get some linux guide for installing some application and try to cookbook it. If anything goes wrong, which seems to be pretty common, then they are sunk. While I know some people that use it, they typically have years of experience with FreeBSD and linux and, despite some setbacks, manage to get it working.

However, for the project as a whole I think that pushing the virtualbox template and removing the linux templates is something that should be considered. Maybe strike up a conversation with the community about linux jails and see what people think of it? There may be far more people using it than we think, or we may find that only 5 people will be inconvenienced. ;)

#4 Updated by Anonymous over 6 years ago

Well, if the guide is really obsolete, I stand corrected.

But... If the guide is old, what is the actual resource usage of the VirtualBox environment? I'm worried because I'm a home user and I have 4Gb RAM, and my FreeNAS computer runs perfectly with that so far.

And if Linux Jail is going to be eliminated, we'll have to revisit an old closed ticket of mine: [[https://bugs.freenas.org/issues/3550]] , where FreeBSD wasn't recognizing non-US accented chars. I'm not fond of being obliged to use VirtualBox because FreeBSD doesn't behave well with the rest of the world outside US.

ps: is my Crashplan-FreeBSD problem related to [[https://bugs.freenas.org/issues/5287]] too?

#5 Updated by Cyber Jock over 6 years ago

Well, if you are using ZFS you are already in dangerous territory as you are using 1/2 the minimum recommended for FreeNAS.

As for the jails, if you allocate 8GB of RAM to a VM, that VM will get 8GB of RAM. So in your case I'd say you'd be just a little insane for trying to run Virtualbox.

That being said. I know some people will be impacted negatively by the loss of linux jails. Notice that I didn't say we should remove them. I said we should consider it. If they really are used in serious quantities then definitely keep them. But I've had nothing but problems trying to get them to work and it seems that a lot of people have problems with the linux jails. :(

#6 Updated by John Hixson over 6 years ago

  • Category set to 38
  • Status changed from Unscreened to Screened

I hate them. They're nothing but trouble. They don't fully function. I'm interested in how many people are actually using them.

#7 Updated by Anonymous over 6 years ago

I'm using UFS, because I know ZFS needs a lot more than I have today.

If the Crashplan plugin non-US accented chars problem is finally fixed (ticket mentioned above), then me and lot of others users with the same problem will have no need of Linux, where those chars works flawlessly.

#8 Updated by Cyber Jock over 6 years ago

Anderson Pereira wrote:

I'm using UFS, because I know ZFS needs a lot more than I have today.

If the Crashplan plugin non-US accented chars problem is finally fixed (ticket mentioned above), then me and lot of others users with the same problem will have no need of Linux, where those chars works flawlessly.

That's nice. But that doesn't answer John's question: "How many people are actually using the linux jail?" Right now we have a vote of one. Not a good defense for keeping the linux jails. ;)

I'll make a post in the forums and see how many respond.

#9 Updated by Cyber Jock over 6 years ago

#10 Updated by Jordan Hubbard over 6 years ago

  • Is duplicate of Bug #5419: There Should be only one type of non-Linux Jail added

#11 Updated by Jordan Hubbard over 6 years ago

  • Status changed from Screened to Closed: Duplicate

Also available in: Atom PDF