Project

General

Profile

Bug #56349

Unable to delete Zvol on new UI, only legacy UI

Added by Spencer Skinner about 1 year ago. Updated 9 months ago.

Status:
Closed
Priority:
No priority
Assignee:
William Grzybowski
Category:
Middleware
Target version:
Seen in:
Severity:
Med High
Reason for Closing:
Duplicate Issue
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

Had an issue after I made a Zvol, used it in a VM, then removed it from the VM. Then when i went to delete it, it said device was busy, I powered off the VM, tried again, same issue. I then turned off all VM's and services which could be linked to it, tried again and it said the same error. Then tried restarting the whole system, same error when I go to delete it. I then tried the legacy UI as a last ditch effort to delete it and it worked without a hitch.

Had the issue twice in the same circumstances. Ive attached a debug to see if that gives any info

Thanks


Related issues

Is duplicate of FreeNAS - Bug #70723: Add dataset force and recursive delete support to API Done

History

#1 Updated by Dru Lavigne about 1 year ago

  • Assignee changed from Release Council to Erin Clark
  • Target version changed from Backlog to 11.2-U2
  • Private changed from No to Yes
  • Severity changed from New to Med High

#3 Updated by Erin Clark about 1 year ago

  • Assignee changed from Erin Clark to Vaibhav Chauhan

Deleting zvols from the new UI seems to work normally, not sure if there is something odd going on there. Passing to VB to investigate since he has worked more with VMs and zvols.

#4 Updated by Spencer Skinner about 1 year ago

Hmm unusual might be an issue specific to my setup, not sure

#5 Updated by Spencer Skinner 12 months ago

Tested it on the new update, the issue still persists

#6 Updated by Vaibhav Chauhan 10 months ago

I tried to reproduce this issue by first trying to remove a zvol which had a VM was running on it, doing so resulted in an error message telling me device is busy. (behaving as intended )
then I turned down VM and then removed the vm's zvol via new UI, which was successful.

#7 Updated by Vaibhav Chauhan 10 months ago

  • Status changed from Unscreened to Screened

#8 Updated by Vaibhav Chauhan 10 months ago

  • Category changed from GUI (new) to Middleware
  • Status changed from Screened to Unscreened
  • Assignee changed from Vaibhav Chauhan to William Grzybowski

#10 Updated by William Grzybowski 10 months ago

  • Status changed from Unscreened to Blocked
  • Reason for Blocked set to Waiting for feedback

Spencer, can you reproduce it at will?

Do you have snapshots of that zvol and/or clones from it?

#11 Updated by Dru Lavigne 10 months ago

  • Target version changed from 11.2-U2 to 11.2-U3

#12 Updated by William Grzybowski 10 months ago

  • Status changed from Blocked to Closed
  • Target version changed from 11.2-U3 to N/A
  • Reason for Closing set to Duplicate Issue
  • Reason for Blocked deleted (Waiting for feedback)

#13 Updated by William Grzybowski 10 months ago

  • Is duplicate of Bug #70723: Add dataset force and recursive delete support to API added

#14 Updated by Dru Lavigne 10 months ago

  • File deleted (debug-AlphaServer-20181107135435.tgz)

#15 Updated by Dru Lavigne 10 months ago

  • Private changed from Yes to No

#16 Updated by Spencer Skinner 9 months ago

  • File debug-AlphaServer-20190221122057.tgz added

To follow up on this bug, I am now experiencing this issue again, I didnt get a chance to test it in the last version but in 11.2 U2 ive tried to deleted a Zvol again and got the device busy bug again. The legacy UI was able to delete it unlike the new UI, not sure if this is specific to my system. Ive attached an updated debug file.

#17 Updated by William Grzybowski 9 months ago

Spencer Skinner wrote:

To follow up on this bug, I am now experiencing this issue again, I didnt get a chance to test it in the last version but in 11.2 U2 ive tried to deleted a Zvol again and got the device busy bug again. The legacy UI was able to delete it unlike the new UI, not sure if this is specific to my system. Ive attached an updated debug file.

See related ticket. This will be fixed in 11.2-U3

#18 Updated by Spencer Skinner 9 months ago

Oh yeh just seen that. cheers for the update

Many thanks
Spencer

#19 Updated by Dru Lavigne 9 months ago

  • File deleted (debug-AlphaServer-20190221122057.tgz)

Also available in: Atom PDF