Project

General

Profile

Bug #56607

Do not log space usage statistics for snapshots accessed over .zfs

Added by Andrew Walker almost 2 years ago. Updated over 1 year ago.

Status:
Done
Priority:
No priority
Assignee:
Ryan Moeller
Category:
OS
Target version:
Seen in:
Severity:
Medium
Reason for Closing:
Reason for Blocked:
Needs QA:
No
Needs Doc:
No
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

collectd's df plugin currently collects data on filesystems that have MNT_IGNORE set. Make it not do that.


Related issues

Related to FreeNAS - Bug #56430: Exclude .zfs/snapshot directories from collectd df outputDone
Related to FreeNAS - Bug #57348: Exclude .zfs/snapshot directories from collectd df outputDone

Associated revisions

Revision cd8e839b (diff)
Added by Ryan Moeller almost 2 years ago

[collectd] Skip mounts marked MNT_IGNORE for df MNT_IGNORE is a flag that indicates a filesystem should not be counted by df. This change teaches the df plugin for collectd to obey it. The df plugin was designed to support statfs as well as statvfs. It preferred statvfs for no apparent reason. The use of statvfs seems to be discouraged by the man page, it doesn't appear to provide any additional data over statfs, and it does not include the `f_flags` field we need to check MNT_IGNORE. So, use of statvfs has been removed. We will always use statfs, and if LIBZFS is enabled we can also use that. Ticket: #56607

Revision 9d4776a4 (diff)
Added by Ryan Moeller almost 2 years ago

[collectd] Skip mounts marked MNT_IGNORE for df MNT_IGNORE is a flag that indicates a filesystem should not be counted by df. This change teaches the df plugin for collectd to obey it. The df plugin was designed to support statfs as well as statvfs. It preferred statvfs for no apparent reason. The use of statvfs seems to be discouraged by the man page, it doesn't appear to provide any additional data over statfs, and it does not include the `f_flags` field we need to check MNT_IGNORE. So, use of statvfs has been removed. We will always use statfs, and if LIBZFS is enabled we can also use that. Ticket: #56607

Revision 45db451f (diff)
Added by Ryan Moeller almost 2 years ago

[collectd] Backport pruning of libzfs code and df MNT_IGNORE support Ticket: #56607

Revision 18fcf61f (diff)
Added by Ryan Moeller over 1 year ago

[collectd] Skip mounts marked MNT_IGNORE for df MNT_IGNORE is a flag that indicates a filesystem should not be counted by df. This change teaches the df plugin for collectd to obey it. The df plugin was designed to support statfs as well as statvfs. It preferred statvfs for no apparent reason. The use of statvfs seems to be discouraged by the man page, it doesn't appear to provide any additional data over statfs, and it does not include the `f_flags` field we need to check MNT_IGNORE. So, use of statvfs has been removed. We will always use statfs, and if LIBZFS is enabled we can also use that. Ticket: #56607

Revision 01e4b257 (diff)
Added by Ryan Moeller over 1 year ago

[collectd] Skip mounts marked MNT_IGNORE for df MNT_IGNORE is a flag that indicates a filesystem should not be counted by df. This change teaches the df plugin for collectd to obey it. The df plugin was designed to support statfs as well as statvfs. It preferred statvfs for no apparent reason. The use of statvfs seems to be discouraged by the man page, it doesn't appear to provide any additional data over statfs, and it does not include the `f_flags` field we need to check MNT_IGNORE. So, use of statvfs has been removed. We will always use statfs, and if LIBZFS is enabled we can also use that. Ticket: #56607

Revision bc89025e (diff)
Added by Ryan Moeller over 1 year ago

[collectd] Skip mounts marked MNT_IGNORE for df MNT_IGNORE is a flag that indicates a filesystem should not be counted by df. This change teaches the df plugin for collectd to obey it. The df plugin was designed to support statfs as well as statvfs. It preferred statvfs for no apparent reason. The use of statvfs seems to be discouraged by the man page, it doesn't appear to provide any additional data over statfs, and it does not include the `f_flags` field we need to check MNT_IGNORE. So, use of statvfs has been removed. We will always use statfs, and if LIBZFS is enabled we can also use that. Ticket: #56607 [collectd] Remove LIBZFS code from df plugin The portions using libzfs are unused and do not add any value. [collectd] Drop post-patch side-effect from patch The port Makefile does a reinplace to remove "-Werror" from configure.ac, which accidentally got added to the patch file.

Revision 80e55859 (diff)
Added by Ryan Moeller over 1 year ago

[collectd] Skip mounts marked MNT_IGNORE for df MNT_IGNORE is a flag that indicates a filesystem should not be counted by df. This change teaches the df plugin for collectd to obey it. The df plugin was designed to support statfs as well as statvfs. It preferred statvfs for no apparent reason. The use of statvfs seems to be discouraged by the man page, it doesn't appear to provide any additional data over statfs, and it does not include the `f_flags` field we need to check MNT_IGNORE. So, use of statvfs has been removed. We will always use statfs, and if LIBZFS is enabled we can also use that. Ticket: #56607

Revision 49860cfc (diff)
Added by Ryan Moeller over 1 year ago

[collectd] Skip mounts marked MNT_IGNORE for df MNT_IGNORE is a flag that indicates a filesystem should not be counted by df. This change teaches the df plugin for collectd to obey it. The df plugin was designed to support statfs as well as statvfs. It preferred statvfs for no apparent reason. The use of statvfs seems to be discouraged by the man page, it doesn't appear to provide any additional data over statfs, and it does not include the `f_flags` field we need to check MNT_IGNORE. So, use of statvfs has been removed. We will always use statfs, and if LIBZFS is enabled we can also use that. Ticket: #56607 [collectd] Remove LIBZFS code from df plugin The portions using libzfs are unused and do not add any value. [collectd] Drop post-patch side-effect from patch The port Makefile does a reinplace to remove "-Werror" from configure.ac, which accidentally got added to the patch file.

Revision 149dbb2f (diff)
Added by Ryan Moeller over 1 year ago

[collectd] Skip mounts marked MNT_IGNORE for df MNT_IGNORE is a flag that indicates a filesystem should not be counted by df. This change teaches the df plugin for collectd to obey it. The df plugin was designed to support statfs as well as statvfs. It preferred statvfs for no apparent reason. The use of statvfs seems to be discouraged by the man page, it doesn't appear to provide any additional data over statfs, and it does not include the `f_flags` field we need to check MNT_IGNORE. So, use of statvfs has been removed. We will always use statfs, and if LIBZFS is enabled we can also use that. Ticket: #56607

Revision e0433b01 (diff)
Added by Ryan Moeller over 1 year ago

[collectd] Skip mounts marked MNT_IGNORE for df MNT_IGNORE is a flag that indicates a filesystem should not be counted by df. This change teaches the df plugin for collectd to obey it. The df plugin was designed to support statfs as well as statvfs. It preferred statvfs for no apparent reason. The use of statvfs seems to be discouraged by the man page, it doesn't appear to provide any additional data over statfs, and it does not include the `f_flags` field we need to check MNT_IGNORE. So, use of statvfs has been removed. We will always use statfs, and if LIBZFS is enabled we can also use that. Ticket: #56607 [collectd] Remove LIBZFS code from df plugin The portions using libzfs are unused and do not add any value. [collectd] Drop post-patch side-effect from patch The port Makefile does a reinplace to remove "-Werror" from configure.ac, which accidentally got added to the patch file.

Revision 6f206054 (diff)
Added by Ryan Moeller over 1 year ago

[collectd] Skip mounts marked MNT_IGNORE for df MNT_IGNORE is a flag that indicates a filesystem should not be counted by df. This change teaches the df plugin for collectd to obey it. The df plugin was designed to support statfs as well as statvfs. It preferred statvfs for no apparent reason. The use of statvfs seems to be discouraged by the man page, it doesn't appear to provide any additional data over statfs, and it does not include the `f_flags` field we need to check MNT_IGNORE. So, use of statvfs has been removed. We will always use statfs, and if LIBZFS is enabled we can also use that. Ticket: #56607

Revision 296739b5 (diff)
Added by Ryan Moeller about 1 year ago

[collectd] Skip mounts marked MNT_IGNORE for df MNT_IGNORE is a flag that indicates a filesystem should not be counted by df. This change teaches the df plugin for collectd to obey it. The df plugin was designed to support statfs as well as statvfs. It preferred statvfs for no apparent reason. The use of statvfs seems to be discouraged by the man page, it doesn't appear to provide any additional data over statfs, and it does not include the `f_flags` field we need to check MNT_IGNORE. So, use of statvfs has been removed. We will always use statfs, and if LIBZFS is enabled we can also use that. Ticket: #56607 [collectd] Remove LIBZFS code from df plugin The portions using libzfs are unused and do not add any value. [collectd] Drop post-patch side-effect from patch The port Makefile does a reinplace to remove "-Werror" from configure.ac, which accidentally got added to the patch file.

Revision 9186f479 (diff)
Added by Ryan Moeller about 1 year ago

[collectd] Skip mounts marked MNT_IGNORE for df MNT_IGNORE is a flag that indicates a filesystem should not be counted by df. This change teaches the df plugin for collectd to obey it. The df plugin was designed to support statfs as well as statvfs. It preferred statvfs for no apparent reason. The use of statvfs seems to be discouraged by the man page, it doesn't appear to provide any additional data over statfs, and it does not include the `f_flags` field we need to check MNT_IGNORE. So, use of statvfs has been removed. We will always use statfs, and if LIBZFS is enabled we can also use that. Ticket: #56607

Revision f3f1b776 (diff)
Added by Ryan Moeller about 1 year ago

[collectd] Skip mounts marked MNT_IGNORE for df MNT_IGNORE is a flag that indicates a filesystem should not be counted by df. This change teaches the df plugin for collectd to obey it. The df plugin was designed to support statfs as well as statvfs. It preferred statvfs for no apparent reason. The use of statvfs seems to be discouraged by the man page, it doesn't appear to provide any additional data over statfs, and it does not include the `f_flags` field we need to check MNT_IGNORE. So, use of statvfs has been removed. We will always use statfs, and if LIBZFS is enabled we can also use that. Ticket: #56607 [collectd] Remove LIBZFS code from df plugin The portions using libzfs are unused and do not add any value. [collectd] Drop post-patch side-effect from patch The port Makefile does a reinplace to remove "-Werror" from configure.ac, which accidentally got added to the patch file.

Revision 96696749 (diff)
Added by Ryan Moeller about 1 year ago

[collectd] Skip mounts marked MNT_IGNORE for df MNT_IGNORE is a flag that indicates a filesystem should not be counted by df. This change teaches the df plugin for collectd to obey it. The df plugin was designed to support statfs as well as statvfs. It preferred statvfs for no apparent reason. The use of statvfs seems to be discouraged by the man page, it doesn't appear to provide any additional data over statfs, and it does not include the `f_flags` field we need to check MNT_IGNORE. So, use of statvfs has been removed. We will always use statfs, and if LIBZFS is enabled we can also use that. Ticket: #56607

History

#1 Updated by Alexander Motin almost 2 years ago

  • Assignee changed from Alexander Motin to Ryan Moeller

Ryan, could please you look on this. This bug makes collectd to log space usage statistics for every snapshot accessed over .zfs directory, whenever it is hidden or not, consuming enormous amount of space and possibly time. You may see those with `mount -v` and `df -a`. I suppose fix should be simple.

#3 Updated by Alexander Motin almost 2 years ago

  • Related to Bug #56430: Exclude .zfs/snapshot directories from collectd df output added

#4 Updated by Ryan Moeller almost 2 years ago

  • Status changed from Unscreened to In Progress
  • Severity changed from New to Medium

#5 Updated by Dru Lavigne almost 2 years ago

  • Target version changed from Backlog to 11.2-U2

#6 Updated by Bug Clerk almost 2 years ago

  • Status changed from In Progress to Ready for Testing

#7 Updated by Bug Clerk almost 2 years ago

  • Target version changed from 11.2-U2 to 11.3

#8 Updated by Bug Clerk almost 2 years ago

  • Status changed from Ready for Testing to In Progress

#9 Updated by Bug Clerk almost 2 years ago

  • Status changed from In Progress to Ready for Testing

#10 Updated by Ryan Moeller almost 2 years ago

  • Needs Merging changed from Yes to No

#11 Updated by Dru Lavigne almost 2 years ago

  • Subject changed from Teach collectd about MNT_IGNORE to Do not log space usage statistics for snapshots accessed over .zfs
  • Needs Doc changed from Yes to No

#12 Updated by Alexander Motin almost 2 years ago

  • Status changed from Ready for Testing to In Progress
  • Target version changed from 11.3 to 11.2-U2
  • Needs Merging changed from No to Yes

It seems to be an arbitrariness from the Bug Clerk side to change the version based on commit to master. Lets still merge it to 11.2-U1.

#13 Updated by Bug Clerk almost 2 years ago

  • Status changed from In Progress to Ready for Testing

#14 Updated by Dru Lavigne almost 2 years ago

  • Needs Merging changed from Yes to No

#15 Updated by Dru Lavigne almost 2 years ago

  • Related to Bug #57348: Exclude .zfs/snapshot directories from collectd df output added

#17 Updated by Ryan Moeller over 1 year ago

  • Needs QA changed from Yes to No

#19 Updated by Dru Lavigne over 1 year ago

  • Status changed from Ready for Testing to Done

Also available in: Atom PDF