Project

General

Profile

Bug #56979

Move logic for getting docstring version to navigation component and add version to Guide link

Added by Bonnie Follweiler almost 2 years ago. Updated almost 2 years ago.

Status:
Done
Priority:
No priority
Assignee:
Erin Clark
Category:
GUI (new)
Target version:
Seen in:
Severity:
Med High
Reason for Closing:
Reason for Blocked:
Needs QA:
No
Needs Doc:
No
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

This just started happening. In FreeNAS-11.2-INTERNAL46 (and the Internal right before)
Right after an update the login screen comes up
Log in and it goes to a white screen
Refresh and it goes to the Log In screen again
Re-Log in and it goes to the Dashboard

Warren's automation is seeing this bug consistently
QE only sees this the first log in after the upgrade


Related issues

Related to FreeNAS - Feature #55944: Add ability to define an online doc URL and version string and substitute them in help text/tooltipsDone
Related to FreeNAS - Umbrella #54909: Unhook Guide from build system and link to online versionDone

Associated revisions

Revision ca58091f (diff)
Added by Erin Clark almost 2 years ago

Move logic for getting docstring version to navigation component and add webversion to guide url Ticket: #56979 #55944

Revision 11dfcd50 (diff)
Added by Erin Clark almost 2 years ago

Move logic for getting docstring version to navigation component and add webversion to guide url Ticket: #56979 #55944 (cherry picked from commit ca58091f9944611ea888555076830779b2409e72)

History

#1 Updated by Dru Lavigne almost 2 years ago

  • Severity changed from New to Med High

#3 Updated by Erin Clark almost 2 years ago

  • Status changed from Unscreened to In Progress

This was caused by my solution to 55944, will have a fix soon

#4 Updated by Erin Clark almost 2 years ago

  • Related to Feature #55944: Add ability to define an online doc URL and version string and substitute them in help text/tooltips added

#6 Updated by Erin Clark almost 2 years ago

  • Status changed from In Progress to Ready for Testing

#7 Updated by Dru Lavigne almost 2 years ago

  • Target version changed from Backlog to 11.2-RC2

#8 Updated by Dru Lavigne almost 2 years ago

  • Subject changed from The first time logging in after an upgrade the login goes to a white screen forcing a refresh and a re-login to Move logic for getting docstring version to navigation component and add version to Guide link
  • Needs Doc changed from Yes to No
  • Needs Merging changed from Yes to No

#9 Updated by Dru Lavigne almost 2 years ago

  • Related to Umbrella #54909: Unhook Guide from build system and link to online version added

#10 Updated by Bonnie Follweiler almost 2 years ago

  • Status changed from Ready for Testing to Passed Testing
  • Needs QA changed from Yes to No

Passed Testing in FreeNAS-11.2-INTERNAL49

#11 Updated by Dru Lavigne almost 2 years ago

  • Status changed from Passed Testing to Done

Also available in: Atom PDF