Project

General

Profile

Bug #5741

Upgrade from 9.2.1.6 to 9.2.1.7 broke ups driver

Added by Sean Vetter over 6 years ago. Updated over 6 years ago.

Status:
Closed: Cannot reproduce
Priority:
Nice to have
Assignee:
Sean Fagan
Category:
OS
Target version:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

Before the upgrade I left the service running.
After upgrade and the reboot that happens from the upgrade upsmon didn't restart. I attempted to start the driver manually and got the error message bellow.

Debugging:
@
[root@FreeNAS] ~# /usr/local/libexec/nut/usbhid-ups -a ups
Network UPS Tools - Generic HID driver 0.38 (2.7.1)
USB communication driver 0.32
No matching HID UPS found

/var/log/messages right after upgrade
Aug 8 10:07:22 FreeNAS notifier: Network UPS Tools - Generic HID driver 0.38 (2.7.1)
Aug 8 10:07:22 FreeNAS notifier: USB communication driver 0.32
Aug 8 10:07:22 FreeNAS notifier: No matching HID UPS found
Aug 8 10:07:22 FreeNAS notifier: Driver failed to start (exit status=1)
Aug 8 10:07:22 FreeNAS notifier: Network UPS Tools - UPS driver controller 2.7.1
Aug 8 10:07:22 FreeNAS root: /usr/local/etc/rc.d/nut: WARNING: failed precmd routine for nut
Aug 8 10:07:22 FreeNAS notifier: /usr/local/etc/rc.d/nut: WARNING: failed precmd routine for nut
Aug 8 10:07:23 FreeNAS notifier: nut_upsmon not running? (check /var/db/nut/upsmon.pid).
Aug 8 10:07:23 FreeNAS notifier: Starting nut_upsmon.
Aug 8 10:07:23 FreeNAS notifier: kill: No such process
Aug 8 10:07:23 FreeNAS notifier: UPS: ups (master) (power value 1)
Aug 8 10:07:23 FreeNAS upsmon6372: UPS [ups]: connect failed: Connection failure: Connection refused
Aug 8 10:07:23 FreeNAS upsmon6372: Communications with UPS ups lost
Aug 8 10:07:23 FreeNAS notifier: nut_upslog not running? (check /var/db/nut/upslog.pid).
Aug 8 10:07:23 FreeNAS notifier: Starting nut_upslog.
Aug 8 10:07:23 FreeNAS notifier: Warning: initial connect failed: Connection failure: Connection refused
Aug 8 10:07:24 FreeNAS notifier: Stopping nut_upslog.
Aug 8 10:07:24 FreeNAS notifier: Waiting for PIDS: 6400.
Aug 8 10:07:24 FreeNAS notifier: Stopping nut_upsmon.
Aug 8 10:07:48 FreeNAS upsmon6371: upsmon parent: read
Aug 8 10:07:48 FreeNAS notifier: Waiting for PIDS: 6372, 6372, 6372, 6372, 6372, 6372, 6372, 6372, 6372, 6372, 6372, 6372, 6372, 6372, 6372, 6372, 6372, 6372, 6372, 6372, 6372, 6372, 6372, 6372, 6372.

@

After this I did another reboot of the system and tried turning on the UPS service from the gui. I had similar resutls and it didn't start. I manually started the driver from the CLI again. This time it started and then from the GUI I could turn the UPS service back on. Turning it on from the GUI did notice that there were multiple instances of the driver running and terminated the one i had started manually but then it succesfully stated on its own. Something is definatly wrong with the UPS system things just don't work propertly.

after reboot manualy start driver:

[root@FreeNAS] ~# /usr/local/libexec/nut/usbhid-ups -a ups
Network UPS Tools - Generic HID driver 0.38 (2.7.1)
USB communication driver 0.32
Using subdriver: CyberPower HID 0.3

/var/log/messages snippit:

Aug 8 10:29:06 FreeNAS notifier: nut not running? (check /var/db/nut/upsd.pid).
Aug 8 10:29:06 FreeNAS notifier: nut_upsmon not running? (check /var/db/nut/upsmon.pid).
Aug 8 10:29:06 FreeNAS notifier: nut_upslog not running? (check /var/db/nut/upslog.pid).
Aug 8 10:29:06 FreeNAS notifier: Will not 'restart' nut because nut_enable is NO.
Aug 8 10:29:06 FreeNAS notifier: Will not 'restart' nut_upsmon because nut_upsmon_enable is NO.
Aug 8 10:29:06 FreeNAS notifier: Will not 'restart' nut_upslog because nut_upslog_enable is NO.
Aug 8 10:30:27 FreeNAS root: Unknown USB device: vendor 0x0764 product 0x0501 bus uhub3
Aug 8 10:30:54 FreeNAS notifier: nut not running? (check /var/db/nut/upsd.pid).
Aug 8 10:30:54 FreeNAS notifier: nut_upsmon not running? (check /var/db/nut/upsmon.pid).
Aug 8 10:30:54 FreeNAS notifier: nut_upslog not running? (check /var/db/nut/upslog.pid).
Aug 8 10:30:54 FreeNAS notifier: nut not running? (check /var/db/nut/upsd.pid).
Aug 8 10:30:54 FreeNAS notifier: Duplicate driver instance detected! Terminating other driver!
Aug 8 10:30:59 FreeNAS root: Unknown USB device: vendor 0x0764 product 0x0501 bus uhub3
Aug 8 10:30:59 FreeNAS notifier: Using subdriver: CyberPower HID 0.3
Aug 8 10:30:59 FreeNAS notifier: Network UPS Tools - Generic HID driver 0.38 (2.7.1)
Aug 8 10:30:59 FreeNAS notifier: USB communication driver 0.32
Aug 8 10:31:11 FreeNAS notifier: Network UPS Tools - UPS driver controller 2.7.1
Aug 8 10:31:11 FreeNAS notifier: Starting nut.
Aug 8 10:31:11 FreeNAS notifier: fopen /var/db/nut/upsd.pid: No such file or directory
Aug 8 10:31:11 FreeNAS notifier: listening on 127.0.0.1 port 3493
Aug 8 10:31:11 FreeNAS notifier: Connected to UPS [ups]: usbhid-ups-ups
Aug 8 10:31:11 FreeNAS notifier: nut_upsmon not running? (check /var/db/nut/upsmon.pid).
Aug 8 10:31:11 FreeNAS notifier: Starting nut_upsmon.
Aug 8 10:31:11 FreeNAS notifier: fopen /var/db/nut/upsmon.pid: No such file or directory
Aug 8 10:31:11 FreeNAS notifier: UPS: ups (master) (power value 1)
Aug 8 10:31:12 FreeNAS notifier: nut_upslog not running? (check /var/db/nut/upslog.pid).
Aug 8 10:31:12 FreeNAS notifier: Starting nut_upslog.

Configuration:
CyberPower CP1000PFCLCD
Freenas 9.2.1.6/9.2.1.7
Connection: USB
Motherboard: AsRock E3C226D2I
My setup is default other than adding MAXAGE 20 to the upsd.conf.

[root@FreeNAS] ~# ps auxw | grep ups
root 6280 0.0 0.0 20332 3760 ?? Is 10:31AM 0:00.00 /usr/local/sbin/upsmon localhost
uucp 6281 0.0 0.0 20332 3872 ?? S 10:31AM 0:00.01 /usr/local/sbin/upsmon localhost
uucp 6299 0.0 0.0 20332 3864 ?? Is 10:31AM 0:00.00 /usr/local/bin/upslog -s ups -l /var/log/ups.log -i 300
uucp 6545 0.0 0.0 14228 2140 ?? Ss 10:42AM 0:00.00 /usr/local/libexec/nut/usbhid-ups -a ups
uucp 6547 0.0 0.0 20348 3852 ?? Ss 10:42AM 0:00.00 /usr/local/sbin/upsd
uucp 6552 0.0 0.0 12108 1756 ?? S 10:42AM 0:00.00 /usr/local/sbin/upssched Communications with UPS ups established

History

#1 Updated by Jordan Hubbard over 6 years ago

  • Assignee set to Sean Fagan
  • Target version set to 111

#2 Updated by Jordan Hubbard over 6 years ago

  • Target version changed from 111 to 9.3-M3

#3 Updated by Sean Fagan over 6 years ago

  • Status changed from Unscreened to Closed: Cannot reproduce

I just upgraded, and it works for me.

Mine is a CyberPower CP 1500C.

Also available in: Atom PDF