Project

General

Profile

Bug #5753

Can not edit or add (GUI)

Added by Rafa Corrales about 7 years ago. Updated almost 4 years ago.

Status:
Resolved
Priority:
Nice to have
Assignee:
John Hixson
Category:
GUI (new)
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

If I try to edit or add rsync tasks or edit permissions of a dataset I get his error message:

Exception Value:
'NoneType' object has no attribute 'encode'
Exception Location: /usr/local/www/freenasUI/../freenasUI/common/freenasldap.py in get_netbios_name, line 1031

I have upgraded to 9.2.1.7 and the same error happens.

Associated revisions

Revision 2c878300 (diff)
Added by John Hixson about 7 years ago

Validate advanced host configurations Ticket: #5927 Ticket: #5897 Ticket: #5753

History

#1 Updated by Jordan Hubbard about 7 years ago

  • Assignee set to John Hixson

Does that make any sense to you, John?

#2 Updated by John Hixson about 7 years ago

  • Status changed from Unscreened to Screened

#3 Updated by John Hixson about 7 years ago

  • Status changed from Screened to Resolved

Fixed in 2c878300d7c1c9ac2ba4085f034b271e50707ea8. Please open your AD configuration and save it again (when you update to 9.2.18.. when it comes out, or if you apply this manually).

#4 Updated by Rafa Corrales almost 7 years ago

When I try to save AD contiguration after updating to 9.2.18 I get the same error so I can´t save my configuration and solve the problem :-(

"Environment: Software Version: FreeNAS-9.2.1.8-RELEASE-x64 (e625626) Request Method: POST Request URL: https://server.domain.local/admin/services/activedirectory/edit/1/?X-Progress-ID=edf80757-2f6d-40c2-85a7-73b6f280d613 Traceback: File "/usr/local/lib/python2.7/site-packages/django/core/handlers/base.py" in get_response 107. response = middleware_method(request, callback, callback_args, callback_kwargs) File "/usr/local/www/freenasUI/../freenasUI/freeadmin/middleware.py" in process_view 158. return login_required(view_func)(request, view_args, **view_kwargs) File "/usr/local/lib/python2.7/site-packages/django/contrib/auth/decorators.py" in wrapped_view 22. return view_func(request, *args, **kwargs) File "/usr/local/www/freenasUI/../freenasUI/freeadmin/options.py" in wrapper 209. return self._admin.admin_view(view)(*args, **kwargs) File "/usr/local/lib/python2.7/site-packages/django/utils/decorators.py" in _wrapped_view 99. response = view_func(request, *args, **kwargs) File "/usr/local/lib/python2.7/site-packages/django/views/decorators/cache.py" in _wrapped_view_func 52. response = view_func(request, *args, **kwargs) File "/usr/local/www/freenasUI/../freenasUI/freeadmin/site.py" in inner 144. return view(request, *args, **kwargs) File "/usr/local/www/freenasUI/../freenasUI/freeadmin/options.py" in edit 526. mf.save() File "/usr/local/www/freenasUI/../freenasUI/services/forms.py" in save 992. started = notifier().started("activedirectory") File "/usr/local/www/freenasUI/../freenasUI/middleware/notifier.py" in started 344. return f() File "/usr/local/www/freenasUI/../freenasUI/middleware/notifier.py" in _started_activedirectory 712. f = FreeNAS_ActiveDirectory(flags=FLAGS_DBINIT) File "/usr/local/www/freenasUI/../freenasUI/common/freenasldap.py" in init 1444. super(FreeNAS_ActiveDirectory, self)._init__(*kwargs) File "/usr/local/www/freenasUI/../freenasUI/common/freenasldap.py" in init 987. initfunc(**kwargs) File "/usr/local/www/freenasUI/../freenasUI/common/freenasldap.py" in db_init 909. self.netbiosname = self.adset(self.netbiosname, self.get_netbios_name()) File "/usr/local/www/freenasUI/../freenasUI/common/freenasldap.py" in get_netbios_name 1066. filter = "(&(objectcategory=crossref)(nCName=%s))" % basedn.encode('utf-8') Exception Type: AttributeError at /admin/services/activedirectory/edit/1/ Exception Value: 'NoneType' object has no attribute 'encode'"

Any idea?

#5 Updated by Rafa Corrales almost 7 years ago

Just one note:

It´s mandatory to disable Directory Services before saving AD configuration, then it works!!

#6 Updated by Rafa Corrales almost 7 years ago

It´s curious, If I turn on Directory Services the bug appears with its evil :-(
So I have to stop directory services if I want to edit anything where the server NETBIOS name is involved, this is annoying in a production server. I am going to install FREENAS in a test server just to check this issue and getting more information for you.

Thanks for your effort.

#7 Updated by Dru Lavigne almost 4 years ago

  • Target version set to Master - FreeNAS Nightlies

Also available in: Atom PDF