Project

General

Profile

Bug #5774

Crashplan doesn't see folders/files with non-US accents (PART 2)

Added by Anonymous about 6 years ago. Updated about 3 years ago.

Status:
Closed: Not To Be Fixed
Priority:
Nice to have
Assignee:
John Hixson
Category:
Middleware
Target version:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

Now that Linux Jails are going down in 9.3, I ask you developers to continue the ticket #3550 (attached here) on this new one I opened, or reopening it.

Related tickets:
[[https://bugs.freenas.org/issues/5287]]
[[https://bugs.freenas.org/issues/4810]]
[[https://bugs.freenas.org/issues/3550]] [CLOSED]

History

#1 Updated by Anonymous about 6 years ago

William, you started the investigation on the previous ticket (3550). Can't you continue it?
Thanks

#2 Updated by William Grzybowski about 6 years ago

I didn't actually start anything, unfortunately I had and have more pressing issues to resolve at the moment. Sorry.

#3 Updated by Anonymous about 6 years ago

Ok, the only thing I ask is: "Resolve this issue" -> "Kill Linux Jails"

If you disable Linux jails in 9.3 without this fixed, non-us crashplan users WILL be impacted

#4 Updated by John Hixson about 6 years ago

  • Status changed from Unscreened to Screened

#5 Updated by Anonymous about 6 years ago

John, you have nuked Linux Jails in #5419, but what about I asked above?

#6 Updated by John Hixson about 6 years ago

Yes, Linux jails are nuked. That does not affect this ticket, it will still be investigated ;-)

#7 Updated by Anonymous about 6 years ago

Ok, then please set this to the next milestone, since it will be the last one.

#8 Updated by Anonymous almost 6 years ago

Please set this to the next milestone, so nobody forgets to look into it.

#9 Updated by William Grzybowski almost 6 years ago

  • Target version set to 49

#10 Updated by Anonymous almost 6 years ago

FreeNAS 9.3-RELEASE will come without Linux Jails and without resolution for this UTF-8 / non-US accents problem?

#11 Updated by Jordan Hubbard almost 6 years ago

Well, TBH, it's not exactly a huge problem from the overall customer impact perspective. It does beg the question, however: Is it not possible to set the locale from within the crash plan jail to simply work-around this issue?

#12 Updated by Anonymous almost 6 years ago

Please read the attached #3550 ticket history (PDF).

For some reason, simply editing the locale doesn`t works... Crashplan still believes his locale is "C", instead of UTF-8 (be it en_US.UTF-8 or pt_BR.UTF-8) .

Manually setting the correct locale parameters fixes typing and reading in the shell context, but:
1. In next jail restart, the "C" comes back.
2. Crashplan service completely ignores it, as I mentioned in #3550 and above.

For some reason, I believe that fixing the ".1" issue above (correct locale in jail start) will fix the whole problem, because it's possible that Crashplan service tries to find the "original" locale that comes in when the jail starts (maybe a config file of the jail?)

It's a easy problem to reproduce, and a big problem to non-US Crashplan FreeNAS users.

By killing Linux Jails, you will force us (non-US) to choose between:
- Don't upgrade to 9.3 until this ticket is fixed
- Upgrade but don't backup files that has accented chars

Both options are equally terrible

Please take a loot at it.

#13 Updated by Anonymous over 5 years ago

- Erased my Linux jail
- Migrated everything to ZFS
- Upgraded to 9.3
- Installed the official Crashplan plugin in a plugin jail
- Configured everything just right

But the problem still remains: no files with non-US accented chars are uploaded/recognized by Crashplan.

Anyone?

#14 Updated by Mike L about 5 years ago

Also seconding that an official fix for this would be quite helpful. Realizing that half your remote backup strategy is now useless is not a good feeling.

This source indicates that an update to the linux compatibility layer is what is needed.
https://lesressourcesduweb.wordpress.com/2015/05/01/how-to-solve-the-crashplan-utf8-problem-on-freenas/
I can second that that does seem to work for my install.

#15 Updated by Jordan Hubbard about 5 years ago

  • Status changed from Screened to Closed: Not To Be Fixed

#16 Avatar?id=14398&size=24x24 Updated by Kris Moore about 3 years ago

  • Target version changed from 49 to N/A

#17 Updated by Dru Lavigne over 2 years ago

  • File deleted (Bug #3550_ Crashplan doesn_t see folders_files with non-US accents - Freenas - Bug Tracking System.pdf)

Also available in: Atom PDF