Project

General

Profile

Bug #58059

Provide distinction between license and EULA on TrueNAS systems

Added by Nick Bettencourt 7 months ago. Updated 5 months ago.

Status:
Done
Priority:
Critical
Assignee:
Vladimir Vinogradenko
Category:
Middleware
Target version:
Seen in:
TrueNAS - TrueNAS-11.1-U6.1
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
No
Needs Doc:
No
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No


Related issues

Copied to FreeNAS - Bug #59319: Provide distinction between license and EULA on TrueNAS systemsClosed
Copied to FreeNAS - Bug #59328: Provide distinction between license and EULA on TrueNAS systemsDone
Copied to FreeNAS - Bug #59337: Allow production to configure HA without accepting the EULAClosed
Copied to FreeNAS - Bug #59346: Allow production to configure HA without accepting the EULAClosed

History

#2 Updated by Nick Bettencourt 7 months ago

  • Subject changed from Fix EULA bypass feature broken to EULA bypass feature broken

#4 Updated by Dru Lavigne 7 months ago

  • Assignee changed from Release Council to William Grzybowski
  • Target version set to TrueNAS 11.1-U6.2

#5 Updated by William Grzybowski 7 months ago

  • Assignee changed from William Grzybowski to Vladimir Vinogradenko

#8 Updated by Dru Lavigne 7 months ago

  • Status changed from Blocked to Not Started

#9 Updated by Warren Block 7 months ago

The terminology is kind of confusing. When we say "license", we really mean "license key" or "license file".

So here are suggestions:

1. Always show an alert until the EULA is accepted.

2. If the EULA has not been accepted, show the EULA to the user every time they come to the UI until they accept it. Don't allow them to skip agreeing to this important thing that affects both them and iXsystems.

3. Allow Production to set up HA (apply the license key or keyfile) without having to accept the EULA. This should be through a method the end user will not see (magic URL, whatever). It sounds like the key/key file creation process is tied to EULA acceptance, and these should be separate functions.

4. In the Support tab, show when the end user accepted the EULA and provide a button that shows the contents of the EULA.

#10 Updated by Vladimir Vinogradenko 7 months ago

  • File 2018-11-20_22-38-36.png added
  • File 2018-11-20_22_42_46.png added

#12 Updated by Vladimir Vinogradenko 7 months ago

  • Status changed from Not Started to Blocked

#16 Updated by Nick Bettencourt 7 months ago

  • Description updated (diff)

#17 Updated by Warren Block 7 months ago

After speaking to Nick, I think we can summarize this:

1. Keep or implement the EULA bypass keystroke so Production can skip the EULA when setting up the system.
2. When the user clicks the Update License button, show only a field for the License Key, with two buttons labeled Update License and Cancel. This window should not show the EULA, which is a separate matter.

This will allow Production to set up an HA system with license keys installed on both controllers, but still show the user the EULA until they agree to it.

#18 Updated by Bug Clerk 7 months ago

  • Status changed from Blocked to In Progress

#20 Updated by Bug Clerk 7 months ago

  • Status changed from In Progress to Ready for Testing

#22 Updated by Bug Clerk 7 months ago

  • Copied to Bug #59319: Provide distinction between license and EULA on TrueNAS systems added

#23 Updated by Bug Clerk 7 months ago

  • Copied to Bug #59328: Provide distinction between license and EULA on TrueNAS systems added

#24 Updated by Bug Clerk 7 months ago

  • Copied to Bug #59337: Allow production to configure HA without accepting the EULA added

#25 Updated by Bug Clerk 7 months ago

  • Copied to Bug #59346: Allow production to configure HA without accepting the EULA added

#26 Updated by Dru Lavigne 7 months ago

  • Subject changed from Allow production to configure HA without accepting the EULA to Provide distinction between license and EULA on TrueNAS systems
  • Description updated (diff)
  • Private changed from Yes to No
  • Reason for Blocked deleted (Waiting for feedback)
  • Needs Merging changed from Yes to No

#27 Updated by Dru Lavigne 7 months ago

  • File deleted (EULAprelicense.PNG)

#28 Updated by Dru Lavigne 7 months ago

  • File deleted (postlicense.PNG)

#29 Updated by Dru Lavigne 7 months ago

  • File deleted (possible checkbox.PNG)

#30 Updated by Dru Lavigne 7 months ago

  • File deleted (2018-11-20_22-38-36.png)

#31 Updated by Dru Lavigne 7 months ago

  • File deleted (2018-11-20_22_42_46.png)

#32 Updated by Dru Lavigne 7 months ago

  • Target version changed from TrueNAS 11.1-U6.2 to 11.1-U7

#33 Updated by Dru Lavigne 6 months ago

  • Target version changed from 11.1-U7 to TrueNAS 11.1-U7

#37 Updated by Bonnie Follweiler 6 months ago

  • Status changed from Failed Testing to Passed Testing

After talking with William this is a Test Passed.

#39 Updated by Bonnie Follweiler 6 months ago

  • Status changed from Passed Testing to Failed Testing

#41 Updated by Vladimir Vinogradenko 5 months ago

  • Status changed from Failed Testing to Blocked
  • Reason for Blocked set to Waiting for feedback

You only need to accept EULA if you install TrueNAS-11.1-U7-INTERNAL3 or later from scratch. Updates of existing systems won't require to accept EULA, this was explicitly asked for in one of related tickets. So I think the results described above are desired. Are they?

Also TrueNAS-11.1-U7-INTERNAL3 is the only release that has these changes so this

I created a TrueNAS 11.1-U6.2 VM, and clicked cancel at the license/EULA screen (which was together) so I guess if the User puts in the license they have to click "I agree"? (is that working as intended?

is not applicable to this ticket

#42 Updated by Bonnie Follweiler 5 months ago

  • Status changed from Blocked to Passed Testing
  • Needs QA changed from Yes to No

#44 Updated by Timothy Moore II 5 months ago

#45 Updated by Dru Lavigne 5 months ago

  • Status changed from Passed Testing to Done
  • Private changed from Yes to No
  • Reason for Blocked deleted (Waiting for feedback)
  • Needs Doc changed from Yes to No

Also available in: Atom PDF