Project

General

Profile

Bug #58131

iocage jails stoped working 11.2 RC1-1

Added by xico xicao almost 2 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
No priority
Assignee:
Release Council
Category:
Services
Target version:
Seen in:
Severity:
New
Reason for Closing:
Duplicate Issue
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

iocage jails not working:

root@freenas:~ # iocage list
Traceback (most recent call last):
File "/usr/local/bin/iocage", line 10, in <module>
sys.exit(cli())
File "/usr/local/lib/python3.6/site-packages/click/core.py", line 722, in call
return self.main(*args, **kwargs)
File "/usr/local/lib/python3.6/site-packages/click/core.py", line 697, in main
rv = self.invoke(ctx)
File "/usr/local/lib/python3.6/site-packages/click/core.py", line 1066, in invoke
return _process_result(sub_ctx.command.invoke(sub_ctx))
File "/usr/local/lib/python3.6/site-packages/click/core.py", line 895, in invoke
return ctx.invoke(self.callback, **ctx.params)
File "/usr/local/lib/python3.6/site-packages/click/core.py", line 535, in invoke
return callback(*args, **kwargs)
File "/usr/local/lib/python3.6/site-packages/iocage_cli/list.py", line 81, in cli
dataset_type, header, _long, _sort, plugin=plugins, quick=quick)
File "/usr/local/lib/python3.6/site-packages/iocage_lib/iocage.py", line 1150, in list
quick=quick
File "/usr/local/lib/python3.6/site-packages/iocage_lib/ioc_list.py", line 75, in list_datasets
_all = self.list_all(ds)
File "/usr/local/lib/python3.6/site-packages/iocage_lib/ioc_list.py", line 153, in list_all
conf = iocage_lib.ioc_json.IOCJson(mountpoint).json_load()
File "/usr/local/lib/python3.6/site-packages/iocage_lib/ioc_json.py", line 407, in json_load
conf = self.json_check_config(conf)
File "/usr/local/lib/python3.6/site-packages/iocage_lib/ioc_json.py", line 910, in json_check_config
with open(freebsd_version, "r") as r:
FileNotFoundError: [Errno 2] No such file or directory: '/mnt/iocage/releases/EMPTY/root/bin/freebsd-version'


Related issues

Is duplicate of FreeNAS - Bug #52637: Catch any exceptions trying to load freebsd-version during iocage check_configDone

History

#1 Updated by xico xicao almost 2 years ago

  • File debug-freenas-20181116122902.txz added
  • Private changed from No to Yes

#2 Updated by Dru Lavigne almost 2 years ago

  • File deleted (debug-freenas-20181116122902.txz)

#3 Updated by Dru Lavigne almost 2 years ago

  • Is duplicate of Bug #52637: Catch any exceptions trying to load freebsd-version during iocage check_config added

#4 Updated by Dru Lavigne almost 2 years ago

  • Status changed from Unscreened to Closed
  • Target version changed from Backlog to N/A
  • Private changed from Yes to No
  • Reason for Closing set to Duplicate Issue

Xico: this has been fixed for RC2 in the related ticket.

A workaround can be found in this comment: https://redmine.ixsystems.com/issues/52637#note-44.

Also available in: Atom PDF