Project

General

Profile

Bug #58356

Unable to boot into 11.2 RC2

Added by Brian Hawley 9 months ago. Updated 9 months ago.

Status:
Closed
Priority:
No priority
Assignee:
Alexander Motin
Category:
OS
Target version:
Seen in:
Severity:
Low Medium
Reason for Closing:
Cannot Reproduce
Reason for Blocked:
Needs QA:
No
Needs Doc:
No
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

Unfortunatly this seems to remain an issue since beta 2. I continue to get the following error from all versions. This appears after attempting to upgrade and after a fresh install with bios boot selected.

Gptzfsboot error 32 lba 30031240

P_20181026_181820_vHDR_Auto.jpg (3.09 MB) P_20181026_181820_vHDR_Auto.jpg Brian Hawley, 11/18/2018 08:25 AM
P_20181026_181820_vHDR_Auto.jpg (3.09 MB) P_20181026_181820_vHDR_Auto.jpg Brian Hawley, 11/18/2018 08:25 AM
41238
41247

History

#1 Updated by Dru Lavigne 9 months ago

  • Private changed from No to Yes
  • Reason for Blocked set to Need additional information from Author

Brian: do you have an existing 11.1 boot environment you can boot into? If not, can you do an 11.1-U6 install and create a debug (System -> Advanced -> Save debug) to this ticket? This will give the dev a more detailed view of the hardware on the system.

Also, is the BIOS on the system at its latest revision?

#2 Updated by Brian Hawley 9 months ago

  • File debug-freenas-20181119100456.tgz added

I did check my BIOs and it is up to date. Attached is my debug file when I reverted back to 11.1 U6

#3 Updated by Dru Lavigne 9 months ago

  • Category changed from Build system to OS
  • Assignee changed from Release Council to Alexander Motin
  • Reason for Blocked deleted (Need additional information from Author)

#4 Updated by Alexander Motin 9 months ago

  • Status changed from Unscreened to Closed
  • Target version changed from Backlog to N/A
  • Severity changed from New to Low Medium
  • Reason for Closing set to Cannot Reproduce
  • Needs QA changed from Yes to No
  • Needs Doc changed from Yes to No
  • Needs Merging changed from Yes to No

Shall I understand "since beta 2" as that 11.2 always had this problem while 11.1 is working? Or there was something in between? The trigger here is likely a switch from GRUB to BSD loader in 11.2, which replaced one set of compatibility issues with another, different one. Unfortunately we have number of reports like that. Sometimes switch to UEFI instead of BIOS, if system supports that, helps.

Unfortunately, "gptzfsboot: error 32 lba 30031240" just tells that some "controller failure" happened when tried to read blocks at specified offset. The offsets themselves looks OK, I suppose loader tries to read GPT tables, so the real problem cause is not reported here. Unfortunately without ability to reproduce this I am not sure we can do much to help here.

What you could do for experiment is to try booting 11.2 with all devices other then the boot one detached. It would leave BIOS and loader less chances for mistake. Please let us know it go.

Also you could try to install vanilla FreeBSD (11.2 and then 12.0) in the same GPT+ZFS way to reproduce the issue, and then report it upstream, if so.

Also just a note, I see that couple of your disks are attached to SATA controller running in legacy mode. Make sure to check that it can't be switched into AHCI for better performance.

#5 Updated by Dru Lavigne 9 months ago

  • File deleted (debug-freenas-20181119100456.tgz)

#6 Updated by Dru Lavigne 9 months ago

  • Private changed from Yes to No

Also available in: Atom PDF