Project

General

Profile

Bug #5869

Expiration date config on SSL creation (WebGUI)

Added by Anonymous over 6 years ago. Updated about 6 years ago.

Status:
Resolved
Priority:
Nice to have
Assignee:
John Hixson
Category:
GUI (new)
Target version:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

Devs, yesterday I noticed that my self-generated certificate (from SYSTEM -> SETTINGS -> SSL) had expired, and there was nothing I could do from WebGUI to fix it. I had to manually create a certificate and insert it there, because the self-generated one keeped creating certificates with date good-until 02/08/2014.

Two options:
- Open a field where we choose which date (or how many days) the expiration happens.
- When auto-generating, always re-calculate the expiration date to +1 year ahead.

History

#1 Updated by Jordan Hubbard over 6 years ago

  • Assignee set to John Hixson
  • Target version set to 9.3-M3

An expiration date (and a check for expiration now) is on the wish list for the new certificate management UI. Over to John!

#2 Updated by John Hixson over 6 years ago

  • Status changed from Unscreened to Screened

#3 Updated by John Hixson over 6 years ago

  • Status changed from Screened to Resolved

A new certificate manager has been added to freenas for 9.3.

#4 Updated by Daniel Spisak about 6 years ago

Recently we upgraded our farm of 15 9.2.1.2 systems to 9.2.1.7 and now all of our systems have invalid SSL certificates. Looking at the certificates that were created I see them have the following dates on them:

Validity
Not Before: Sep 8 17:47:38 2014 GMT
Not After : Oct 8 17:47:38 2014 GMT

We did our upgrades on Sept 8, so this would seem to indicate the SSL cert creation step is at fault here.

Also available in: Atom PDF