Project

General

Profile

Bug #58815

Auto Boot Not Working

Added by Zachary Hutson 10 months ago. Updated 8 months ago.

Status:
Closed
Priority:
No priority
Assignee:
Alexander Motin
Category:
OS
Target version:
Seen in:
Severity:
New
Reason for Closing:
Cannot Reproduce
Reason for Blocked:
Needs QA:
No
Needs Doc:
No
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

I am not able to get my FreeNAS 11.2 RC1 System to auto boot on start. The Bootloader splash screen shows up, but it doesn't automatically boot. I have to press 1. When I check the variables via "show", the autoboot_delay=No. Is there a way to edit the boot config so I can have my system auto boot without needing to press 1?

Thank You,

Zach H.

History

#1 Updated by Dru Lavigne 10 months ago

  • Category changed from Quality Engineering to OS
  • Status changed from Unscreened to Blocked
  • Assignee changed from Joe Maloney to Release Council
  • Private changed from No to Yes
  • Reason for Blocked set to Need additional information from Author

Zachary: does the issue persist after updating to RC2? If so, please attach a debug (System -> Advanced -> Save debug) from the RC2 system to this ticket.

#2 Updated by Zachary Hutson 10 months ago

  • File debug.tgz added

Dru Lavigne wrote:

Zachary: does the issue persist after updating to RC2? If so, please attach a debug (System -> Advanced -> Save debug) from the RC2 system to this ticket.

Dru,

Please find the debug attached. I’ll update to RC2 after the holiday’s if you aren't able to find anything useful in the RC1 debug.

Thanks,

Zach H.

#3 Updated by Dru Lavigne 10 months ago

Zachary: does this issue persist in RC2?

#4 Updated by Dru Lavigne 10 months ago

  • File deleted (debug.tgz)

#5 Updated by Dru Lavigne 10 months ago

  • Status changed from Blocked to Closed
  • Target version changed from Backlog to N/A
  • Private changed from Yes to No

Zachary: please leave a comment on this ticket if the issue is still reproducible after updating to RELEASE (due out later today).

#6 Updated by Zachary Hutson 9 months ago

  • File debug-FreeNAS1-20181214085404.tgz added

Dru Lavigne wrote:

Zachary: please leave a comment on this ticket if the issue is still reproducible after updating to RELEASE (due out later today).

Dru, just updated to 11.2-Release and the problem still persists. I've attached the debug.

Thanks,

Zach H.

#7 Updated by Dru Lavigne 9 months ago

  • Status changed from Closed to Unscreened
  • Assignee changed from Release Council to Alexander Motin
  • Target version changed from N/A to Backlog
  • Private changed from No to Yes
  • Seen in changed from 11.2-RC1 to 11.2-RELEASE
  • Reason for Blocked deleted (Need additional information from Author)

#8 Updated by Alexander Motin 9 months ago

  • Status changed from Unscreened to Blocked
  • Reason for Blocked set to Need additional information from Author

FreeNAS by default sets autoboot_delay to "5" in /boot/loader.conf. Could you attach what you have in /boot/loader.conf.local in case there is anything that could be misparced.

#9 Updated by Alexander Motin 9 months ago

  • Status changed from Blocked to Closed
  • Target version changed from Backlog to N/A
  • Reason for Closing set to Cannot Reproduce
  • Reason for Blocked deleted (Need additional information from Author)
  • Needs QA changed from Yes to No
  • Needs Doc changed from Yes to No
  • Needs Merging changed from Yes to No

Closing on lack of response and inability to reproduce.

#10 Updated by Dru Lavigne 9 months ago

  • File deleted (debug-FreeNAS1-20181214085404.tgz)

#11 Updated by Dru Lavigne 9 months ago

  • Private changed from Yes to No

#12 Updated by Zachary Hutson 9 months ago

Alexander Motin wrote:

FreeNAS by default sets autoboot_delay to "5" in /boot/loader.conf. Could you attach what you have in /boot/loader.conf.local in case there is anything that could be misparced.

Sorry, I've been out of country for awhile and wasn't able to get the .conf file. How do I extract/get to the /boot/loader.conf.local? I'm assuming I need to use shell in my Freenas unit; however, not too familiar with BSD commands.

Thanks,

Zach H.

#13 Updated by Alexander Motin 9 months ago

`cat /boot/loader.conf.local` in command line should print it on terminal.

#14 Updated by Zachary Hutson 9 months ago

Alexander Motin wrote:

`cat /boot/loader.conf.local` in command line should print it on terminal.

So, 'cat /boot/loader.conf.local' doesn't return much, but I tried 'cat /boot/loader.conf' and got an output that shows much more. It shows autoboot delay of 5, but in practice it never gets past the splash screen. I've waited about a half hour last night and it didn't autoboot. Any help would be appreciated.

[root@FreeNAS1 ~]# cat /boot/loader.conf.local
kernel="kernel"
module_path="/boot/kernel;/boot/modules;/usr/local/modules"
kern.cam.ctl.ha_id=0
[root@FreeNAS1 ~]# cat /boot/loader.conf #
  1. Boot loader file for FreeNAS. #
    product="FreeNAS"
    autoboot_delay="5"
    loader_logo="FreeNAS"
    loader_menu_title="Welcome to FreeNAS"
    loader_brand="FreeNAS"
    loader_version=" "
  1. Workaround slow to attach USB boot devices
    kern.cam.boot_delay="30000"
  1. If the machine dies at boot before /etc/rc.d/sysctl is run, let the user do
  2. something.
    debug.debugger_on_panic=1
    debug.ddb.textdump.pending=1

hw.hptrr.attach_generic=0

  1. Retry for 30 seconds before giving up.
    vfs.mountroot.timeout="30"
  1. Load firmware for isp FC cards.
    ispfw_load="YES"
  1. Load ipmi module
    ipmi_load="YES"
  1. Load freenas sysctl module
    freenas_sysctl_load="YES"
  1. Put FC ports in initiator mode
    hint.isp.0.role=2
    hint.isp.1.role=2
    hint.isp.2.role=2
    hint.isp.3.role=2
  1. Possible kernel module locations
    module_path="/boot/kernel;/boot/modules;/usr/local/modules"
  1. Disable IPv6 link local addresses. We'll enable this per interface
  2. if IPv6 is configured for the interface later on in boot.
    net.inet6.ip6.auto_linklocal="0"
  1. Switch ZVOLs into "dev" mode, skipping GEOM.
    vfs.zfs.vol.mode=2
  1. Disable unused GEOM labels.
    kern.geom.label.disk_ident.enable=0
    kern.geom.label.ufs.enable=0
    kern.geom.label.ufsid.enable=0
    kern.geom.label.reiserfs.enable=0
    kern.geom.label.ntfs.enable=0
    kern.geom.label.msdosfs.enable=0
    kern.geom.label.ext2fs.enable=0
  1. Disable AHCI Enclosure support, not wired anywhere now.
    hint.ahciem.0.disabled="1"
    hint.ahciem.1.disabled="1"
  1. Increase dmesg buffer to fit longer boot output.
    kern.msgbufsize="524288"
  1. Prefer newer mrsas(4) to mfi(4) for controllers supported by both.
    hw.mfi.mrsas_enable="1"
  1. Don't wait for USB detach when rebooting. We may wish
  2. to investigate this further.
    hw.usb.no_shutdown_wait=1
  1. Disable File Handle Affinity for NFS write operations.
  2. It improves NFS write throughput with ZFS sync=always.
    vfs.nfsd.fha.write=0
    vfs.nfsd.fha.max_nfsds_per_fh=32
  1. Make pagedaemon always request kernel (primarily ZFS) to free memory
  2. before even thinking about swapping. It may be another extreme, but
  3. hopefully it will be better then going out of swap, since arc_min won't
  4. allow ARC to shrink too much if some application really require swap.
    vm.lowmem_period=0

#15 Updated by Alexander Motin 9 months ago

I've checked on my system and confirmed in code, that autoboot_delay=NO there appear when you get to the loader prompt, so it does not mean anything in the `show` command output. I'd propose you to think whether anything may send some (space?) char to the loader, making it stop booting. Don't you have also serial console enabled or something else? Since you are the only reporting this issue, it must be something specific to your system.

#16 Updated by Zachary Hutson 9 months ago

Alexander Motin wrote:

I've checked on my system and confirmed in code, that autoboot_delay=NO there appear when you get to the loader prompt, so it does not mean anything in the `show` command output. I'd propose you to think whether anything may send some (space?) char to the loader, making it stop booting. Don't you have also serial console enabled or something else? Since you are the only reporting this issue, it must be something specific to your system.

I'm not sure what would send a character at boot? I have a wireless keyboard connected for troubleshooting and a HDMI monitor connected as well. But those two things should cause it to stop booting, since I had the same setup with 11.1-U4&6 and it would boot just fine. Is there an option in the bios that might cause it or a setting in the setup process? Is there a way to override any settings to force it to autoboot?

#17 Updated by Dru Lavigne 9 months ago

  • Status changed from Closed to Unscreened

#18 Updated by Alexander Motin 9 months ago

  • Status changed from Unscreened to Blocked
  • Reason for Closing deleted (Cannot Reproduce)
  • Reason for Blocked set to Waiting for feedback

Unfortunately I have no clue why it may happen. You are the only one reporting this. I'd propose you to backup existing FreeNAS configuration and try freshly reinstall it on some other media to see whether new copy will boot fine on that setup. If it will, then try to restore the configuration and see again. If it work, then so be it, if not, and it happen even for fresh installation, then it will also be an information.

#19 Updated by Alexander Motin 8 months ago

  • Status changed from Blocked to Closed
  • Reason for Closing set to Cannot Reproduce
  • Reason for Blocked deleted (Waiting for feedback)

Closing this on lack of ideas.

Also available in: Atom PDF