Project

General

Profile

Bug #5894

Adding file-based extent to running experimental iscsi target (ctld) fails

Added by Richard Kojedzinszky over 6 years ago. Updated about 6 years ago.

Status:
Resolved
Priority:
Nice to have
Assignee:
Josh Paetzel
Category:
OS
Target version:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

When adding a new file based extent to ctld, the file should be explicitly created by the management system:

I got the following messages:
Aug 23 15:55:28 freenas-teszt ctld6774: error returned from LUN creation request: ctl_be_block_open: error opening /mnt/vol0/iscsi/x1
Aug 23 15:55:28 freenas-teszt ctld6774: failed to add lun 1, target iqn.2011-03.org.example.istgt:target1
Aug 23 15:55:28 freenas-teszt ctld6774: failed to reload configuration

I dont know if this is the intended behaviour, but istgt implicitly created the file if it was missing, and I suspect that the management code relied on it.

Associated revisions

Revision a1e2826f (diff)
Added by Josh Paetzel about 6 years ago

Create file extents via GUI. We can no longer depend on istgt to do this for us. Ticket: #5894

History

#1 Updated by Josh Paetzel over 6 years ago

  • Status changed from Unscreened to Screened
  • Target version set to 9.3-RELEASE

Bingo

#2 Updated by Josh Paetzel over 6 years ago

  • Target version changed from 9.3-RELEASE to 9.3-M3

#3 Updated by Josh Paetzel over 6 years ago

That is the case exactly.

#4 Updated by Jordan Hubbard over 6 years ago

BRB: Josh will add code to "truncate" the file into place from the UI when the file-based extent is added.

#5 Updated by Josh Paetzel about 6 years ago

  • Status changed from Screened to Resolved

Also available in: Atom PDF