Project

General

Profile

Bug #5955

Create new folder option in jails storage manager doesn't seem to work anymore

Added by Shawn NA about 6 years ago. Updated about 3 years ago.

Status:
Closed: Duplicate
Priority:
Nice to have
Assignee:
John Hixson
Category:
Middleware
Target version:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

So I've been using FreeNAS pretty solidly for awhile now. Generally when you don't change anything and it's solid, there aren't issues. :) I recently tried to re-add in the BTSync plugin. I decided I wanted to set this up again and actually start using it with some of the new advances they've made in the code. When I went to enable it everything seemed to go fine, Jail was created, Plugin loaded, and I was able to hit the web interface. When I decided to start configuring the folders to mount to the jail, I hit an issue. It seems that I'm no longer able to have the jail Create and/or Mount folders to ANY jail now. I thought it was just an issue with the BTSync jail (perhaps something related to having an install previously) but I tested this with my currently working PlexMediaServer jail, and it failed with the same message.

My steps to reproduce:
Login to the WebUI
Expand the Jails section in the left column
Select a jail
Select storage
Select add storage
Map a current folder in your system to a non-existent folder in the jail
Check the box for create new folder
The below error message is what I've received multiple times when attempting on any jail
It will also spit this message if you select a currently mapped folder that isn't mounted, and check the mounted box
The folder mapping will be created in the Web UI for the jail (as the name appears with the mapping after the error message), but it will not actually Mount the folder

Aug 30 12:34:25 atlantis manage.py: [middleware.exceptions:38] [MiddlewareError: The path could not be mounted /mnt/vol1/software: Mount failed (64) -> mount: /mnt/vol1/jails/btsync_1/mnt/software: No such file or directory ]
Aug 30 12:36:34 atlantis manage.py: [middleware.exceptions:38] [MiddlewareError: The path could not be mounted /mnt/vol1/shared: Mount failed (64) -> mount: /mnt/vol1/jails/plexmediaserver_1/mnt/shared: No such file or directory ]

Related issues

Has duplicate FreeNAS - Bug #5349: When mounting storage into a jail if the dest dir doesn't exist, the create dir checkbox doesn't workResolved2014-06-25

History

#1 Updated by Shawn NA about 6 years ago

So I decided to try and just manually open the jail and create the folder myself, and it seems this solves the problem. So perhaps there is simply something wrong when using the "Create new folder" option box when adding storage?

#2 Updated by Jordan Hubbard about 6 years ago

  • Subject changed from WebUI won't Mount new folders or mappings that don't exist to Create new folder option in jails storage manager doesn't seem to work anymore
  • Category set to 38
  • Assignee set to John Hixson
  • Target version set to 49

I've seen this behavior too - it's definitely just the issue reported in the follow-up.

#3 Updated by John Hixson about 6 years ago

  • Status changed from Unscreened to Screened

#4 Updated by Josh Paetzel about 6 years ago

My feeling is this is a dup. I recall there being tickets about this before, the fix just hasn't been merged to 9.2.1-BRANCH.

#5 Updated by John Hixson about 6 years ago

Josh Paetzel wrote:

My feeling is this is a dup. I recall there being tickets about this before, the fix just hasn't been merged to 9.2.1-BRANCH.

It is in fact a bug. I have confirmed it. Looking into why and coming up with a fix now ;-)

#6 Updated by Josh Paetzel about 6 years ago

John,

Maybe I wasn't clear.

Yes, this is a bug. Yes, it's reproducible. We've looked at it before. In fact I believe you fixed it in master. We didn't merge it to 9.2.1-BRANCH because it was judged too disruptive.

We should find the ticket this duplicates before doing any work on it.

#7 Updated by John Hixson about 6 years ago

John Hixson wrote:

Josh Paetzel wrote:

My feeling is this is a dup. I recall there being tickets about this before, the fix just hasn't been merged to 9.2.1-BRANCH.

It is in fact a bug. I have confirmed it. Looking into why and coming up with a fix now ;-)

Or not ;-) I did it wrong, heheh.

#9 Updated by Josh Paetzel about 6 years ago

  • Has duplicate Bug #5349: When mounting storage into a jail if the dest dir doesn't exist, the create dir checkbox doesn't work added

#10 Updated by Josh Paetzel about 6 years ago

  • Status changed from Screened to Closed: Duplicate

#11 Avatar?id=14398&size=24x24 Updated by Kris Moore about 3 years ago

  • Target version changed from 49 to N/A

Also available in: Atom PDF