Project

General

Profile

Bug #5958

Plugins treemenu issue, 500 INTERNAL SERVER ERROR

Added by Jason Calvert about 6 years ago. Updated about 4 years ago.

Status:
Closed: Cannot reproduce
Priority:
Nice to have
Assignee:
Suraj Ravichandran
Category:
Middleware
Target version:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

I am receiving this for 2 out of 6 installed plugins.
- Plex gives the error and doesn't show up in the Plugins tree, but still works
- SABnzbd - The jail starts, gives the error, but the plugin itself will not start.

Aug 31 20:41:13 freenas notifier: Performing sanity check on nginx configuration:
Aug 31 20:41:13 freenas notifier: nginx: the configuration file /usr/local/etc/nginx/nginx.conf syntax is ok
Aug 31 20:41:13 freenas notifier: nginx: configuration file /usr/local/etc/nginx/nginx.conf test is successful
Aug 31 20:41:16 freenas manage.py: [freeadmin.navtree:526] Couldn't retrieve https://192.168.0.9/plugins/plexmediaserver/3/_s/treemenu: HTTP Error 500: INTERNAL SERVER ERROR
Aug 31 20:41:16 freenas manage.py: [freeadmin.navtree:526] Couldn't retrieve https://192.168.0.9/plugins/sabnzbd/6/_s/treemenu: HTTP Error 500: INTERNAL SERVER ERROR

All plugins have VIMAGE UNticked.
I believe that both of these problem plugins are ones that I have used the "Upgrade" button for previously.

Jason

History

#1 Updated by Sean Fagan about 6 years ago

  • Assignee changed from Sean Fagan to John Hixson

John?

#2 Updated by John Hixson about 6 years ago

  • Status changed from Unscreened to 15

I'm not convinced plugins will actually work with VIMAGE unchecked as I have never actually tried it and it isn't recommended or supported. Can you enable VIMAGE again, restart your jails and verify this is still a problem?

#3 Updated by Jason Calvert about 6 years ago

John Hixson wrote:

I'm not convinced plugins will actually work with VIMAGE unchecked as I have never actually tried it and it isn't recommended or supported. Can you enable VIMAGE again, restart your jails and verify this is still a problem?

OK, I have tried each of my installed Jails/Plugins with both VIMAGE enabled and disabled, with the following results:
(short-hand summary, options with + worked, - didnt')

sabnzbd (after deleting and reinstalling entire jail)
+ VIMAGE Ticked = Works Fine, shows in Tree Menu
- VIMAGE Unticked =

transmission
- VIMAGE Ticked = Doesn't show in TreeMenu and plugin won't start
+ VIMAGE Unticked = All OK & in TreeMenu (has always been that way)

plexmediaserver
+ VIMAGE Ticked = Works OK, but NOT in TreeMenu
+ VIMAGE Unticked = Works OK, but NOT in TreeMenu

sickbeard
- VIMAGE Ticked = Doesn't show in TreeMenu and plugin won't start
+ VIMAGE Unticked = All OK & in TreeMenu

couchpotato
- VIMAGE Ticked = Doesn't show in TreeMenu and plugin won't start
+ VIMAGE Unticked = All OK & in TreeMenu

headphones
- VIMAGE Ticked = Doesn't show in TreeMenu and plugin won't start
+ VIMAGE Unticked = All OK & in TreeMenu

Thanks
Jason

#4 Updated by Jordan Hubbard about 6 years ago

  • Status changed from 15 to Investigation
  • Assignee changed from John Hixson to Suraj Ravichandran
  • Target version set to 111

Thanks for the feedback. Hmmm. Interesting - over to Suraj to investigate.

#5 Updated by Jason Calvert about 6 years ago

Jordan Hubbard wrote:

Thanks for the feedback. Hmmm. Interesting - over to Suraj to investigate.

Thanks.
I have just updating CouchPotato via the GUI Update button, and now the Plugin will not start whether VIMAGE is enabled or not!

Would you like some logs or config file?

Jason

#6 Updated by Jordan Hubbard almost 6 years ago

  • Status changed from Investigation to Closed: Cannot reproduce

BRB: We cannot reproduce this failure. Something specific to user's system?

#7 Avatar?id=14398&size=24x24 Updated by Kris Moore about 4 years ago

  • Target version changed from 111 to N/A

Also available in: Atom PDF