Project

General

Profile

Bug #59688

Show console messages in new UI without having to scroll

Added by Jurgen Segaert about 3 years ago. Updated over 2 years ago.

Status:
Done
Priority:
No priority
Assignee:
Dennis Mullen
Category:
GUI (new)
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
No
Needs Doc:
No
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

ACCEPTANCE CRITERIA:
Console message footer should now just pop up rather than make the user scroll to see it. Turn it on in System/Advanced + 'Show Console messages' and the console should always be attached to the bottom of the window, regardless of the size of the window.

ORIGINAL DESCRIPTION
When you activate the "Show console Messages" option, the log messages are added at the bottom of the screen as expected, but consistently require scrolling to make said messages visible, no matter how much space is available on the screen. Reducing the font size (zooming out) doesn't help. The screenshots speak for themselves.

I'm using Firefox.


Related issues

Has duplicate FreeNAS - Bug #63591: UI glitch: System / GeneralClosed

History

#3 Updated by Anonymous almost 3 years ago

  • Assignee changed from Release Council to Damian Szidiropulosz
  • Target version changed from Backlog to 11.2-U2

#4 Updated by Anonymous almost 3 years ago Private

BRB: We want to possibly redesign this for 11.3 but for the time being we should look into adjusting the window height so it doesn't force the user to scroll.

#5 Updated by Anonymous almost 3 years ago

  • Has duplicate Bug #63591: UI glitch: System / General added

#6 Updated by Damian Szidiropulosz almost 3 years ago

  • Status changed from Unscreened to Screened

#7 Updated by Dru Lavigne almost 3 years ago

  • Target version changed from 11.2-U2 to 11.2-U3

#8 Updated by Anonymous almost 3 years ago

  • Status changed from Screened to Unscreened
  • Assignee changed from Damian Szidiropulosz to Dennis Mullen

#9 Updated by Dennis Mullen almost 3 years ago

  • Status changed from Unscreened to In Progress

#10 Updated by Anonymous almost 3 years ago

  • Status changed from In Progress to Ready for Testing
  • Needs Merging changed from Yes to No

Testing criteria: console message footer should now just pop up rather than make the user scroll to see it

#11 Updated by Dru Lavigne almost 3 years ago

  • Subject changed from Show console messages without having to scroll to Show console messages in new UI without having to scroll
  • Needs Doc changed from Yes to No

#12 Updated by Dennis Mullen over 2 years ago

  • Description updated (diff)

#14 Updated by Jeff Ervin over 2 years ago

58818
58827
58836
58845
58854

*Test Failed FreeNAS-11.2-U2-INTERNAL93

I showed Dennis what I was seeing, and he felt that this isn't what should be seen. When using Chrome & Firefox there are two scroll bars to the right. If the outer scroll bar is pulled all the way down then the console shows at all times at the bottom in the WebUI. If the same bar is all the way up, then the console disappears when scrolling through the UI. This works as intended in Safari since only one scroll bar is used. See screenshots

#16 Updated by Anonymous over 2 years ago

  • Status changed from Failed Testing to Ready for Testing

#18 Updated by Jeff Ervin over 2 years ago

59844
59853
59862

Test Passed FreeNAS-11.2-U2-INTERNAL96

Tested this in Chrome, Firefox & Safari

#19 Updated by Dru Lavigne over 2 years ago

  • Status changed from Passed Testing to Done

Also available in: Atom PDF