Project

General

Profile

Bug #6003

Install Plugin Fails if Jails Dataset Already Exists

Added by Dru Lavigne over 6 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
Nice to have
Assignee:
John Hixson
Category:
Middleware
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

See attached screenshot. To reproduce, create a dataset named jails and point Jails Configuration to it. Install a couple of jails. Then, try to install a Plugin.

Suggestion: have the Plugins install script check to see if a jails dataset already exists and automatically use, rather than throw an error, it if it does.

error.png (60.8 KB) error.png Dru Lavigne, 09/04/2014 09:27 AM
error.png (107 KB) error.png Dru Lavigne, 09/19/2014 06:58 AM
1204
1252

History

#1 Updated by Jordan Hubbard over 6 years ago

  • Category set to 38
  • Assignee set to John Hixson
  • Target version set to 9.3-M3

#2 Updated by John Hixson over 6 years ago

  • Status changed from Unscreened to Screened

#3 Updated by Jordan Hubbard over 6 years ago

  • Target version changed from 9.3-M3 to 9.3-BETA

#4 Updated by John Hixson over 6 years ago

  • Status changed from Screened to 15

Dru,

This one is weird. So if a jails dataset does not exist, one is created. If one already exists, it does in fact use that. Is this still able to be reproduced? Again, I am not able to reproduce this =-(

#5 Updated by Dru Lavigne over 6 years ago

Right now I can't even get the Jails Configuration screen to open (it tracebacks) on the Sept 17 nightly. Will try again tomorrow in case your changes didn't get in before the build.

#6 Updated by Dru Lavigne over 6 years ago

1252

We're getting closer. Jails Configuration now opens. Plugins start to install, but give the attached traceback about 3/4 of the installation way in. Again, to reproduce, create a dataset called jails and try to install a Plugin. I tried the bacula-sd and CouchPotato plugins.

#7 Updated by John Hixson over 6 years ago

  • Status changed from Unscreened to Screened

#8 Updated by Dru Lavigne over 6 years ago

  • Status changed from Screened to Closed

Woohoo! No more tracebacks as of M4-4989948.

Also available in: Atom PDF