Project

General

Profile

Bug #6008

Volume manager blows the hell up

Added by Jordan Hubbard about 6 years ago. Updated about 6 years ago.

Status:
Resolved
Priority:
Nice to have
Assignee:
Josh Paetzel
Category:
-
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

Trying to create new pool on 10.5.0.125 (my usual root pw) - destroyed old pool and said to mark drives as destroyed. This worked. Dragged new drives into a RAIDZ2 + L2ARC and said to create volume tank.
Traceback ensued.

Associated revisions

Revision 636af47a (diff)
Added by Josh Paetzel about 6 years ago

Deal with there being dead symlinks to old pools for the NFSv4 stablerestart files. The root cause of the buggy behavior is that os.path.exists() returns False for dead symlinks; it follows the symlink. Because the programmer that wrote the code assumed that os.path.exists would return True if the symlink was there (regardless if it was valid or not) the code would try to create a symlink where one already existed and explode with a glorious traceback. Ticket: #6008

History

#1 Updated by Jordan Hubbard about 6 years ago

P.S. After traceback it does appear that the pool was created, just noisily.

#2 Updated by Josh Paetzel about 6 years ago

  • Status changed from Unscreened to Investigation
  • Assignee changed from William Grzybowski to Josh Paetzel

It's my code that is exploding. I'll fix it.

#3 Updated by Josh Paetzel about 6 years ago

Of course I can't repro it, even on the machine in the ticket.

#4 Updated by Josh Paetzel about 6 years ago

Ok, in order to repro this you have to create a pool, destroy it, then create a new pool.

Also this box is a few weeks old at this point, which can make following tracebacks a bit difficult!

#5 Updated by Josh Paetzel about 6 years ago

  • Status changed from Investigation to Resolved

explosions suppressed.

Note: FreeNAS can still explode, just not here anymore, and not in this way.

Also available in: Atom PDF