Project

General

Profile

Bug #60390

Remove showmount from freenas-debug to prevent hang condition

Added by Dru Lavigne 6 months ago. Updated 6 months ago.

Status:
Done
Priority:
No priority
Assignee:
Caleb St. John
Category:
Middleware
Target version:
Seen in:
TrueNAS - TrueNAS-11.1-U6.1
Severity:
Medium
Reason for Closing:
Reason for Blocked:
Needs QA:
No
Needs Doc:
No
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

freenas-debug being run on an HA system, will sometimes fail to capture the passive controllers debug because of this traceback

Nov 5 07:48:26 truenas-node-A uwsgi: [system.utils:406] Failed to get debug from standby node
Traceback (most recent call last):
File "./freenasUI/system/utils.py", line 404, in debug_generate
standby_debug = c.call('failover.call_remote', 'system.debug', [], {'job': True}, timeout=300)
File "./freenasUI/system/utils.py", line 404, in debug_generate
standby_debug = c.call('failover.call_remote', 'system.debug', [], {'job': True}, timeout=300)
File "/usr/local/lib/python3.6/site-packages/middlewared/client/client.py", line 429, in call
raise CallTimeout("Call timeout")
middlewared.client.client.CallTimeout: Call timeout

This is because freenas-debug is running job=True with timeout=300 and the "showmount -e" command is hanging so the entire debug process is failing.

This bug is to create a workaround for "showmount -e" command.


Related issues

Copied from FreeNAS - Bug #55734: Remove showmount from freenas-debug to prevent hang conditionDone
Copied to FreeNAS - Bug #60426: Remove showmount from freenas-debug to prevent hang conditionDone

History

#1 Updated by Dru Lavigne 6 months ago

  • Copied from Bug #55734: Remove showmount from freenas-debug to prevent hang condition added

#2 Updated by Dru Lavigne 6 months ago

#3 Updated by Dru Lavigne 6 months ago

  • Copied to Bug #60426: Remove showmount from freenas-debug to prevent hang condition added

#4 Updated by Caleb St. John 6 months ago

Test case:

On the passive controller:

1. log in via ssh
2. service rpcbind onestop

Then try and capture a debug. If both A and B controllers are present, then the issue is resolved.

#5 Updated by Bonnie Follweiler 6 months ago

  • Status changed from Ready for Testing to Passed Testing
  • Needs QA changed from Yes to No

TrueNAS-11.1-U6.2-INTERNAL2

#6 Updated by Dru Lavigne 6 months ago

  • Status changed from Passed Testing to Done

Also available in: Atom PDF