Project

General

Profile

Bug #60426

Remove showmount from freenas-debug to prevent hang condition

Added by Dru Lavigne 5 months ago. Updated 4 months ago.

Status:
Done
Priority:
No priority
Assignee:
Caleb St. John
Category:
Middleware
Target version:
Seen in:
TrueNAS - TrueNAS-11.1-U6.1
Severity:
Medium
Reason for Closing:
Reason for Blocked:
Needs QA:
No
Needs Doc:
No
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

freenas-debug being run on an HA system, will sometimes fail to capture the passive controllers debug because of this traceback

Nov 5 07:48:26 truenas-node-A uwsgi: [system.utils:406] Failed to get debug from standby node
Traceback (most recent call last):
File "./freenasUI/system/utils.py", line 404, in debug_generate
standby_debug = c.call('failover.call_remote', 'system.debug', [], {'job': True}, timeout=300)
File "./freenasUI/system/utils.py", line 404, in debug_generate
standby_debug = c.call('failover.call_remote', 'system.debug', [], {'job': True}, timeout=300)
File "/usr/local/lib/python3.6/site-packages/middlewared/client/client.py", line 429, in call
raise CallTimeout("Call timeout")
middlewared.client.client.CallTimeout: Call timeout

This is because freenas-debug is running job=True with timeout=300 and the "showmount -e" command is hanging so the entire debug process is failing.

This bug is to create a workaround for "showmount -e" command.


Related issues

Copied from FreeNAS - Bug #60390: Remove showmount from freenas-debug to prevent hang conditionDone

History

#1 Updated by Dru Lavigne 5 months ago

  • Copied from Bug #60390: Remove showmount from freenas-debug to prevent hang condition added

#2 Updated by Caleb St. John 4 months ago

  • Status changed from Ready for Testing to Passed Testing

#4 Updated by Dru Lavigne 4 months ago

  • Status changed from Passed Testing to Done
  • Needs QA changed from Yes to No

Also available in: Atom PDF