Project

General

Profile

Bug #60936

Fix bug in Init/Shutdown scripts create and edit modes

Added by Disk Didler 8 months ago. Updated 5 months ago.

Status:
Done
Priority:
No priority
Assignee:
William Grzybowski
Category:
Middleware
Target version:
Seen in:
Severity:
Med High
Reason for Closing:
Reason for Blocked:
Needs QA:
No
Needs Doc:
No
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

I am currently working with this user interface and finding it .... extremely inconsistent.

Firstly, see this screenshot.
https://i.imgur.com/tbwSdKM.jpg

How can I have a 'script' command set and a 'command' command set?

I have been editing the same entry, each time I go to edit the entry, it seems to forget if it's a script or command, it forgets if it's post or pre.

I've tried a mammoth amount of combinations of commands (which I know work in the CLI when I SSH in)

Also, I know this command works in SSH, 100% - NONE of these 6 (!) entries are working for me.
https://imgur.com/hJ5uQLH

Also, there's discussion in previous old forum threads about FreeNAS, discussing keeping script files in /data/ (yeah, presumably the FreeNAS root USB?)
When I attempt to replicate this, I can't point (in the new UI) to /data/ I have to do it off /mnt/ points.

I have set my script as +x and I've set a +777. I know the script runs in CLI, I can not in any way get the system to execute it.

Look at this command.
/mnt/ARRAY/media/33/FreeNAS-scripts-master/set_hdd_erc.sh | tee -a /mnt/ARRAY/media/bob.log
100% does what it is supposed to and writes a log file, won't work in the init section, no matter what I do.

I think the key thing here, in the very least is the fact entries 'forget' if they're command or script, they forget if they're pre or post.

Can someone please take a look


Related issues

Has duplicate FreeNAS - Bug #59643: editing a Init/Shutdown entry a 2nd time wont populate fieldsClosed
Has duplicate FreeNAS - Bug #69616: Editing an Init or Shutdown script in the GUI renders it inoperableClosed
Has duplicate FreeNAS - Bug #75522: "Init/shutdown scripts" UI gets confused if an entrey changes from script to commandClosed

Associated revisions

Revision eddf645f (diff)
Added by William Grzybowski 6 months ago

fix(middlewared/initshut): reset one of script/command

Ticket: #60936

Revision f67e5718 (diff)
Added by William Grzybowski 6 months ago

fix(middlewared/initshutdown): use correct dict to update datastore

Ticket: #60936

Revision 0cf3895e (diff)
Added by William Grzybowski 6 months ago

fix(middlewared/initshut): reset one of script/command

Ticket: #60936

Revision 45e2c436 (diff)
Added by William Grzybowski 6 months ago

fix(middlewared/initshutdown): use correct dict to update datastore

Ticket: #60936

Revision eb0ae141 (diff)
Added by William Grzybowski 6 months ago

fix(db): migration to correct mistake in middleware

Ticket: #60936

Revision af3cefaf (diff)
Added by William Grzybowski 6 months ago

fix(db): migration to correct mistake in middleware

Ticket: #60936

Revision 1688b272 (diff)
Added by William Grzybowski 6 months ago

feat(db): add merge migration for master/11.3

Ticket: #60936

Revision 2163ba6c (diff)
Added by William Grzybowski 6 months ago

fix(middlewared/initshut): reset one of script/command

Ticket: #60936

Revision 1d7436f6 (diff)
Added by William Grzybowski 6 months ago

fix(middlewared/initshutdown): use correct dict to update datastore

Ticket: #60936

Revision 231fad56 (diff)
Added by William Grzybowski 6 months ago

fix(db): migration to correct mistake in middleware

Ticket: #60936

Revision b6417765 (diff)
Added by William Grzybowski 6 months ago

feat(db): add merge migration for master/11.3

Ticket: #60936

History

#1 Updated by Erin Clark 7 months ago

  • Subject changed from Init / Shutdown scripts UI seems to be inconsistent / odd. to Init / Shutdown scripts UI edit mode appears to be broken.
  • Assignee changed from Release Council to Vaibhav Chauhan
  • Target version changed from Backlog to 11.2-U2

BRB: There appears to be a bug with edit mode where it is not loading the saved values. VB will look into this.

#2 Updated by William Grzybowski 7 months ago

  • Category changed from GUI (new) to Middleware
  • Status changed from Unscreened to Screened
  • Assignee changed from Vaibhav Chauhan to William Grzybowski
  • Severity changed from New to Med High

This seems mostly a backend issue.

#3 Updated by William Grzybowski 7 months ago

  • Target version changed from 11.2-U2 to 11.2-U3

#4 Updated by Vaibhav Chauhan 7 months ago

  • Related to Bug #59643: editing a Init/Shutdown entry a 2nd time wont populate fields added

#5 Updated by Bug Clerk 6 months ago

  • Status changed from Screened to In Progress

#6 Updated by Bug Clerk 6 months ago

  • Status changed from In Progress to Ready for Testing

#7 Updated by Bug Clerk 6 months ago

  • Target version changed from 11.2-U3 to 11.2-U2

#8 Updated by Dru Lavigne 6 months ago

  • Related to deleted (Bug #59643: editing a Init/Shutdown entry a 2nd time wont populate fields)

#9 Updated by Dru Lavigne 6 months ago

  • Has duplicate Bug #59643: editing a Init/Shutdown entry a 2nd time wont populate fields added

#10 Updated by Dru Lavigne 6 months ago

  • Subject changed from Init / Shutdown scripts UI edit mode appears to be broken. to Fix bug in Init/Shutdown scripts create and edit modes
  • Needs Doc changed from Yes to No
  • Needs Merging changed from Yes to No

#11 Updated by Dru Lavigne 6 months ago

  • Has duplicate Bug #69616: Editing an Init or Shutdown script in the GUI renders it inoperable added

#13 Updated by Dru Lavigne 5 months ago

  • Status changed from Ready for Testing to Done
  • Needs QA changed from Yes to No

Confirmed that selecting Script added a browse button to select script and reselecting Command went back to type-in box for the command.

#14 Updated by Dru Lavigne 5 months ago

  • Has duplicate Bug #75522: "Init/shutdown scripts" UI gets confused if an entrey changes from script to command added

Also available in: Atom PDF