Project

General

Profile

Bug #61659

Fix iocage restart

Added by pascal bombardier almost 2 years ago. Updated almost 2 years ago.

Status:
Done
Priority:
No priority
Assignee:
Brandon Schneider
Category:
Middleware
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
No
Needs Doc:
No
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

Hello,
on my system, the pool "rpool" is encrypted and used as iocage pool
after booting and unlocking this pool while choosing "automatic restart for iocage", the iocage pool setup seems to be lost, and the jail is not started
I can define the iocage pool again, and start the jail manually afterwards
Thanks
Kind Regards
Pascal


Related issues

Has duplicate FreeNAS - Bug #63441: Rebooting the server with a locked pool might hinder the start of the pluginsClosed
Has duplicate FreeNAS - Bug #66261: Not all plugins will start after reboot from updateClosed
Has duplicate FreeNAS - Bug #71092: FreeNAS-11.2-RELEASE-U1 has decided to simply not start jails at boot (autostart is ticked)Closed
Copied to FreeNAS - Bug #62604: Fix iocage restartDone
Copied to FreeNAS - Bug #62613: iocage pool setup lost and no automatic start after pool unlockingClosed

Associated revisions

Revision 031f51bf (diff)
Added by Brandon Schneider almost 2 years ago

fix(jail/rc_action): RESTART now works as intended Previous behavior would have the same cached list and that would cause issues with start. This instantiates a new instance for both actions. Ticket: #61659

Revision 47f53b20 (diff)
Added by Brandon Schneider almost 2 years ago

fix(jail/rc_action): RESTART now works as intended Remove the sleeping between instances and use the iocage interface for this. Ticket: #61659

Revision 2adfac2a (diff)
Added by Brandon Schneider almost 2 years ago

tkt-61659: fix(jail/rc_action): RESTART now works as intended (#2193) * fix(jail/rc_action): RESTART now works as intended Remove the sleeping between instances and use the iocage interface for this. Ticket: #61659 * Remove time import

Revision e7e5561a (diff)
Added by Brandon Schneider almost 2 years ago

fix(jail/rc_action): RESTART now works as intended Remove the sleeping between instances and use the iocage interface for this. Ticket: #61659 (cherry picked from commit 47f53b20ee23a8323a3ffe378c3db3c01ceb0d15)

Revision 959f3fce (diff)
Added by Bug Clerk almost 2 years ago

tkt-62613: fix(jail/rc_action): RESTART now works as intended (by skarekrow) (#2213) * fix(jail/rc_action): RESTART now works as intended Remove the sleeping between instances and use the iocage interface for this. Ticket: #61659 (cherry picked from commit 47f53b20ee23a8323a3ffe378c3db3c01ceb0d15) * Remove time import (cherry picked from commit 2216ee833dd1b827bdfd0bffd78c0d9258057340)

History

#1 Updated by Dru Lavigne almost 2 years ago

  • Assignee changed from Release Council to William Grzybowski
  • Private changed from No to Yes

#2 Updated by William Grzybowski almost 2 years ago

  • Assignee changed from William Grzybowski to Brandon Schneider
  • Target version changed from Backlog to 11.2-U2

Brandon, pretty sure we had a similar ticket before, must be a regression.

#3 Updated by Brandon Schneider almost 2 years ago

  • Status changed from Unscreened to Not Started

#4 Updated by Bug Clerk almost 2 years ago

  • Status changed from Not Started to In Progress

#5 Updated by Bug Clerk almost 2 years ago

  • Status changed from In Progress to Ready for Testing

#6 Updated by Bug Clerk almost 2 years ago

  • Target version changed from 11.2-U2 to 11.3

#7 Updated by Bug Clerk almost 2 years ago

#9 Updated by Bug Clerk almost 2 years ago

  • Copied to Bug #62613: iocage pool setup lost and no automatic start after pool unlocking added

#10 Updated by Dru Lavigne almost 2 years ago

  • File deleted (debug-freenas-20181204192041.tgz)

#11 Updated by Dru Lavigne almost 2 years ago

  • Subject changed from iocage pool setup lost and no automatic start after pool unlocking to Fix iocage restart
  • Status changed from Ready for Testing to Done
  • Target version changed from 11.3 to Master - FreeNAS Nightlies
  • Needs QA changed from Yes to No
  • Needs Doc changed from Yes to No
  • Needs Merging changed from Yes to No

#13 Updated by Dru Lavigne almost 2 years ago

  • Private changed from Yes to No

#14 Updated by Brandon Schneider almost 2 years ago

  • Has duplicate Bug #63441: Rebooting the server with a locked pool might hinder the start of the plugins added

#15 Updated by William Grzybowski almost 2 years ago

  • Has duplicate Bug #66261: Not all plugins will start after reboot from update added

#16 Updated by William Grzybowski over 1 year ago

  • Has duplicate Bug #71092: FreeNAS-11.2-RELEASE-U1 has decided to simply not start jails at boot (autostart is ticked) added

Also available in: Atom PDF