Project

General

Profile

Bug #6176

USB device not listed in install FreeNAS menu

Added by Mykolas Norvaisas almost 6 years ago. Updated almost 3 years ago.

Status:
Closed: Third party to resolve
Priority:
No priority
Assignee:
Mykolas Norvaisas
Category:
OS
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

Booted from CD to upgrade to latest 9.3 M4 nightly. When selecting installation USB device (da0) is not listed. I see only my two ZFS data disks (ada0 and ada1). My usb key da0 is not there. As a workaround I can plug one more USB key (da1) and reenter install menu once more. Now there are tree choices to install to ada1, ada2 and da0. If I select da0 further upgrade process forks fine.

1- boot with 1 usb.jpg (78.1 KB) 1- boot with 1 usb.jpg Booted with 1 USB flash disk inserted Mykolas Norvaisas, 09/24/2014 11:54 AM
2- inserting second usb.jpg (137 KB) 2- inserting second usb.jpg Inserted second USB disk after boot Mykolas Norvaisas, 09/24/2014 11:54 AM
3- reetering install menu.jpg (83.3 KB) 3- reetering install menu.jpg Reetered menu after 2nd USB disk Mykolas Norvaisas, 09/24/2014 11:54 AM
1267
1268
1269

History

#1 Updated by William Grzybowski almost 6 years ago

What was the latest release the USB flash drive worked? Is it plugged in a USB3 port? Did you try changing ports?

#2 Updated by Mykolas Norvaisas almost 6 years ago

1267
1268
1269

Previously fresh installed 9.3 M3 issue was the same. computer and usb sticks are USB2. Added screenshot series to describe issue. Changing port does not help. Inserting usb show menu with usb count-1 . So if I insert or boot with 4 usb drives. Install menu will show 3

#3 Updated by Jordan Hubbard almost 6 years ago

  • Assignee set to Sean Fagan

#4 Updated by Sean Fagan almost 6 years ago

  • Status changed from Unscreened to 15
  • Assignee changed from Sean Fagan to Mykolas Norvaisas

The installer only sees disks that the kernel sees; it doesn't weed anything out other than cdroms.

At the installer menu, select Shell, and then do a couple of things:

sysctl kern.disks

Do you see da0 there?

dmesg | grep da0

should also show information.

#5 Updated by Mykolas Norvaisas almost 6 years ago

  • File dmesg.log added
  • File disk.info.log added

Tried CD install with latest image FreeNAS-9.3-M4-451a894-x64 on Dell E6430 laptop with two sata disks and 1 usb flash
Same situation. Booted from Freenas install CD. Install menu does not show USB flash. See attached dmesg and diskinfo logs

sysctl kern.disks
kern.disks: da0 cd0 ada1 ada0
dmesg | grep da
FreeBSD is a registered trademark of The FreeBSD Foundation.
  Standard Extended Features=0x281<GSFSBASE,SMEP,ENHMOVSB>
acpi_acad0: <AC Adapter> on acpi0
ada0 at ahcich0 bus 0 scbus0 target 0 lun 0
ada0: <WDC WD3200BEKT-75PVMT1 01.01A01> ATA-8 SATA 2.x device
ada0: Serial Number WD-WX31A43N6615
ada0: 300.000MB/s transfers (SATA 2.x, UDMA6, PIO 8192bytes)
ada0: Command Queueing enabled
ada0: 305245MB (625142448 512 byte sectors: 16H 63S/T 16383C)
ada0: Previously was known as ad4
ada1 at ahcich1 bus 0 scbus1 target 0 lun 0
ada1: <OCZ-VERTEX4 1.5> ATA-9 SATA 3.x device
ada1: Serial Number OCZ-387K4DEH8733O2TV
ada1: 600.000MB/s transfers (SATA 3.x, UDMA6, PIO 8192bytes)
ada1: Command Queueing enabled
ada1: 244198MB (500118192 512 byte sectors: 16H 63S/T 16383C)
ada1: quirks=0x1<4K>
ada1: Previously was known as ad6
da0 at umass-sim1 bus 1 scbus6 target 0 lun 0
da0: <SanDisk Cruzer Blade 1.26> Removable Direct Access SCSI-5 device 
da0: Serial Number 4C532000060306108541
da0: 40.000MB/s transfers
da0: 7633MB (15633408 512 byte sectors: 255H 63S/T 973C)
da0: quirks=0x2<NO_6_BYTE>
cdce0: <Dell Wireless 5540 HSPA Mini-Card Network Adapter> on usbus1
md0 attached to /data/base.ufs.uzip

#6 Updated by Jordan Hubbard almost 6 years ago

  • Target version changed from 9.3-M4 to 9.3-BETA

#7 Updated by Jordan Hubbard almost 6 years ago

  • Status changed from 15 to Closed: Third party to resolve

FreeBSD 9.3 evidently does not see this device. We're not likely to have a solution for FreeNAS 9.3 and will have to wait for a fix to come from upstream.

#8 Updated by S Nochkin over 5 years ago

This is actually by design. I mean the menu, not detecting the drive.
The "da0" is actually in the list and detected properly. Scroll down by pressing "arrow down" button to see your "da0" in the list.
The original menu shows "66%". That means you see 66% of the lines (drives) only. The "+" sign also gives you a hint that the menu is not completely shown in the screen.

#9 Updated by Dru Lavigne almost 3 years ago

  • File deleted (dmesg.log)

#10 Updated by Dru Lavigne almost 3 years ago

  • File deleted (disk.info.log)

#11 Updated by Dru Lavigne almost 3 years ago

  • Target version changed from 9.3-BETA to N/A

Also available in: Atom PDF