Project

General

Profile

Bug #61785

Hide pool column in new UI until middleware is complete

Added by Jeff Ervin 9 months ago. Updated 5 months ago.

Status:
Done
Priority:
No priority
Assignee:
Lola Yang
Category:
GUI (new)
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
No
Needs Doc:
No
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

The disks are marked as unused, but they are underlying devices for g multi-path device used within a pool.


Related issues

Related to FreeNAS - Bug #69346: Dashboard Pool card 'Disk details not avalible'Closed
Related to FreeNAS - Feature #70527: Add multipath page to new UIDone
Related to FreeNAS - Bug #77413: Add back pool column to disk list page of new UIReady for Testing

History

#1 Updated by Dru Lavigne 9 months ago

  • Category changed from Middleware to Hardware
  • Assignee changed from Release Council to Alexander Motin
  • Reason for Blocked set to Need additional information from Author

#3 Updated by Alexander Motin 9 months ago

  • Category changed from Hardware to Middleware
  • Assignee changed from Alexander Motin to William Grzybowski

I don't see what can be a hardware problem here. It seems like multipaths are real and correct. The pools are created on top of partitions on top of multipaths, so everything seem to be valid, except that UI shows one of two multipath disk instances as unused. I suppose it is middleware problem.

#4 Updated by William Grzybowski 9 months ago

  • Status changed from Unscreened to Screened
  • Reason for Blocked deleted (Need additional information from Author)

#5 Updated by Alex Rosenberg 9 months ago

Seeing the same. Additionally, the webui dashboard widgetpool only shows my log and cache devices and none of the multipath devices.

#6 Updated by Alex Rosenberg 9 months ago

Another datapoint: the Storage->Pools->View Multipaths UI is not showing up for me, but does under the legacy UI.

#7 Updated by Alex Rosenberg 8 months ago

Alex Rosenberg wrote:

Another datapoint: the Storage->Pools->View Multipaths UI is not showing up for me, but does under the legacy UI.

I don't see any code in the webui project to handle multipath UI at all. Also:

[2018/12/25 01:48:56] (DEBUG) ZFSPoolService.get_disks():89 - Could not find disk for multipath/disk7p2

#8 Updated by William Grzybowski 8 months ago

  • Category changed from Middleware to GUI (new)
  • Status changed from Screened to Unscreened
  • Assignee changed from William Grzybowski to Erin Clark
  • Target version changed from Backlog to 11.2-U3

Erin, new UI needs a View Multipaths in the new UI.
There is likely some middleware problem here but lets identify those when your team get a chance to work on it.

#9 Updated by John Delisle 7 months ago

Just wanted to chime in with a "me too" post.

I'm running 11.2 U1 in a VM with my "Dell SAS 6gbps HBA" in passthrough mode. It's a JBOD/"IT Mode" HBA. It has two SAS connections to my NetApp DS4246 enclosure. Disks show up as follows in geom/gmultipath (abbreviated):

root@freenas[~]# geom multipath list disk3
Geom name: disk3
Type: AUTOMATIC
Mode: Active/Passive
UUID: 09e7d1bd-15ee-11e9-b650-000c29f308bf
State: OPTIMAL
Providers:
1. Name: multipath/disk3
   Mediasize: 3000592981504 (2.7T)
   Sectorsize: 512
   Mode: r2w2e5
   State: OPTIMAL
Consumers:
1. Name: da20
   Mediasize: 3000592982016 (2.7T)
   Sectorsize: 512
   Mode: r3w3e6
   State: ACTIVE
2. Name: da3
   Mediasize: 3000592982016 (2.7T)
   Sectorsize: 512
   Mode: r3w3e6
   State: PASSIVE

root@freenas[~]# 

In the 11.2 U1 Web UI, I do not see what is described here: https://www.ixsystems.com/documentation/freenas/11.2/storage.html#view-multipaths and instead I see individual disks as described by Jeff above. This is a fresh install, with disks that were freshly wiped with dd.

I do see the "view multipaths" stuff in the Legacy UI.

#10 Updated by Dru Lavigne 7 months ago

  • Related to Bug #69346: Dashboard Pool card 'Disk details not avalible' added

#11 Updated by Erin Clark 7 months ago

#12 Updated by Erin Clark 6 months ago

  • Assignee changed from Erin Clark to Lola Yang

#14 Updated by Erin Clark 6 months ago

  • Related to Bug #77413: Add back pool column to disk list page of new UI added

#16 Updated by Lola Yang 6 months ago

  • Status changed from Unscreened to In Progress

#17 Updated by Dru Lavigne 6 months ago

  • Subject changed from Storage/Disks not associating mulitpath devices with pool to Hide pool column in new UI until middleware is complete
  • Needs Merging changed from Yes to No

#19 Updated by Erin Clark 6 months ago

  • Status changed from In Progress to Ready for Testing

#20 Updated by Jeff Ervin 6 months ago

58602

Test Passed FreeNAS-11.2-U2-INTERNAL93

#21 Updated by Timothy Moore II 6 months ago

Docs PR: https://github.com/freenas/freenas-docs/pull/760 [angulargui]. Master branch text is slightly less specific and didn't need any updates.

#22 Updated by Dru Lavigne 5 months ago

  • Status changed from Passed Testing to Done
  • Needs Doc changed from Yes to No

Also available in: Atom PDF