Project

General

Profile

Bug #62163

Disk Temperatures feature Broken

Added by Jerzy Sobski 7 months ago. Updated 2 months ago.

Status:
Closed
Priority:
No priority
Assignee:
Damian Szidiropulosz
Category:
GUI (new)
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

Prior to upgrading from 11.2RC2 UI was able to display drive temperatures. Once updated to latest Freenas 11.2 Release drive temperature no longer shows up and remains at 0

UI - Drive Temp 2.png (115 KB) UI - Drive Temp 2.png Jerzy Sobski, 12/05/2018 06:31 PM
UI - Drive Temp 1.png (67 KB) UI - Drive Temp 1.png Jerzy Sobski, 12/05/2018 06:31 PM
43836
43839

Related issues

Related to FreeNAS - Bug #62583: Disk temp not shown for Seagate Desktop HDD.15 ST4000DM000-1F2168Closed
Related to FreeNAS - Feature #62181: Display disk temperatures and CPU frequency on dashboard.Closed
Related to FreeNAS - Bug #63069: PCIe SSD disk temperature not reportingClosed

History

#2 Updated by Dru Lavigne 7 months ago

  • Assignee changed from Release Council to Erin Clark
  • Target version changed from Backlog to 11.2-U2

#3 Updated by Dru Lavigne 7 months ago

  • Status changed from Unscreened to In Progress
  • Assignee changed from Erin Clark to Damian Szidiropulosz

#5 Updated by Dru Lavigne 6 months ago

  • Related to Bug #62583: Disk temp not shown for Seagate Desktop HDD.15 ST4000DM000-1F2168 added

#6 Updated by Dru Lavigne 6 months ago

  • Related to Feature #62181: Display disk temperatures and CPU frequency on dashboard. added

#7 Updated by Dru Lavigne 6 months ago

  • Related to Bug #63069: PCIe SSD disk temperature not reporting added

#9 Updated by Damian Szidiropulosz 5 months ago

  • Target version changed from 11.2-U2 to 11.2-U3

I can't reproduce this problem(s) and there has not been any change in how the UI makes calls to the backend between RC2 and RELEASE. Do temperature graphs have data in reports section of the legacy UI? If not, this might not be a UI issue. Either way, we need more information so we can reproduce this issue. Changing target to U3

#10 Updated by Roger Hayter 5 months ago

N54L here, 11.2-RELEASE-U1

sysctl -a gives:

dev.cpu.1.temperature: 44.1C
dev.cpu.0.temperature: 44.1C

Legacy GUI reads approx 45 for CPU temp

New GUI gives CPU temp 31.6 (ignoring the bit where it drops to zero of course)

#11 Updated by Roger Hayter 5 months ago

OK, sorry, wrong bug!

#12 Updated by Patrik Kernstock 4 months ago

I can reproduce this on the latest 11.2-U2 version. No disk temperatures being shown on new UI in the Dashboard nor in the legacy UI.

The disks I have in use:
- Western Digital Red 1 TB/4 TB/ 10 TB
- Samsung SSD 850 EVO 250GB
- Samsung SSD 850 PRO 256GB
- Samsung SSD 860 EVO
- SanDisk SDSSDRC032G

#13 Updated by Patrik Kernstock 4 months ago

I'm unsure what kind of magic has caused this, but when taking a look on Monday morning today, the temperatures are visible. Updated to 11.2-U2 on Saturday, no disk temperaturen visible and starting Monday I can finally see them. CPU/Bandwidth-widgets working now too. I assume any stats-related cronjob seems to run somewhen end of Sunday or early Monday to re-calculate the stats or so.

So, I'm sorry for pushing this ticket. However it indeed looks strange when all Dashboard widgets show absolutely no data for multiple days.

#14 Updated by Nick M 4 months ago

I had seen this issue as well but it seems to be working at the moment. I have no idea what fixed it.

#15 Updated by Dru Lavigne 4 months ago

  • Target version changed from 11.2-U3 to 11.2-U4

#16 Avatar?id=14398&size=24x24 Updated by Kris Moore 2 months ago

  • Status changed from In Progress to Closed

Also available in: Atom PDF