Project

General

Profile

Bug #62397

root: /usr/local/etc/rc.d/smartd-daemon: WARNING: /usr/local/etc/smartd.conf is not readable.

Added by Jason Prokopowich 8 months ago. Updated 6 months ago.

Status:
Closed
Priority:
No priority
Assignee:
Vladimir Vinogradenko
Category:
Middleware
Target version:
Severity:
New
Reason for Closing:
Cannot Reproduce
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

Upon upgrading from 11.1 U6 to 11.2 I received this,
Dec 6 14:59:54 storage root: /usr/local/etc/rc.d/smartd-daemon: WARNING: /usr/local/etc/smartd.conf is not readable.

I tried touching file and then modified that smart parameters for the drives. Still no go.

debug attached.

How do I generate the file.

History

#1 Updated by Dru Lavigne 8 months ago

  • Category changed from Services to Middleware
  • Assignee changed from Release Council to William Grzybowski

#2 Updated by William Grzybowski 8 months ago

  • Assignee changed from William Grzybowski to Vladimir Vinogradenko
  • Target version changed from Backlog to 11.2-U2

Vladimir, is the -d removable on the queue for U1 going to fix this?

#3 Updated by Jason Prokopowich 8 months ago

William Grzybowski wrote:

Vladimir, is the -d removable on the queue for U1 going to fix this?

I had that for options for the 2 USB boot devices but have since removed all the options to get it to work. Can you tell me how to generate the conf file please.

#4 Updated by Vladimir Vinogradenko 8 months ago

  • Status changed from Unscreened to Blocked
  • Reason for Blocked set to Waiting for feedback

Jason, please check if /usr/local/etc/smartd.conf is empty now.

Also please run midclt call etc.generate smartd and post output (if any). It will generate config, please check if it is empty.

Also please post /var/log/middlewared.log after you run the generator if it fails.

#5 Updated by Jason Prokopowich 8 months ago

Vladimir Vinogradenko wrote:

Jason, please check if /usr/local/etc/smartd.conf is empty now.

Also please run midclt call etc.generate smartd and post output (if any). It will generate config, please check if it is empty.

Also please post /var/log/middlewared.log after you run the generator if it fails.

1. the file exists but is empty

2. output,
root@freenas:~ # midclt call etc.generate smartd
null

root@freenas:~ # cat /usr/local/etc/smartd.conf
/dev/ada1 -d removable -n never -W 0,0,0 -m root -M exec /usr/local/www/freenasUI/tools/smart_alert.py

Am I going to have to run that manually when I make a change in the UI?

#6 Updated by Vladimir Vinogradenko 7 months ago

Jason, there is some bug that prevented SMART config generation on system startup.

Unfortunately middleware log in the debug you've provided does not include this bug's backtrace.

You can try repeating this by removing /usr/local/etc/smartd.conf and rebooting machine. If this file won't exist or would be empty after reboot, please attach your /var/log/middlewared.log here.

#7 Updated by Jason Prokopowich 7 months ago

  • File middlewared.log added

Vladimir Vinogradenko wrote:

Jason, there is some bug that prevented SMART config generation on system startup.

Unfortunately middleware log in the debug you've provided does not include this bug's backtrace.

You can try repeating this by removing /usr/local/etc/smartd.conf and rebooting machine. If this file won't exist or would be empty after reboot, please attach your /var/log/middlewared.log here.

So this is what I did,

1. renamed the /usr/local/etc/smartd.conf to /usr/local/etc/smartd.conf.bak
2. restarted
3. system didn't come up so I reset it
4. finally booted with the /usr/local/etc/smartd.conf created with the /usr/local/etc/smartd.conf.bak disappeared.

Log attached.

#8 Updated by Vladimir Vinogradenko 7 months ago

  • Status changed from Blocked to Closed
  • Reason for Closing set to Cannot Reproduce
  • Reason for Blocked deleted (Waiting for feedback)

Jason, sorry, looks like we are unable to repeat that behavior and understand why SMART config generation failed after upgrade. Feel free to reopen this issue if this happens again.

#9 Updated by Dru Lavigne 7 months ago

  • File deleted (debug-storage-20181206152146.tgz)

#10 Updated by Dru Lavigne 7 months ago

  • File deleted (middlewared.log)

#11 Updated by Dru Lavigne 7 months ago

  • Target version changed from 11.2-U2 to N/A
  • Private changed from Yes to No

#12 Updated by Ricardo Junior 7 months ago

Perhaps we should consider reopening this issue. Today I upgraded from 11.2-RC1 to 11.2-U1 and the smartd.conf file is gone. I noticed that in the first boot in the new BE the daemon goes up, and after subsequent reboots it will not get generated:

Jan 2 00:15:38 arquivos smartd2745: Device: /dev/ada1, SMART Usage Attribute: 190 Airflow_Temperature_Cel changed from 61 to 63
Jan 2 00:15:38 arquivos smartd2745: Device: /dev/ada1, SMART Usage Attribute: 194 Temperature_Celsius changed from 39 to 37
Jan 2 00:15:38 arquivos smartd2745: Device: /dev/ada0, SMART Usage Attribute: 194 Temperature_Celsius changed from 102 to 104

After the reboot when upgrading:

messages:Jan 2 00:39:40 arquivos root: /etc/rc: WARNING: /usr/local/etc/smartd.conf is not readable.

root@arquivos[/var/log]# uptime
1:04AM up 33 mins, 1 user, load averages: 1.04, 0.48, 0.36
root@arquivos[/var/log]# date
Wed Jan 2 01:05:00 -02 2019

#13 Updated by Jacob Quillen 7 months ago

  • Seen in changed from 11.2-RELEASE to 11.2-RELEASE-U1

I as well am having this issue after a fresh install of 11.2-RELEASE. It is still being reproduced after an update to 11.2-RELEASE-U1

[root@freenas ~]# service smartd onestart
/usr/local/etc/rc.d/smartd: WARNING: /usr/local/etc/smartd.conf is not readable.
/usr/local/etc/rc.d/smartd: WARNING: failed precmd routine for smartd
[root@freenas ~]#

#14 Updated by Dru Lavigne 6 months ago

Jacob: there are more fixes going into U2 (due out at end of month). If your issue persists after that update, please open a new ticket for investigation.

Also available in: Atom PDF