Project

General

Profile

Bug #62511

iocage does not update version info correctly

Added by Patrick M. Hausen 12 months ago. Updated 11 months ago.

Status:
Closed
Priority:
No priority
Assignee:
Brandon Schneider
Category:
Middleware
Target version:
Seen in:
Severity:
New
Reason for Closing:
Duplicate Issue
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

FreeNAS 11.2-RELEASE and a jail named "cloud", updating the jail from p4 to p6:

root@freenas-pmh:~ # uname -a
FreeBSD freenas-pmh.local 11.2-STABLE FreeBSD 11.2-STABLE #0 r325575+fc3d65faae6(freenas/11.2-stable): Wed Dec  5 15:08:42 EST 2018     root@nemesis.tn.ixsystems.com:/freenas-11.2-releng/freenas/_BE/objs/freenas-11.2-releng/freenas/_BE/os/sys/FreeNAS.amd64  amd64

root@freenas-pmh:~ # iocage get release cloud
11.2-RELEASE-p4
root@freenas-pmh:~ # iocage exec cloud freebsd-version
11.2-RELEASE-p4

root@freenas-pmh:~ # iocage stop cloud
[...]
root@freenas-pmh:~ # iocage update cloud
[...]
cloud has been updated successfully.
root@freenas-pmh:~ # iocage start cloud
[...]

root@freenas-pmh:~ # iocage get release cloud
11.2-RELEASE-p4
root@freenas-pmh:~ # iocage exec cloud freebsd-version
11.2-RELEASE-p6

Bug is propagated into the UI where the jail still shows with 11.2-RELEASE-p4 as the version.


Related issues

Is duplicate of FreeNAS - Bug #59442: Ensure iocage update correctly updates the release property with the patch levelDone

History

#1 Updated by Dru Lavigne 12 months ago

  • Assignee changed from Release Council to William Grzybowski

#2 Updated by Patrick M. Hausen 12 months ago

N.B. I tried to update the property manually, but that is not possible:

root@freenas-pmh:~ # iocage set release=11.2-RELEASE-p6 cloud
release cannot be changed by the user.

#3 Updated by William Grzybowski 12 months ago

  • Assignee changed from William Grzybowski to Brandon Schneider

Brandon, I believe this is a duplicate, can you verify, please?

#4 Updated by Brandon Schneider 12 months ago

  • Status changed from Unscreened to Closed
  • Reason for Closing set to Duplicate Issue

Yep, will be fixed in U1 :)

#5 Updated by Brandon Schneider 12 months ago

  • Is duplicate of Bug #60183: iocage update does not update "release" field in config.json added

#6 Updated by Dru Lavigne 11 months ago

  • Is duplicate of Bug #59442: Ensure iocage update correctly updates the release property with the patch level added

#7 Updated by Dru Lavigne 11 months ago

  • Is duplicate of deleted (Bug #60183: iocage update does not update "release" field in config.json )

#8 Updated by Dru Lavigne 11 months ago

  • Target version changed from Backlog to N/A

Also available in: Atom PDF