Project

General

Profile

Bug #62628

Fix ffmpeg issue that prevented transcoding with Emby and Plex plugins

Added by John Chen 9 months ago. Updated 7 months ago.

Status:
Done
Priority:
No priority
Assignee:
Martin Wilke
Category:
Plugins
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
No
Needs Doc:
No
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No
Tags:

Description

I haven't found plex log.
But on emby log, I found this
Shared object "libx264.so.152" not found, required by "libavcodec.so.58"

1544206014556.jpg (631 KB) 1544206014556.jpg John Chen, 12/07/2018 10:07 AM
44151

History

#1 Updated by Dru Lavigne 9 months ago

  • Assignee changed from Release Council to Martin Wilke
  • Target version changed from Backlog to 11.2-U2
  • Seen in set to 11.2-RELEASE

#2 Updated by Dru Lavigne 8 months ago

  • Category changed from Services to Plugins

#3 Updated by gerry the hat 8 months ago

I'm seeing the same error on emby: Shared object "libx264.so.152" not found, required by "libavcodec.so.58".

#4 Updated by Brian Hawley 8 months ago

I wanted to also confirm that this is an issue for me as well. I use emby on freenas very heavily and any newer version past 3.2 on freenas 11.1 stopped working due to many libraries not being installed for ffmpeg to function. Luckily, I happen to have a copy from the 3.2 plugin to copy over from a warden jail, but this effectively makes emby useless with out them.

I can't imagine that this only has been noticed by the handful of people here. The following is the ffmpeg version, config and libraries needed for the package:

ffmpeg version 4.0.2-emby_2018_09_13 Copyright (c) 2000-2018 the FFmpeg developers
built with gcc 6.4.0 (FreeBSD Ports Collection)
configuration: --cc=gcc --arch=x86_64 --prefix=/usr/home/embybuilder/Buildbot/x64_freebsd/ffmpeg-x64_freebsd/staging --pkg-config=pkg-config --disable-doc --disable-ffplay --disable-vdpau --disable-xlib --enable-fontconfig --enable-gnutls --enable-gpl --enable-iconv --enable-libass --enable-libfreetype --enable-libfribidi --enable-libmp3lame --enable-libopus --enable-libtheora --enable-libvorbis --enable-libwebp --enable-libx264 --enable-libzvbi --enable-version3 --disable-decoders --disable-encoders --enable-decoder=aac --enable-decoder=aac_fixed --enable-decoder=aac_latm --enable-decoder=ac3 --enable-decoder=ac3_fixed --enable-decoder=alac --enable-decoder=apng --enable-decoder=ass --enable-decoder=ayuv --enable-decoder=bmp --enable-decoder=dca --enable-decoder=dirac --enable-decoder=dvbsub --enable-decoder=dvdsub --enable-decoder=eac3 --enable-decoder=flac --enable-decoder=gif --enable-decoder=h264 --enable-decoder=hevc --enable-decoder=huffyuv --enable-decoder=mjpeg --enable-decoder=mlp --enable-decoder=mov_text --enable-decoder=mp3 --enable-decoder=mp3float --enable-decoder=mpeg4 --enable-decoder=opus --enable-decoder=pcm_alaw --enable-decoder=pcm_bluray --enable-decoder=pcm_dvd --enable-decoder=pcm_f16le --enable-decoder=pcm_f24le --enable-decoder=pcm_f32be --enable-decoder=pcm_f32le --enable-decoder=pcm_f64be --enable-decoder=pcm_f64le --enable-decoder=pcm_lxf --enable-decoder=pcm_mulaw --enable-decoder=pcm_s16be --enable-decoder=pcm_s16be_planar --enable-decoder=pcm_s16le --enable-decoder=pcm_s16le_planar --enable-decoder=pcm_s24be --enable-decoder=pcm_s24daud --enable-decoder=pcm_s24le --enable-decoder=pcm_s24le_planar --enable-decoder=pcm_s32be --enable-decoder=pcm_s32le --enable-decoder=pcm_s32le_planar --enable-decoder=pcm_s64be --enable-decoder=pcm_s64le --enable-decoder=pcm_s8 --enable-decoder=pcm_s8_planar --enable-decoder=pcm_u16be --enable-decoder=pcm_u16le --enable-decoder=pcm_u24be --enable-decoder=pcm_u24le --enable-decoder=pcm_u32be --enable-decoder=pcm_u32le --enable-decoder=pcm_u8 --enable-decoder=pcm_zork --enable-decoder=pgssub --enable-decoder=png --enable-decoder=r210 --enable-decoder=rawvideo --enable-decoder=ssa --enable-decoder=subrip --enable-decoder=srt --enable-decoder=text --enable-decoder=theora --enable-decoder=truehd --enable-decoder=v210 --enable-decoder=v210x --enable-decoder=v308 --enable-decoder=v408 --enable-decoder=v410 --enable-decoder=vorbis --enable-decoder=vp8 --enable-decoder=vp9 --enable-decoder=webp --enable-decoder=webvtt --enable-decoder=wmalossless --enable-decoder=wmapro --enable-decoder=wmav1 --enable-decoder=wmav2 --enable-decoder=wmavoice --enable-decoder=wmv1 --enable-decoder=wmv2 --enable-decoder=wmv3 --enable-decoder=wmv3image --enable-decoder=y41p --enable-decoder=yuv4 --enable-decoder=zero12v --enable-encoder=aac --enable-encoder=ac3 --enable-encoder=ac3_fixed --enable-encoder=ass --enable-encoder=dvbsub --enable-encoder=dvdsub --enable-encoder=flac --enable-encoder=libmp3lame --enable-encoder=libopus --enable-encoder=libtheora --enable-encoder=libvorbis --enable-encoder=libwebp --enable-encoder=libx264 --enable-encoder=mjpeg --enable-encoder=mov_text --enable-encoder=png --enable-encoder=srt --enable-encoder=ssa --enable-encoder=subrip --enable-encoder=text --enable-encoder=webvtt --enable-libsmbclient --enable-decoder=mp1 --enable-decoder=mp2 --enable-decoder=mpegvideo --enable-decoder=mpeg1video --enable-decoder=mpeg2video --enable-decoder=vc1 --enable-vaapi --enable-encoder=h264_vaapi --enable-encoder=hevc_vaapi --enable-encoder=mjpeg_vaapi --enable-shared --disable-static
libavutil 56. 14.100 / 56. 14.100
libavcodec 58. 18.100 / 58. 18.100
libavformat 58. 12.100 / 58. 12.100
libavdevice 58. 3.100 / 58. 3.100
libavfilter 7. 16.100 / 7. 16.100
libswscale 5. 1.100 / 5. 1.100
libswresample 3. 1.100 / 3. 1.100
libpostproc 55. 1.100 / 55. 1.100

#5 Updated by Daniel H 8 months ago

Okay I ran into this issue too, sadly no easy fix in sight atm.
But, I found this on the FreeBSD bugtracker: https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=232935 (hope links are allowed here) maybe this can help?
What I was abel to extrapolate out of that issue on the FreeBSD Bugzilla is that the emby port was build against the wrong "branch" (sorry new to BSD)

System INFO:

OS_Version:      11.2-RELEASE-U1
Plugin:          emby
Plugin_Version:  3.5.3.0
Plugin_Release:  11.2-RELEASE-p7

EDITs:
1# - added sys-info

#7 Updated by Martin Wilke 8 months ago

Hi,

Thank you for your feedback, can u please login to your jail and give me the output of find / -name 'libx264*'

thanks.

#8 Updated by Daniel H 8 months ago

Hi Martin,

sure can do!

# find / -name 'libx264*'
/var/cache/pkg/libx264-0.155.2917.txz
/var/cache/pkg/libx264-0.155.2917-28b627aacd.txz
/usr/local/share/licenses/libx264-0.155.2917
/usr/local/lib/libx264.a
/usr/local/lib/libx264.so.155
/usr/local/lib/libx264.so
#

hope this helps

#9 Updated by Martin Wilke 8 months ago

Hi Daniel,

Thanks at least I have a idea. I will get back on that tomorrow.

#10 Updated by Dru Lavigne 7 months ago

  • Target version changed from 11.2-U2 to 11.2-U3

#11 Updated by gerry the hat 7 months ago

Martin Wilke wrote:

Hi Daniel,

Thanks at least I have a idea. I will get back on that tomorrow.

As 'tomorrow' is the day before yesterday..., could you please share your idea so that one could build his / her own workaround? Unfortunately this ticket seems to be postponed to an uncertain point in time in the future.

#12 Updated by Brian Hawley 7 months ago

I got Emby to work by manually building the missing libraries using the ports. Eventually, I hit a brick wall when trying to get it to work and just copied the missing libraries over from the last working version 3.2 in warden.
ldd /usr/local/lib/emby-server/bin/ffmpeg is your best friend to figure out what is missing.
When 3.6 is released soon, I'll come back and post the instructions on how to do this from beginning to end.
I'm hopeful that future versions will include more support that has been removed or left behind in 11.1.

#14 Updated by Dru Lavigne 7 months ago

  • Status changed from Unscreened to In Progress
  • Target version changed from 11.2-U3 to 11.2-U2

#15 Updated by Dru Lavigne 7 months ago

  • Subject changed from It can't transcode on plex & emby to Fix ffmpeg issue that prevented transcoding with Emby plugin

#16 Updated by Dru Lavigne 7 months ago

PR for Plex is in progress.

#17 Updated by Martin Wilke 7 months ago

  • Status changed from In Progress to Ready for Testing

Hi,

Sorry for the delay,

for the emby plugin, the LD_LIBRARY_EXPORT part in the rc.d script is not working as intended, i have added a workaround described here https://emby.media/community/index.php?/topic/65471-freenas-iocage-plugin-emby-3530-ffmpeg-solution/ which fix the issue for now.

For plexmediaserver and plexmediaserver-plexpass on existing installation the solution is to edit the rc.d script as below:
Login to your jail and go to /usr/local/etc/rc.d/ and edit the file plexmediaserver(-plexpass),
now search for export LD_LIBRARY_PATH="/usr/local/lib/compat:${SCRIPTPATH}" and replace it with export LD_LIBRARY_PATH="${SCRIPTPATH}"
after that restart plexmediaserver(-plexpass).

A new plugin installation will have that fix included.

#18 Updated by Dru Lavigne 7 months ago

  • Subject changed from Fix ffmpeg issue that prevented transcoding with Emby plugin to Fix ffmpeg issue that prevented transcoding with Emby and Plex plugins
  • Needs Doc changed from Yes to No
  • Needs Merging changed from Yes to No

#21 Updated by Cao Pham 7 months ago

The H264 codec works for me on the latest Plex version (1.14.1.5488 and FreeNAS 11.2-U1), is anyone still encountering issues or is it a different one?

#22 Updated by Dru Lavigne 7 months ago

  • Status changed from Ready for Testing to Done
  • Needs QA changed from Yes to No

#23 Updated by gerry the hat 7 months ago

The pull requests are only about Plex, what's about Emby? The title and discussion in this very ticket implies a problem for Emby as well.

#24 Updated by Martin Wilke 7 months ago

Hi Gerry,

Emby was fixed slight different from plex. I am sorry I did forget to update the ticket for that commit.

commit:
https://github.com/freenas/iocage-plugin-emby/pull/1

- Martin

#25 Updated by gerry the hat 7 months ago

Cool, thanks for pointing that out.

#26 Updated by Disk Didler 7 months ago

Didn't I read Emby is going to some proprietary model?

Sadly, maybe time for yet another plugin to be made? Anyone?

https://www.reddit.com/r/emby/comments/a545g9/annoucing_jellyfin_a_free_software_fork_of_emby/?st=jrhf10zq&sh=c03d88b3

#27 Updated by Dru Lavigne 7 months ago

Yes. #70842 is currently on hold until we have a chance to investigate further.

Also available in: Atom PDF