Project

General

Profile

Bug #62766

Creating a jail in the 11.2 UI does not show after being created

Added by Mohammed Mohammed almost 3 years ago. Updated almost 3 years ago.

Status:
Done
Priority:
No priority
Assignee:
Brandon Schneider
Category:
Middleware
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
No
Needs Doc:
No
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No
Tags:

Description

After creating the jail in the UI, the jail will not show in the UI. I've tried about a dozen times, and only one of the jails showed up. I'm not sure what caused it to show up. I tried to replicate it, but could not.

I upgraded to 11.2 from 11.1-U6. To further debug this, I SSH'd into my system and ran iocage df and saw that the jails were created. They're just not appearing in the UI.

I've tried restarting the system multiple times as well.


Related issues

Copied to FreeNAS - Bug #63522: Catch iocage subprocess exceptionDone

Associated revisions

Revision 348ccdcf (diff)
Added by Brandon Schneider almost 3 years ago

fix(jail/query): Catch subprocess exception If the user has some interface issue, this would have halted all jails being returned. Ticket: #62766

Revision 1e3e8186 (diff)
Added by Brandon Schneider almost 3 years ago

fix(jail/query): Catch subprocess exception If the user has some interface issue, this would have halted all jails being returned. Ticket: #62766

Revision 70db01c3 (diff)
Added by Brandon Schneider almost 3 years ago

fix(jail/query): Catch subprocess exception (#2244) If the user has some interface issue, this would have halted all jails being returned. Ticket: #62766

Revision 83340054 (diff)
Added by Brandon Schneider almost 3 years ago

fix(jail/query): Catch subprocess exception If the user has some interface issue, this would have halted all jails being returned. Ticket: #62766 (cherry picked from commit 1e3e81866aa4d7208c80a749f83cbc5b0ea0c4c0)

Revision 7b811934 (diff)
Added by Bug Clerk almost 3 years ago

fix(jail/query): Catch subprocess exception (#2246) If the user has some interface issue, this would have halted all jails being returned. Ticket: #62766 (cherry picked from commit 1e3e81866aa4d7208c80a749f83cbc5b0ea0c4c0)

History

#1 Updated by Mohammed Mohammed almost 3 years ago

Please let me know if you need any further information.

Found this log after creating a jail:

[2018/12/08 07:10:14] (INFO) iocage.callback():54 - unifi2 successfully created!
[2018/12/08 07:10:14] (DEBUG) JailService.query():91 - Failed to get list of jails
Traceback (most recent call last):
  File "/usr/local/lib/python3.6/site-packages/middlewared/plugins/jail.py", line 80, in query
    out = su.check_output(ip4_cmd)
  File "/usr/local/lib/python3.6/subprocess.py", line 336, in check_output
    **kwargs).stdout
  File "/usr/local/lib/python3.6/subprocess.py", line 418, in run
    output=stdout, stderr=stderr)
subprocess.CalledProcessError: Command '['jexec', 'ioc-unifi', 'ifconfig', 'epair0b', 'inet']' returned non-zero exit st
atus 1.
[2018/12/08 07:10:29] (DEBUG) JailService.query():91 - Failed to get list of jails
Traceback (most recent call last):
  File "/usr/local/lib/python3.6/site-packages/middlewared/plugins/jail.py", line 80, in query
    out = su.check_output(ip4_cmd)
  File "/usr/local/lib/python3.6/subprocess.py", line 336, in check_output
    **kwargs).stdout
  File "/usr/local/lib/python3.6/subprocess.py", line 418, in run
    output=stdout, stderr=stderr)
subprocess.CalledProcessError: Command '['jexec', 'ioc-unifi', 'ifconfig', 'epair0b', 'inet']' returned non-zero exit st
atus 1.
[2018/12/08 07:10:34] (DEBUG) JailService.query():91 - Failed to get list of jails
Traceback (most recent call last):

#2 Updated by Mohammed Mohammed almost 3 years ago

Upon further inspection, I'm wondering whether that error has to do with the pre-existing jail that I had created in 11.1 using iocage via terminal via SSH. The jail is based on 11.1-RELEASE-p6. The jail runs fine and is named UniFi (with that exact capitalization). I've tried upgrading it via iocage using iocage upgrade -r 11.2-RELEASE UniFi and it tells me jail 'unifi' not found!. Is it because of the capitalization?

#3 Updated by Mohammed Mohammed almost 3 years ago

My intuition was right. The issue was the pre-existing jail. I deleted it because it didn't let me upgrade it. I'm not sure if it was due to the uppercase letters or something else.

#4 Updated by Dru Lavigne almost 3 years ago

  • Category changed from GUI (new) to Middleware
  • Assignee changed from Release Council to William Grzybowski

#5 Updated by William Grzybowski almost 3 years ago

  • Assignee changed from William Grzybowski to Brandon Schneider

Brandon, is there something we can do here? Is the jail skipped if there is an error so we get a list of the remaining ones?

#6 Updated by Brandon Schneider almost 3 years ago

Yeah I'll have to investigate the capitalization, that's a weird issue. But on a base exception like that we log it and it should continue.

#7 Updated by Brandon Schneider almost 3 years ago

  • Status changed from Unscreened to Not Started

#8 Updated by Bug Clerk almost 3 years ago

  • Status changed from Not Started to In Progress

#9 Updated by Bug Clerk almost 3 years ago

  • Status changed from In Progress to Ready for Testing

#10 Updated by Bug Clerk almost 3 years ago

  • Target version changed from Backlog to 11.3

#11 Updated by Bug Clerk almost 3 years ago

  • Copied to Bug #63522: Catch iocage subprocess exception added

#12 Updated by Brandon Schneider almost 3 years ago

Mohammed: I couldn't reproduce the capitalization issue you experienced, naming a jail and trying to upgrade it worked for me.

root@freenas[~]# iocage create -n UniFi -r 11.1-RELEASE
UniFi successfully created! 

root@freenas[~]# iocage upgrade -r 11.2-RELEASE UniFi
Looking up update.FreeBSD.org mirrors... 2 mirrors found.
Fetching metadata signature for 11.1-RELEASE from update1.FreeBSD.org... done.
Fetching metadata index... done.
Fetching 1 metadata files... done.
^C
Aborted!

#13 Updated by Dru Lavigne almost 3 years ago

  • Status changed from Ready for Testing to Done
  • Target version changed from 11.3 to Master - FreeNAS Nightlies
  • Needs QA changed from Yes to No
  • Needs Doc changed from Yes to No
  • Needs Merging changed from Yes to No

#15 Updated by Mohammed Mohammed almost 3 years ago

Thank you for the PR fix. It's hard for me to dig more into the issue since I had deleted the problematic jail in order to resolve the issue, but your changes will at least allow users to create another jail and move the setup to that jail before having to delete the problematic one.

Also available in: Atom PDF