Project

General

Profile

Bug #63360

Make use of new middleware reporting of train descriptions in new UI

Added by Eric Loewenthal 10 months ago. Updated 9 months ago.

Status:
Done
Priority:
No priority
Assignee:
Dennis Mullen
Category:
GUI (new)
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
No
Needs Doc:
No
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

As the title says, when trying to upgrade to 11.2-Release from an RC, the GUI thinks it's still not a Release version.

I saw this myself and other users have reported it (example: https://forums.freenas.org/index.php?threads/freenas-11-2-release-has-arrived.71699/post-497736).


Related issues

Related to FreeNAS - Bug #61254: Remove pre-production warning for 11.2-RELEASEDone
Related to FreeNAS - Feature #39977: Revise update page in new UI Done
Related to FreeNAS - Bug #65589: Train descriptions get overwritten when the UI needs them mostDone
Related to FreeNAS - Bug #68493: Have middleware use description from trains.txtDone
Is duplicate of FreeNAS - Bug #63636: Delay initial check for updates til necessary values are filled in new UIDone

History

#1 Updated by Dru Lavigne 10 months ago

  • Assignee changed from Release Council to Erin Clark
  • Target version changed from Backlog to 11.2-U2

#3 Updated by Erin Clark 10 months ago

Could you please provide a screenshot?

#4 Updated by Eric Loewenthal 10 months ago

It's the same warning that was (correctly) shown for upgrades to -RC1 and -RC2. I can rollback and capture it if you need it.

#5 Updated by Eric Loewenthal 10 months ago

44952

D'oh, I forgot I'd taken a screencap before upgrading, for a future bug report if anyone else complained about the message. Image attached.

#6 Updated by Erin Clark 10 months ago

  • Assignee changed from Erin Clark to Vaibhav Chauhan

I believe VB took care of this prior to the 11.2 release however it was not in the 11.2-RC so RC will still say that no matter what we do, is this correct?

#7 Updated by Vaibhav Chauhan 10 months ago

  • Status changed from Unscreened to Blocked
  • Reason for Blocked set to Need verification

#9 Updated by Dru Lavigne 10 months ago

  • Related to Bug #61254: Remove pre-production warning for 11.2-RELEASE added

#10 Updated by Dru Lavigne 10 months ago

#12 Updated by Dru Lavigne 10 months ago

  • Status changed from Blocked to Unscreened
  • Reason for Blocked deleted (Need verification)

#13 Updated by Vaibhav Chauhan 10 months ago

  • Assignee changed from Vaibhav Chauhan to Dennis Mullen

Dennis worked more on update page than I did in recent times, so passing on to him.

#14 Updated by Dennis Mullen 10 months ago

When the UI makes the api call to get trains, it gets back the list below. The problem is that the train description, which contains the tag [release], [pre-release] or [nightly] gets overwritten by the text 'Installed OS' in whichever branch you are currently on, which is the very branch we need to read the tag from. I will file a ticket. I can't think of another reliable way to know for sure to get that tag that we need.

{"trains": {
...
"FreeNAS-11-Nightlies-SDK": {"description": "Nightly SDK builds for FreeNAS 11. Very unstable, even ISO installs are not guaranteed to work. [nightly]", "sequence": null},
"FreeNAS-11-STABLE": {"description": "Release Train for FreeNAS 11.1 [release]", "sequence": null},
"FreeNAS-11.2-STABLE": {"description": "Installed OS", "sequence": "63e5b1280ef0b8d882194a8a85d19665"}},
"current": "FreeNAS-11.2-STABLE",
"selected": "FreeNAS-11.2-STABLE"
}

#15 Updated by Dennis Mullen 10 months ago

  • Status changed from Unscreened to In Progress

#16 Updated by Dennis Mullen 10 months ago

  • Related to Bug #65589: Train descriptions get overwritten when the UI needs them most added

#17 Updated by Erin Clark 9 months ago

  • Status changed from In Progress to Ready for Testing

#18 Updated by Dru Lavigne 9 months ago

  • Is duplicate of Bug #63636: Delay initial check for updates til necessary values are filled in new UI added

#19 Updated by Dru Lavigne 9 months ago

  • Status changed from Ready for Testing to Closed
  • Target version changed from 11.2-U2 to N/A
  • Reason for Closing set to Duplicate Issue

Eric: the fix for this issue will appear on #63636.

#20 Updated by Dru Lavigne 9 months ago

  • Related to Bug #68493: Have middleware use description from trains.txt added

#21 Updated by Dru Lavigne 9 months ago

  • Status changed from Closed to In Progress
  • Target version changed from N/A to 11.2-U3
  • Reason for Closing deleted (Duplicate Issue)

#23 Updated by Dru Lavigne 9 months ago

  • Target version changed from 11.2-U3 to 11.2-U2

#24 Updated by Dru Lavigne 9 months ago

  • Subject changed from Upgrades from 11.2-RC2 to 11.2-Release are marked as not for production in the GUI to Make use of new middleware reporting of train descriptions in new UI
  • Status changed from In Progress to Ready for Testing
  • Needs Doc changed from Yes to No
  • Needs Merging changed from Yes to No

#25 Updated by Dennis Mullen 9 months ago

Testing: On the update page, all the warning / Notes boxes should be appropriate to the currently selected train. If you change selections, the boxes should update. Production releases should not be labeled pre-production and vice versa.

#27 Updated by Jeff Ervin 9 months ago

51960
51969
51978

Test Passed FreeNAS-11.2-U2-INTERNAL81

#28 Updated by Dru Lavigne 9 months ago

  • Status changed from Passed Testing to Done

Also available in: Atom PDF