Project

General

Profile

Bug #63450

Bug #41676

Added by Stefano T 8 months ago. Updated 7 months ago.

Status:
Closed
Priority:
No priority
Assignee:
Alexander Motin
Category:
OS
Target version:
Seen in:
Severity:
New
Reason for Closing:
Cannot Reproduce
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

As requested by Dru Lavigne in the forum

https://redmine.ixsystems.com/issues/41676


Related issues

Related to FreeNAS - Bug #41676: FreeNAS 11.2-Beta2 unable to bootClosed

History

#1 Updated by Stefano T 8 months ago

  • File debug-nas1-20181211183446.txz added
  • Private changed from No to Yes

#2 Updated by Dru Lavigne 8 months ago

  • Related to Bug #41676: FreeNAS 11.2-Beta2 unable to boot added

#3 Updated by Dru Lavigne 8 months ago

  • Category changed from Build system to OS
  • Assignee changed from Release Council to Alexander Motin

#5 Updated by Alexander Motin 8 months ago

  • Status changed from Unscreened to Blocked
  • Seen in changed from 11.1-U6 to 11.2-RELEASE
  • Reason for Blocked set to Need additional information from Author

Hi Stefano,

I am failing to correlate your comment "i would to say that from 11.1U6 thru the 11.2RC2 doing the "in place" upgrade from the web interface, the system started well ... after the upgrade to the 11.2 STABLE the system does not boot anymore." with topic of that ticket "FreeNAS 11.2-Beta2 unable to boot". RC2 was released after BETA2, so here is some inconsistency. If you was ever able to boot 11.2 on your hardware in this, as I understand, UEFI mode, what was exactly the version it stopped working? It could help us to localize the related change set, since otherwise hang without any messages is not very helpful.

#6 Updated by Stefano T 8 months ago

Hi Alexander,

Yes, i can confirm that from 11.1U6 to 11.2RC2 the system started ... the system was upgraded in place (exactly as from 11.2RC2 to 11.2STABLE).
During the upgrade from 11.1U6 to 11.2RC2 i've received a lot of error and i crossed my finger but the system started. I don't remember if with all these error, the bootloader on 11.2RC2 it is left Grub or was replaced with the freebsd bootloader.
On the second upgrade (to the stable) i was calm but the system don't started anymore and here i'm sure that the new bootloader of freebsd take in place.
To answer at your question, also with the 11.1U6 the system booted with UEFI. I've always UEFI active in this system. IMHO the problem with 11.2 it's not on UEFI. The booloader start and i can select also many option (none of them worked). The problem is when the system start loading the kernel because hang with the message

Booting...
Start @ 0xffffffff8031e000 ...
EFI framebuffer Information:
addr, size       0xd0000000, 0x3ff0000
dimensions       800x600
stride           800
masks 0x00ff0000, 0x0000ff00, 0x000000ff, 0xff000000

don't be fooled by the message "EFI framebuffer Information", here the EFI has already started correctly the new freebsd bootloader and the problem is in this stage.
I suppose that if i upgrade the system to 11.2STABLE this hang again (already tried), but if i try to replace the bootloader with grub the system start ... i haven't tried this but i'm sure that this can work.
The version that stopped working is the 11.2STABLE. I've worked flawless some days with the 11.2RC2 and i've also the backup done on 11.2RC2 that i hope to restore on 11.2STABLE when i'm able to upgrade and boot this version.

PS: i've correlated the problem to the ticket ""FreeNAS 11.2-Beta2 unable to boot" because searching the message where the system hang, i've found that someone with the same hardware have already had the same error and it was naturally for me add +1 to this ticket. The problem was the same and wasn't resolved ... i hoped that supplying the debug trace you was able to solve the problem.

I'm at your disposal for further investigation or try

Thank you for your support

#7 Updated by Alexander Motin 8 months ago

It would be great if you could try fresh installation of RC2 and RELEASE on some other media to confirm the issue and narrow down the time window. Between RC2 and RELEASE were only few OS changes, and only one I could even slightly to pull to this.

#8 Updated by Alexander Motin 7 months ago

  • Status changed from Blocked to Closed
  • Target version changed from Backlog to N/A
  • Reason for Closing set to Cannot Reproduce
  • Reason for Blocked deleted (Need additional information from Author)

Closing this on lack of ideas and input.

#9 Updated by Dru Lavigne 7 months ago

  • File deleted (debug-nas1-20181211183446.txz)

#10 Updated by Dru Lavigne 7 months ago

  • Private changed from Yes to No

Also available in: Atom PDF