Project

General

Profile

Bug #63600

Wrong default column width of Name column in snapshot list.

Added by F. Unger 7 months ago. Updated 6 months ago.

Status:
Closed
Priority:
No priority
Assignee:
Dennis Mullen
Category:
GUI (new)
Target version:
Seen in:
Severity:
New
Reason for Closing:
Duplicate Issue
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

The Name column is far too small in the default. The names are clipped, while column contents of most other columns have plenty reserve white space. Resize is possibly (although fiddly). See attached screen shots.


Related issues

Is duplicate of FreeNAS - Bug #48295: Use visible resize handles and min/max column sizes in new UIDone

History

#1 Updated by F. Unger 7 months ago

  • Seen in set to 11.2-RELEASE

#2 Updated by Dru Lavigne 7 months ago

  • Assignee changed from Release Council to Erin Clark
  • Target version changed from Backlog to 11.2-U2

#3 Updated by Erin Clark 7 months ago

We should experiment with this fluid row height on ngx-datatable: https://swimlane.github.io/ngx-datatable/#

#4 Updated by F. Unger 7 months ago

fluid row height is apparently already in use in the Pools view. But this topic is about column width, not row height! Having line breaks and higher columns would at least show all information but this would be a very ugly solution. The pools view is a good example for such a bad solution (comments column ...)

A correct solution determines an optimum layout in terms of column widths taking possible line breaks in the consideration. Please compare this to the automatic table sizing feature of Word.

I expect a table component to offer this feature.

#5 Updated by Erin Clark 7 months ago

it turns out wrapping it doesn't work with the infinite scroll anyway, we'll have to explore ways to resize the column widths or something

#6 Updated by Erin Clark 7 months ago

  • Assignee changed from Erin Clark to Dennis Mullen

#8 Updated by Erin Clark 6 months ago

  • Status changed from Unscreened to Closed
  • Reason for Closing set to Duplicate Issue

This ticket is a duplicate of https://redmine.ixsystems.com/issues/48295, we will continue investigating ways to make column widths adjust better for sections like this in the fix for that ticket.

#9 Updated by Erin Clark 6 months ago

  • Is duplicate of Bug #48295: Use visible resize handles and min/max column sizes in new UI added

#10 Updated by Dru Lavigne 6 months ago

  • Target version changed from 11.2-U2 to N/A

Also available in: Atom PDF