Project

General

Profile

Bug #63810

Check iocage release exists before destroying it

Added by Waqar Ahmed about 1 year ago. Updated 10 months ago.

Status:
Done
Priority:
No priority
Assignee:
Waqar Ahmed
Category:
Middleware
Target version:
Severity:
Low Medium
Reason for Closing:
Reason for Blocked:
Needs QA:
No
Needs Doc:
No
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

In iocage before destroying a release, we should check if it exists or not and then destroy it. Right now we don't raise an appropriate exception for this case which indirectly implies that the specified release was destroyed as intended

root@freenas[~]# iocage destroy -f -r asdf asdf adsf 
Destroying RELEASE dataset: asdf
Destroying RELEASE dataset: asdf
Destroying RELEASE dataset: adsf

Risk
We risk breaking destroying of releases

Acceptance Criteria
This case should be verified that we raise an appropriate exception if illegal release is specified and it should be verified that releases are still destroyable.

History

#1 Updated by Waqar Ahmed about 1 year ago

  • Status changed from Not Started to In Progress

#2 Updated by Waqar Ahmed about 1 year ago

  • Status changed from In Progress to Ready for Testing

#3 Updated by Dru Lavigne 12 months ago

  • Target version changed from 11.3 to 11.3-BETA1

#4 Updated by Dru Lavigne 12 months ago

  • Subject changed from Check release exists before destroying it to Check iocage release exists before destroying it
  • Needs Doc changed from Yes to No
  • Needs Merging changed from Yes to No

#7 Avatar?id=55038&size=24x24 Updated by Zackary Welch 10 months ago

  • Status changed from Ready for Testing to Passed Testing
  • Needs QA changed from Yes to No

Confirmed fixed in 11.3-BETA1.

#8 Updated by Dru Lavigne 10 months ago

  • Status changed from Passed Testing to Done

#10 Updated by Dru Lavigne 10 months ago

  • Target version changed from 11.3-BETA1 to 11.3-ALPHA1

Also available in: Atom PDF