Project

General

Profile

Bug #65013

Ignore utf-8 decoding errors that prevent SMART service from starting

Added by Damien Myracle almost 3 years ago. Updated over 2 years ago.

Status:
Done
Priority:
No priority
Assignee:
Vladimir Vinogradenko
Category:
Middleware
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
No
Needs Doc:
No
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

System was running version 11.1 update6.
smartd service was running as expected, no issues.
OS was upgraded via UI to 11.2 stable train.
After upgrade was finished and server restarted, smartd-daemon fails to start.
Corresponding message in log: root: /usr/local/etc/rc.d/smartd-daemon: WARNING: /usr/local/etc/smartd.conf is not readable.

When SMART service is enabled in UI, it fails to start and the message above is repeated.

Please let me know what other info is needed for diagnostics.

Thank you FreeNAS Dev team for work that you do.

DM


Related issues

Copied to FreeNAS - Bug #75667: smartd-daemon fails to start after upgrade from 11.1 to 11.2Done

History

#1 Updated by Dru Lavigne almost 3 years ago

  • Private changed from No to Yes
  • Reason for Blocked set to Need additional information from Author

Damien: please attach a debug (System -> Advanced -> Save debug) to this ticket.

#2 Updated by Dru Lavigne almost 3 years ago

  • Status changed from Unscreened to Blocked

#3 Updated by Damien Myracle almost 3 years ago

  • File debug-nas01-20181219125051.tgz added

Dru Lavigne wrote:

Damien: please attach a debug (System -> Advanced -> Save debug) to this ticket.

Hello Mr. Lavigne, as you requested, file - debug-nas01-20181219125051.tgz generated and attached to this ticket.
Could you please ask to keep the content of the debug file private for your internal review for diagnostics purposes only as well as this ticket while debug file attached to it.
Once you no longer need the debug file attached to the ticket and it is removed, if it is possible, let's make this ticket public so other users can benefit if solution to the issue is found.
Thank you for your help and development efforts.

DM

#4 Updated by Dru Lavigne almost 3 years ago

  • Assignee changed from Release Council to William Grzybowski
  • Reason for Blocked deleted (Need additional information from Author)

Yup, that's our process wrt debug files :-)

#5 Updated by William Grzybowski almost 3 years ago

  • Category changed from Services to Middleware
  • Status changed from Blocked to Unscreened
  • Assignee changed from William Grzybowski to Vladimir Vinogradenko

#7 Updated by Bug Clerk over 2 years ago

  • Status changed from Unscreened to In Progress

#8 Updated by Bug Clerk over 2 years ago

  • Status changed from In Progress to Ready for Testing

#9 Updated by Bug Clerk over 2 years ago

  • Copied to Bug #75667: smartd-daemon fails to start after upgrade from 11.1 to 11.2 added

#10 Updated by Dru Lavigne over 2 years ago

  • File deleted (debug-nas01-20181219125051.tgz)

#11 Updated by Dru Lavigne over 2 years ago

  • Subject changed from smartd-daemon fails to start after upgrade from 11.1 to 11.2 to Ignore utf-8 decoding errors that prevent SMART service from starting
  • Private changed from Yes to No
  • Needs Doc changed from Yes to No
  • Needs Merging changed from Yes to No

#12 Updated by Vladimir Vinogradenko over 2 years ago

  • Needs QA changed from Yes to No

Can't really be tested

#13 Updated by Dru Lavigne over 2 years ago

  • Status changed from Ready for Testing to Done
  • Target version changed from Backlog to 11.2-U3

Also available in: Atom PDF