Project

General

Profile

Bug #65043

Avatar?id=14398&size=50x50 Avatar?id=14398&size=22x22

Change OpenSSL dhparam usage to work on OpenSSL 1.0 and newer

Added by Kris Moore 11 months ago. Updated 7 months ago.

Status:
Done
Priority:
No priority
Assignee:
Kris Moore
Category:
Middleware
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
No
Needs Doc:
No
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

In 12.0 and systems that use newer openssl 1.1.1 we need to change some CLI usage of openssl command when generating the initial dhparam.pem file.

Associated revisions

Revision 78154cba (diff)
Added by Kris Moore 11 months ago

Change openssl dhparam usage so it works on both OpenSSL 1.0 and newer 1.1 standard Ticket: #65043

History

#1 Avatar?id=14398&size=24x24 Updated by Kris Moore 11 months ago

  • Status changed from In Progress to Ready for Testing
  • Target version changed from Backlog to 11.3

#2 Updated by Dru Lavigne 11 months ago

#3 Updated by Dru Lavigne 10 months ago

  • Subject changed from Fix OpenSSL > 1.1 usage with generating dhparam.pem to Change Open dhparam usage so it works on both OpenSSL 1.0 and newer

#4 Updated by Dru Lavigne 10 months ago

  • Subject changed from Change Open dhparam usage so it works on both OpenSSL 1.0 and newer to Change Open dhparam usage so it works on OpenSSL 1.0 and newer

#5 Updated by Dru Lavigne 10 months ago

  • Subject changed from Change Open dhparam usage so it works on OpenSSL 1.0 and newer to Change Open dhparam usage to work on OpenSSL 1.0 and newer

#6 Updated by Dru Lavigne 10 months ago

  • Target version changed from 11.3 to 11.3-BETA1

#7 Avatar?id=14398&size=24x24 Updated by Kris Moore 9 months ago

  • Needs QA changed from Yes to No

No testing required. This fix didn't change behavior on 11.X, only for 12.x

#8 Updated by Dru Lavigne 9 months ago

  • Status changed from Ready for Testing to Done

#9 Updated by Dru Lavigne 8 months ago

  • Subject changed from Change Open dhparam usage to work on OpenSSL 1.0 and newer to Change OpenSSL dhparam usage to work on OpenSSL 1.0 and newer

#10 Updated by Dru Lavigne 7 months ago

  • Target version changed from 11.3-BETA1 to 11.3-ALPHA1

Also available in: Atom PDF