Project

General

Profile

Bug #6511

Dynamic DNS Service configured for freedns.afraid.org tries tup date dyndns instead

Added by Ian Cartwright almost 6 years ago. Updated almost 3 years ago.

Status:
Resolved
Priority:
Nice to have
Assignee:
Dru Lavigne
Category:
Documentation
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

Just what it says on the tin. If you configure the Dynamic DNS service for freedns.afraid.org it will try to update dyndns.com instead. Apparently this has been broken for a while but no one has officially opened a ticket to have it fixed. See this thread: https://forums.freenas.org/index.php?threads/freedns-afraid-ddns-help.18944/.

Screen Shot 2015-01-28 at 10.15.53 AM.jpg (42.9 KB) Screen Shot 2015-01-28 at 10.15.53 AM.jpg GUI Screenshot Ian Cartwright, 01/28/2015 07:16 AM
2066

History

#1 Updated by Jordan Hubbard almost 6 years ago

  • Category set to 20
  • Assignee set to William Grzybowski
  • Target version set to 9.3-M4

Hmm. Casual inspection of the code doesn't explain this to me...

#2 Updated by William Grzybowski almost 6 years ago

  • Status changed from Unscreened to Closed: Behaves correctly
  • Target version deleted (9.3-M4)

That is just how inadyn-mt works.

You can specify a different IP server if you want.

#3 Updated by Ian Cartwright almost 6 years ago

Hi William,

I just want to make sure I understand the behavior of inadyn-mt in FreeNAS. My understanding from the man page is that as long as the provider is specified, inadyn-mt will use the default update server for that provider. I have confirmed this is true for some of the providers (easydns and Hurricane Electric). However, what I understand from you is that that even though there is a drop down list to choose the Dynamic DNS provider, that the provider's update server must still be specified? This doesn't seem to match the behavior for EasyDNS and Hurricane Electric. I think that there is a bug such that when freedns.afraid.org is chosen from he drop down, the appropriate command line option is not set which causes inadyn-mt to fall back to its default behavior, which is to contact DynDNS.

#4 Updated by William Grzybowski almost 6 years ago

What makes you think so?

Check the field "IP Server".

#5 Updated by Ian Cartwright almost 6 years ago

My source of information is the man page for inadyn-mt and tcpdump on my FreeNAS server. According to the man page, it is sufficient to specify the Dynamic DNS provider. I confirmed this for EasyDNS and Hurricane Electric via tcpdump.

From the man page (http://manned.org/inadyn-mt.8):
--dyndns_system
An optional DNS service. For

http://www.dyndns.org
the    acceptable   services   are   one   of   ,
or .
There     is     only     one     acceptable      service      for
http://freedns.afraid.org, which is .
Other   services   are:  ,  ,
, , ,
, , ,
, , ,
, custom@http_svr_basic_auth._ The default
service is , which is believed to be used by most
users, at least initially.
--dyndns_server_name[:port]
The server that receives the update DNS requests. When no proxy is
specified it is sufficient to set the dyndns_system so that the
default servers will be taken. The option is useful for generic
DynDNS services that support HTTP update.
TYPICAL USAGE
http://www.dyndns.org
inadyn-mt
-u username -p password -a my.registered.name
inadyn-mt
--username test --password test --update_period 60000 --alias
test.homeip.net --alias my.second.domain
inadyn-mt
--background u test -p test --update_period 60000 --alias
inarcis.homeip.net --alias my.second.domain --log_file inadyn

mt.log
http://freedns.afraid.org
inadyn-mt
--dyndns_system -a
my.registrated.name,hash_from_freedns
inadyn-mt
--update_period 60000 --alias test.homeip.net,hash_for_host1 -a
my.second.domain,hash2 --dyndns_system

#6 Updated by Ian Cartwright almost 6 years ago

Ewwww. Sorry about the formatting...

#7 Updated by William Grzybowski almost 6 years ago

That doesn't explain absolutely anything.

Do you see anything wrong at all in the generated config file?

#8 Updated by Ian Cartwright almost 6 years ago

I'm not looking at the config file at all. I'm using the FreeNAS GUI and not getting the expected results. Are you saying that the GUI generates the config file properly and that inadyn-mt has a bug where it doesn't follow the config file when it comes to freedns.afraid.org?

#9 Updated by William Grzybowski almost 6 years ago

Yeah, or you're not understanding the meaning of IP Server which I have been screaming all along.

#10 Updated by Ian Cartwright almost 6 years ago

Enlighten me then... What does IP server mean? It doesn't appear in either the FreeNAS GUI or the inadyn-mt man page.

#11 Updated by Ian Cartwright almost 6 years ago

Well, I figured it out. It looks like freedns.afraid.org is "special" and doesn't take the "standard" fields presented in the GUI. I can document this if desired. I definitely wouldn't say that this "Behaves correctly" using the FreeNAS GUI and documentation. Maybe removing freedns.afraid.org from the drop down list would be an alternative.

#12 Updated by Dru Lavigne almost 6 years ago

  • Category changed from 20 to Documentation
  • Status changed from Closed: Behaves correctly to Screened
  • Assignee changed from William Grzybowski to Dru Lavigne

Ian, what is the status of this from a doc perspective?

#13 Updated by Dru Lavigne almost 6 years ago

  • Status changed from Screened to Closed: Insufficient Info

No feedback yet on what to document...

#14 Updated by Ian Cartwright almost 6 years ago

2066

Here's where I spelled out what I did to make it work: https://forums.freenas.org/index.php?threads/dynamic-dns-and-freeedns-afraid-org.24455/#post-151746

See attachment for it looks like in the GUI (note: not my actual hashes).

#15 Updated by Dru Lavigne almost 6 years ago

  • Status changed from Closed: Insufficient Info to Screened

#16 Updated by Dru Lavigne over 5 years ago

  • Status changed from Screened to Resolved

Fixed in 6baaa07ca2701ecc2ebf236ebfa595f8f0d4f010.

#17 Updated by Dru Lavigne almost 3 years ago

  • Target version set to Master - FreeNAS Nightlies

Also available in: Atom PDF