Project

General

Profile

Bug #65517

gptzfsboot errors and BTX halted on fresh FreeNAS-11.2-RELEASE install to USB

Added by Matthew Helm 7 months ago. Updated 4 months ago.

Status:
Closed
Priority:
No priority
Assignee:
Ryan Moeller
Category:
OS
Target version:
Seen in:
Severity:
Medium
Reason for Closing:
Duplicate Issue
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

Hello. I've recently wanted to start fresh on a previous NAS build I've used. This time around I thought I'd try the latest version released: FreeNAS-11.2-RELEASE

Mobo: ASrock E3C236D2I
CPU: Xeon E3-1230 V5 3.4 GHz
RAM: 32GB ECC

I've attempted to use multiple known working USB devices to install from/to. Source USBs were made using Rufus with 4GB/16GB sticks and destination USBs were 16GB/32GB. I would be able to complete the installation to the USB media however upon attempt in booting for the first time I would always hit the same snags you'll see in the attached image with gptzfsboot errors, read error information, then the BTX halted message:

gptzfsboot: error 49 lba 32
read 1 from 0 to 0x8b15d340, error: 0x31read 1 from 0 to 0x8b15d340, error: 0x31
BTX halted

I saw other users reporting the need for SATA controllers running in AHCI, which I have confirmed is true. I've also seen in Bug #46509 a 'bad' internal USB slot which was disabled and resolved the issue. This board also has an internal USB slot which I attempted to use along with other ports on the back/front both 3.0 and 2.0 with this same issue. I don't see any ability to disable my internal USB slot. I've also attempted to install with the SATA controller completely disabled and all 6x4TB WD Reds disconnected with no change.

The only thing worth mentioning is that there appear to be BIOS 'USB' virtual CD/HDD/Floppy devices from the IPMI/BMC which I can't see any way to "disable".

I have now attempted a fresh install of FreeNAS-11.1-U6 which was successful.

gptzfsboot_BTX_FreeNAS_boot_errors.bmp (2.59 MB) gptzfsboot_BTX_FreeNAS_boot_errors.bmp Matthew Helm, 12/20/2018 02:32 PM
Screenshot_1.png (53.3 KB) Screenshot_1.png Matthew Helm, 01/27/2019 11:44 PM
Screenshot_2.png (17.1 KB) Screenshot_2.png Matthew Helm, 01/27/2019 11:49 PM
rufus.jpg (56.4 KB) rufus.jpg Matthew Helm, 01/28/2019 12:29 AM
laptopboot.jpg (476 KB) laptopboot.jpg Matthew Helm, 01/28/2019 12:40 AM
46116
50739
50747
50755
50763

Related issues

Related to FreeNAS - Bug #72964: 11.2 bootloader broken, gptzfsboot error 32, now incompatible on previous running hardwareClosed
Has duplicate FreeNAS - Bug #66315: BTX Halted - After FreeNAS installation . Please helpClosed
Is duplicate of FreeNAS - Bug #65994: Merge in FreeBSD boot loader fixesReady for Testing

History

#1 Updated by William Grzybowski 7 months ago

  • Assignee changed from Release Council to Alexander Motin

#2 Updated by Alexander Motin 7 months ago

  • Assignee changed from Alexander Motin to Ryan Moeller

#3 Updated by Ryan Moeller 7 months ago

  • Status changed from Unscreened to In Progress

Matthew, was this a UEFI or BIOS boot installation? Have you tried both?

#4 Updated by Matthew Helm 7 months ago

Ryan Moeller wrote:

Matthew, was this a UEFI or BIOS boot installation? Have you tried both?

I'd have to try again and verify (and will if you feel it would be helpful to the cause) however, I want to say I tried both and while the installs were "successful" the attempted boots yielded the same results.

#5 Updated by Brad Waite 7 months ago

  • File 11.2-U1 Upgrade.txt added

I had almost identical issues upgrading from 11.2-RELEASE to 11.2-RELEASE-U1.

Intel SE7520BD2V
12GB DDR2
Dual Xeon 3.6 GHz Irwindale
LSI SAS 3081E-R
Sun F20 accelerator (LSI 1068E-based)
SanDisk 16GB Cruzer Fit

In my case, the gptzfsboot error was 1, not 49, and the boot loader would just hang after a slew of the "0x1read" errors (no "BTX halted"). This was initially under BIOS firmware, but I tried a new UEFI install of 11.2 with the same results. Boot log is attached.

In desperation to get my server back online, I upgraded the motherboard to an Intel S5000PSLSASR. Initially, I was able to get a fresh 11.2 to boot, but it failed again in the same fashion after I installed the LSI SAS HBAs. On the new board, the BTX halted after the "error: 0x1read" errors.

On both boards, the install media would boot fine, but the installed FreeNAS would toss the errors on boot.

I tried multiple gptzfsboot versions, from FreeBSD 11 & 12 and Allan Jude's patched gptzfsboot_hp from https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=144234. In the latter case, the initial "gptzfsboot: error 1 lba xxxx" errors disappeared, but the "0x1read" errors and halted BTX remained.

I disabled the on-board LSI 1064E on the S5000, and even tried to enable AHCI, even though I wasn't using any SATA devices. The firmware on all HBAs was up to date (and re-updated for good measure).

I was unable to install a fresh 11.2-RELEASE on the older board, even though the initial upgrade from 11-STABLE worked. It's been a frantic and frenzied blur over the last week trying to restore this server, so I can't recall whether I tried a fresh 11.2-RELEASE UEFI install or not.

As of this writing, the only way I was able to restore functionality was by booting the original USB on another machine, selecting the 11.1-U6 boot environment, copying the freenas-v1.db off the machine and restoring it on a fresh 11.1-U6 install.

There seems to be quite a few gztzfsboot-related errors in 11.2. Even though I've spent 20+ hours on this, I'm happy to try various things to get this bug squashed. Not to mention I'd like to be able to run the very latest version.

#6 Updated by Ryan Moeller 6 months ago

  • Status changed from In Progress to Blocked
  • Reason for Blocked set to Need verification

Matthew, Brad: I've seen reports that disabling "legacy USB" options in BIOS/UEFI can lead to success for some people. I'll admit it's a shot in the dark but is that something either of you can try?

#7 Updated by Ryan Moeller 6 months ago

  • Has duplicate Bug #66315: BTX Halted - After FreeNAS installation . Please help added

#8 Updated by Matthew Helm 6 months ago

Ryan Moeller wrote:

Matthew, Brad: I've seen reports that disabling "legacy USB" options in BIOS/UEFI can lead to success for some people. I'll admit it's a shot in the dark but is that something either of you can try?

I'll be doing a fresh install to an SSD using 11.2-RELEASE-U1 soon with this build however, I'll go ahead and test disabling 'legacy USB' for a install to USB again (this time using FreeNAS-11.2-RELEASE-U1) to help out anyone else after I confirm this is still an issue with FreeNAS-11.2-RELEASE-U1.

#9 Updated by Ryan Moeller 6 months ago

  • Severity changed from New to Medium
  • Reason for Blocked changed from Need verification to Waiting for feedback

Brad, I notice you're booting from a SanDisk Cruzer Fit. Please try using a different USB stick or upgrade to an SSD and let me know how it goes. There appears to be a quirk with some production runs of SanDisk Ultra Fit USB 3.0 devices that makes them unbootable in some systems, and I wonder if there might be a similar problem with your Cruzer Fit USB 2.0 stick. Quite a few of the gptzfsboot issues have been resolved by simply using a different device. The ticket for that issue is here: https://redmine.ixsystems.com/issues/65994

Matthew, can you also let me know what USB stick you are using, and possibly try a different one if disabling legacy USB support doesn't work? The SSD will be a great upgrade, so this would just be for science, of course. ;)

#10 Updated by Matthew Helm 6 months ago

50739
50747

Ryan Moeller wrote:

Matthew, can you also let me know what USB stick you are using, and possibly try a different one if disabling legacy USB support doesn't work? The SSD will be a great upgrade, so this would just be for science, of course. ;)

ADATA 16GB Superior Series S102 Pro (USB 3.0) - FreeNAS Bootable Installer
Patriot 32GB Supersonic Boost Series (USB 3.0) - Installation Destination/FreeNAS Boot

Attempted an installation of FreeNAS-11.2-RELEASE-U1 and yielded what appear to be the same results (Screenshot_1)

Setting Legacy USB Support to Disabled (Screenshot_2) completely ignores the two USB drives as available devices. Doesn't appear to be a fitting resolution for this board (ASrock E3C236D2I) with AMI BIOS.

When using an SSD in the future I'll report any issues but I'd assume just like any HDD installs I attempted with 11.2 on this build it will be successful. If there's any further tests in the future or releases available I'll be happy to test to see if we get any further BTX halted issues when installing and booting USB. The only thing I haven't tested is if a different machine can boot the installation media of FreeNAS completed on this mentioned build. Let me know if that's worth attempting, as I'm not sure what all specifics go into creating the install based on initial hardware/firmware discovered.

#11 Updated by Ryan Moeller 6 months ago

  • Status changed from Blocked to In Progress

Thanks for the quick update. I'll have to look around for some info on those flash drives, but I will guess they don't have the same issues as the SDUF devices.

Matthew Helm wrote:

The only thing I haven't tested is if a different machine can boot the installation media of FreeNAS completed on this mentioned build. Let me know if that's worth attempting, as I'm not sure what all specifics go into creating the install based on initial hardware/firmware discovered.

That could be worth trying, to have another data point. The main thing that is set at install time is your selection of either UEFI or BIOS bootloader. Assuming that is compatible, you should be able to boot the installed system in another machine.

#12 Updated by Ryan Moeller 6 months ago

Regarding your picture of the BIOS screen, it says on the right that disabling legacy USB makes USB devices only appear for UEFI booting. Were your other settings configured for UEFI booting when you had that disabled?

#13 Updated by Matthew Helm 6 months ago

50755

Ryan Moeller wrote:

Regarding your picture of the BIOS screen, it says on the right that disabling legacy USB makes USB devices only appear for UEFI booting. Were your other settings configured for UEFI booting when you had that disabled?

Is there a preferred method to create a the installation media? I've always used Rufus without issues, but I see that now (and I don't think in the past) the grayed out option for target system is BIOS (or UEFI-CSM). I didn't see an option to boot the installer USB via UEFI this time around, so I performed the last install on the USB for BIOS as well. If I should have seen USB UEFI boot options if available (with legacy disabled), this would certainly explain why I didn't see any.

#14 Updated by Matthew Helm 6 months ago

50763

Ryan Moeller wrote:

That could be worth trying, to have another data point. The main thing that is set at install time is your selection of either UEFI or BIOS bootloader. Assuming that is compatible, you should be able to boot the installed system in another machine.

Attempting to use a few year old Acer Aspire laptop booting via Legacy/BIOS to the USB that was created on the original machine this is the result we get:
an unsuccessful boot
SOLARIS unable to find pool label 'freenas-boot'
zfs freenas-boot error 5

I can try my desktop later when I'm not running specific tasks.

EDIT: NOTE: the install USB was configured using the Rufus settings attached previously and only had BIOS boot options. the OS boot USB was also installed as BIOS boot.

#15 Updated by Ryan Moeller 6 months ago

Matthew Helm wrote:

Is there a preferred method to create a the installation media?

Rufus in DD mode should work (it leaves everything up to the image itself, which is why the options you described were greyed out, I figure). I've also heard etcher is a good one. What doesn't work is the stuff like unetbootin or other Rufus modes, because they manipulate the image instead of writing it straight to the device as intended.

Matthew Helm wrote:

SOLARIS unable to find pool label 'freenas-boot'
zfs freenas-boot error 5

Not sure I've seen that one before, interesting.

Looking forward to see how this goes on your desktop. I'm wrapping up for the night so no need to rush on my behalf.

Thanks again for testing these different configurations!

#16 Updated by Ryan Moeller 6 months ago

I just noticed the screenshot of Rufus and it looks different from what I remember, I guess it's been a while. No idea where it would tell you whether it's in DD mode or what it's doing, but I assume if the installer booted it's doing the right thing.

#17 Updated by Brad Waite 6 months ago

Ryan Moeller wrote:

Brad, I notice you're booting from a SanDisk Cruzer Fit. Please try using a different USB stick or upgrade to an SSD and let me know how it goes. There appears to be a quirk with some production runs of SanDisk Ultra Fit USB 3.0 devices that makes them unbootable in some systems, and I wonder if there might be a similar problem with your Cruzer Fit USB 2.0 stick. Quite a few of the gptzfsboot issues have been resolved by simply using a different device. The ticket for that issue is here: https://redmine.ixsystems.com/issues/65994

My Samsung MUF-32AB/AM FIT Plus 32GB thumbdrives should be here today, and I'll report back as soon as I've had a chance to twiddle with them.

#18 Updated by Ryan Moeller 5 months ago

  • Related to Bug #72964: 11.2 bootloader broken, gptzfsboot error 32, now incompatible on previous running hardware added

#19 Updated by Ilkka Tengvall 5 months ago

Matthew Helm wrote:

Ryan Moeller wrote:

Matthew, was this a UEFI or BIOS boot installation? Have you tried both?

I'd have to try again and verify (and will if you feel it would be helpful to the cause) however, I want to say I tried both and while the installs were "successful" the attempted boots yielded the same results.

I suffer from this also. I tried both the UEFI and legacy. Actually, my mobo is from the time UEFI was just EFI, but anyhow. It doesn't make a difference. I see in this case there are two types of issues, which are different.

1. One can install the system, or upgrade from e.g. 11.1, but first boot won' work, and
2. others can't get install media to work.

I belong to group 1, which I believe this bug was originally about. Issue type 2. is totally different issue, if it's about whether someone knows how to use dd or not, or faulty usb sticks.

I tried in several methods, with several usb sticks to get to 11.2. It definitely is not USB stick issue for me, as with the very same sticks I always end up with working 11.1 release. EFI or legacy BIOS. And install or upgrade always works, the problem is the first real boot into installed system.

End result is FreeBSD bootloader just does not work with my box. My box is same ASUS EM35 as in the closed ticket: https://redmine.ixsystems.com/issues/52647

The box has years worked with FreeNAS, and still runs with the same stick with 11.1-U6.3. I'm eagerly waiting this issue to get sorted out, or FreeNAS going back to grub which just works.

Unfortunately my box is in location that I seldom can reach physically. But I spent a day trying different ways, and am pretty sure about this. It is something with FreeBSD bootloader or options it get's installed with. Or BIOS bug that only FreeBSD bootloader hits. Or how partitions are made by new installer. Common dominator according to forums and bugs seems to be old HW.

#20 Updated by IT IGP 5 months ago

@Ilkka Tengvall agree completely. nice writeup.

#21 Updated by Ilkka Tengvall 5 months ago

IT IGP wrote:

@Ilkka Tengvall agree completely. nice writeup.

Thanks, I also wrote my 2 cents on the forum side: https://forums.freenas.org/threads/11-2-series-wont-boot-after-install-or-upgrade.72734/page-2#post-514191

#22 Updated by Ryan Moeller 5 months ago

  • Reason for Blocked deleted (Waiting for feedback)

There has been significant work to the bootloader merged into our freenas/11-stable branch. If someone would like to test a build:
https://download.freenas.org/11.3/MASTER/201902231007/x64/FreeNAS-11.3-MASTER-201902231007-e132e27.iso

#23 Updated by IT IGP 5 months ago

i tested that master on my old asus with fresh BIOS install/boot. worked so far. i should test an upgrade of 11.1 on that machine though i guess...

#24 Updated by mike myers 5 months ago

It's interesting that people are flagging the Samsung Fit USB sticks as having issues. The folks at Servethehome recommend them as the goto drive for USB boot loaders. I use them on my vmware hosts with no issues, and they are pretty fast.

I found my system crashed again today, though I don't know from what. It looks like it tried to boot, but the USB drive wasnt recognized or had some issue and couldn't boot from the next device. I rebooted it it just now and it seemed to come up fine. I am not sure how robust the UEFI code is on my SUpermicro X9DRW-TF+ is.

For the new master, should I attempt to write it to a USB boot drive in the legacy format and assume it will boot normally? Is it a pretty stable release in other aspects?

#25 Updated by Ryan Moeller 5 months ago

mike myers wrote:

I found my system crashed again today, though I don't know from what. It looks like it tried to boot, but the USB drive wasnt recognized or had some issue and couldn't boot from the next device. I rebooted it it just now and it seemed to come up fine. I am not sure how robust the UEFI code is on my SUpermicro X9DRW-TF+ is.

Random crash and intermittent UEFI boot failure doesn't sound much like the issue described in this ticket. Were you having the problems described by this ticket in legacy boot mode?

mike myers wrote:

For the new master, should I attempt to write it to a USB boot drive in the legacy format and assume it will boot normally? Is it a pretty stable release in other aspects?

The ISO linked is a regular installer image you can write to a USB stick and install normally. It corresponds to the nightly train, described here: https://www.ixsystems.com/documentation/freenas/11.2/system.html#updates-and-trains
This is considered experimental and should not be used in production. Please only use it for testing.

#26 Updated by IT IGP 5 months ago

related Bug #77062

#27 Updated by Ryan Moeller 4 months ago

  • Is duplicate of Bug #65994: Merge in FreeBSD boot loader fixes added

#28 Updated by Ryan Moeller 4 months ago

  • Status changed from In Progress to Closed
  • Target version changed from Backlog to N/A
  • Reason for Closing set to Duplicate Issue
  • Needs Merging changed from Yes to No

#29 Updated by Dru Lavigne 4 months ago

  • File deleted (11.2-U1 Upgrade.txt)

Also available in: Atom PDF