Project

General

Profile

Bug #6562

CPU loop under VMware ESXi 5.5.0

Added by Andrzej Tobola almost 6 years ago. Updated about 3 years ago.

Status:
Resolved
Priority:
Nice to have
Assignee:
Dru Lavigne
Category:
Documentation
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

On the first boot of FreeNAS 9.3-M4 VM under ESXi 5.5.0 I have CPU loop after message:
Timecounter "HPET" frequency 14318180 quality 950
When I reset machine it boots OK.

VirtualMachineProperties_hpet_off.JPG (94.3 KB) VirtualMachineProperties_hpet_off.JPG DENNY VANDEMAELE, 01/21/2015 08:09 AM
2026

Related issues

Is duplicate of FreeNAS - Bug #6585: VMWare and Reboot Typically HangsClosed: Duplicate2014-11-09

History

#1 Updated by Jordan Hubbard almost 6 years ago

  • Status changed from Unscreened to Closed: Third party to resolve

Nothing for us to fix - this is an ESXi interoperability issue (and not an officially supported configuration).

#2 Updated by DENNY VANDEMAELE over 5 years ago

2026

For those of you who are pulling your hair out on this one, Vmware has provided the solution solution in this document: http://www.vmware.com/files/pdf/Timekeeping-In-VirtualMachines.pdf

The pertinent part of the document quoted below:

"A virtual HPET was introduced with Virtual Hardware version 8 (which first appeared in ESX 5.0, Workstation 8.0 and Fusion 4.0). It runs in apparent time. Currently supported guest operating systems do not require a HPET, but some will use a HPET if one is present (including Windows Vista and later, and many versions of Linux). It can be disabled by setting hpet0.present=FALSE in the VM's configuration."

Step by Step
1) Turn off your FreeNAS virtual machine
2) Edit settings on the FreeNAS virtual machine
3) Click on Options Tab
4) Click on General under Advanced
5) Click the Configuration Parameters Button on the bottom right
6) Change hpet0.present from true to false.
7) Click Start

#3 Updated by DENNY VANDEMAELE over 5 years ago

Adding Step:
6.5) Click OK, and then OK to save the settings.
7) Start the virtual machine, and it will pick the next fastest timer to hpet (and won't lockup on restart).

#4 Updated by Jordan Hubbard over 5 years ago

  • Category set to Documentation
  • Status changed from Closed: Third party to resolve to Unscreened
  • Assignee set to Dru Lavigne
  • Target version set to 49

Thanks for the "howto" information from VMWare! Here's what I'm going to do - I'm going to move this back to Unscreened and hand it to Dru under the Documentation category. The goal will be to add it to whatever section seems relevant (creating a new one if necessary) for VMWare interoperability issues, since VMWare + FreeNAS is a very very popular combo and it's worth it to us to document such tips-and-tricks there.

#5 Updated by Dru Lavigne over 5 years ago

  • Status changed from Unscreened to Screened

#6 Updated by Chris Murray over 5 years ago

Thank you so much Denny!

#7 Updated by Josh Paetzel over 5 years ago

  • Is duplicate of Bug #6585: VMWare and Reboot Typically Hangs added

#8 Updated by Josh Paetzel over 5 years ago

  • Status changed from Screened to Closed: Duplicate

#9 Updated by Joe Schmuck over 5 years ago

When this gets added into the documentation, please add the file which must be changed is the .vmx file. The setps above do not work for VMWare Workstation 10, there is not option to edit the .vmx file from within the application. I'd say the instructions would be as follows or similar:

Step by Step (ESXi)
1) Turn off your FreeNAS virtual machine
2) Edit settings on the FreeNAS virtual machine
3) Click on Options Tab
4) Click on General under Advanced
5) Click the Configuration Parameters Button on the bottom right
6) Change hpet0.present from true to false.
7) Click OK, and then OK to save the settings.
8) Start the virtual machine, and it will pick the next fastest timer to hpet (and won't lockup on restart).

Step by Step (Workstation or Player)
1) Turn off your FreeNAS virtual machine
2) Edit settings on the FreeNAS virtual machine
3) Click on Options Tab
4) Click on Advanced
5) Under File Locations locate the path for the Configuration file (filename.vmx).
6) Edit the configuration file using a text editor.
7) Change hpet0.present from true to false and save the file.
8) Start the virtual machine, and it will pick the next fastest timer to hpet (and won't lockup on restart).

#10 Updated by Dru Lavigne over 5 years ago

  • Status changed from Closed: Duplicate to Resolved

Added in commit a0dff4d0d824e4270436073ce8d5392514889a10.

#11 Avatar?id=14398&size=24x24 Updated by Kris Moore about 3 years ago

  • Target version changed from 49 to N/A

Also available in: Atom PDF