Project

General

Profile

Bug #6585

VMWare and Reboot Typically Hangs

Added by Joe Schmuck almost 6 years ago. Updated over 3 years ago.

Status:
Closed: Duplicate
Priority:
Nice to have
Assignee:
Xin Li
Category:
OS
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

This Thread https://forums.freenas.org/index.php?threads/reboot-shutdown-sometimes-dont-work-nightly-2014-10-24.24322/#post-152783

lists two people having issues with VMWare where if you reboot the FreeNAS VM it will typically hang, however if you shutdown and then power up the VM, no issue.

My concern is there is something wrong in the bootloader which could affect even a bare metal machine in some adverse way. I'm just asking someone to look into it.


Related issues

Has duplicate FreeNAS - Bug #6562: CPU loop under VMware ESXi 5.5.0Resolved2014-11-06

History

#1 Updated by Jordan Hubbard almost 6 years ago

  • Category set to 18
  • Assignee set to Josh Paetzel
  • Target version set to 111

Unless we actually get evidence specifically tying this to a bare metal install, I'm not sure this is 9.3-RELEASE material. For one thing, VMWare+FreeNAS is simply not the same scenario at all - under VMWare, there's an entire handshake dance with the vmware tools (particularly during shutdown / reboot) that simply isn't there at all in a bare metal scenario.

#2 Updated by Joe Schmuck almost 6 years ago

I completely understand, I just wanted to raise attention to it just in case there is something going on behind the scenes that you didn't want.

#3 Updated by Josh Paetzel almost 6 years ago

  • Status changed from Unscreened to Closed

We use vmware for a lot of testing and development and haven't noticed this issue. I'll keep my eye on it though.

#4 Updated by Jeremy Smith almost 6 years ago

Just wanted to say you have a 3rd case of this happening with me. I'll add the relevant details to the forum thread but the short version is on every reboot of the FreeNAS 9.3 builds on ESX 5.5u2 it hangs on the HPET timer until i "Force Reset" the vm. At that point it boots fine. I have this in a 100% reproducible lab setup and would be willing to help get to the bottom of it.

#5 Updated by Thomas Åkesson almost 6 years ago

I am unable to see the forum thread (permission denied even when logged in). Anyone else able to see the thread?

I am consistently seeing this problem on both ESXi 5.1 and 5.5 with FreeNAS 9.3 (it was fine with 8.3).

Issue #6562 likely related the same problem.

Based on VMware KBs there has been problems with FreeBSD HPET before, but that was quite a while ago. Perhaps there have been changes in FreeBSD that triggers new incompatibilities with ESXi.
http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=2021185

#6 Updated by Kyle Fox almost 6 years ago

1997

I can also attest this is a problem in FreeNAS 9.3 / FreeBSD 9.3 as I'm also testing FreeNAS 9.3 on VMWare ESXi 5.5.. I have FreeNAS 9.2.1.X running in my home "production" Under a VM (still is running) and trying to deploy a test FreeNAS 9.3 VM results in this every reboot, until I soft reboot the VM.. I cannot move to FreeNAS 9.3 until this is resolved.. The VM is built with the following configuration (which I'm assuming most people build as such given its mostly defaults:

Memory = 8 GB
vCPU = 2 CPU
VM Version = Version 8
VM OS = FreeBSD 64bit
SCSI Controller = LSI Logic SAS
Network Adapter = E1000
VMCI device = Restricted

#7 Updated by Chris Murray almost 6 years ago

I see exactly the same on ESXi 5.5 U2. FreeNAS 9.3 only boots every 2nd attempt. Setting kern.timecounter.hardware is fruitless as this is only overridden after the point the VM would hang.

Interestingly, I can't get FreeBSD 9.3 to do the same. I understand there have been timer issues in the past with FreeBSD and vSphere, but this boots fine for me, suggesting the problem is particular to FreeNAS 9.3? I guess there are a few users out there with a test/pre-production FreeNAS on a virtual platform, so I'm keen to help troubleshoot.

#8 Updated by Joe Schmuck almost 6 years ago

This does only occur on FreeNAS 9.3, not FreeBSD 9.3 on my system as well. I am willing to do some testing.

My complete system information is:
Host: Intel i7 950 CPU, 24GB RAM, Windows 7 Pro 64-bit
Running VMWare Workstation 10.0.4 build-2249910 (the most current v10 available, can't afford version 11 just yet).

I am willing to configure my VM in any way requested to run any test.

#9 Updated by Chris Murray almost 6 years ago

Just to correct myself, in case it causes anyone to have a brainwave with this: it's not every second attempt that the machine boots correctly, it's the shutdown method that matters:

Power on the VM. TSC-low timer is chosen. System boots. '12' to shutdown.
Power on the VM. TSC-low timer is chosen. System boots. '12' to shutdown.
Power on the VM. TSC-low timer is chosen. System boots. '12' to shutdown.
...
Power on the VM. TSC-low timer is chosen. System boots. '11' to reboot.
HPET timer is chosen. System hangs. Reset system.
TSC-low timer is chosen. System boots. '11' to reboot.
HPET timer is chosen. System hangs. Reset system.
TSC-low timer is chosen. System boots. Reset system.
TSC-low timer is chosen. System boots. Reset system.
TSC-low timer is chosen. System boots.

So, shutting down gracefully works, resetting in VMware works, but rebooting gracefully causes the issue?

Again, this isn't happening on vanilla FreeBSD 9.3, so I'm intrigued.

#10 Updated by Jordan Hubbard almost 6 years ago

  • Status changed from Closed to Unscreened
  • Assignee changed from Josh Paetzel to Xin Li
  • Target version changed from 111 to 49

#11 Updated by Chris Murray almost 6 years ago

I see there's a workaround in bug 6562 regarding how to disable the HPET timer in vSphere.

That has worked fine for me, thank you.

#12 Updated by Josh Paetzel almost 6 years ago

  • Has duplicate Bug #6562: CPU loop under VMware ESXi 5.5.0 added

#13 Updated by Josh Paetzel almost 6 years ago

  • Status changed from Unscreened to Closed: Duplicate

#14 Avatar?id=14398&size=24x24 Updated by Kris Moore over 3 years ago

  • Category set to 129
  • Target version changed from 49 to N/A

Also available in: Atom PDF