Project

General

Profile

Bug #65979

Error creating cloud sync task using SFTP credentials - "[EFAULT] 2018/12/25 20:50:37 Failed to create file system for "remote:": NewFs: couldn't initialise SFTP: EOF"

Added by David Nierhoff almost 2 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
No priority
Assignee:
Release Council
Category:
Middleware
Target version:
Seen in:
Severity:
New
Reason for Closing:
Behaves as Intended
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

Hi FreeNAS,
I tried creating a cloud sync task on FreeNAS 11.2 RELEASE using SFTP target.

When I am entering a remote folder, I cannot save the task getting error
"[EFAULT] 2018/12/25 20:50:37 Failed to create file system for "remote:": NewFs: couldn't initialise SFTP: EOF"
"Error: Traceback (most recent call last):
File "/usr/local/lib/python3.6/site-packages/middlewared/main.py", line 161, in call_method
result = await self.middleware.call_method(self, message)
File "/usr/local/lib/python3.6/site-packages/middlewared/main.py", line 1109, in call_method
return await self._call(message['method'], serviceobj, methodobj, params, app=app, io_thread=False)
File "/usr/local/lib/python3.6/site-packages/middlewared/main.py", line 1049, in _call
return await methodobj(*args)
File "/usr/local/lib/python3.6/site-packages/middlewared/service.py", line 283, in update
f'{self._config.namespace}.update', self, self.do_update, [id, data]
File "/usr/local/lib/python3.6/site-packages/middlewared/main.py", line 1049, in _call
return await methodobj(*args)
File "/usr/local/lib/python3.6/site-packages/middlewared/schema.py", line 664, in nf
return await f(*args, **kwargs)
File "/usr/local/lib/python3.6/site-packages/middlewared/plugins/cloud_sync.py", line 449, in do_update
await self._validate_folder(verrors, "cloud_sync_update", cloud_sync)
File "/usr/local/lib/python3.6/site-packages/middlewared/plugins/cloud_sync.py", line 344, in _validate_folder
args=data.get("args"),
File "/usr/local/lib/python3.6/site-packages/middlewared/schema.py", line 664, in nf
return await f(*args, **kwargs)
File "/usr/local/lib/python3.6/site-packages/middlewared/plugins/cloud_sync.py", line 508, in list_directory
return await self.ls(dict(cloud_sync, credentials=credentials), path)
File "/usr/local/lib/python3.6/site-packages/middlewared/plugins/cloud_sync.py", line 518, in ls
raise CallError(proc.stderr)
middlewared.service_exception.CallError: [EFAULT] 2018/12/25 20:50:37 Failed to create file system for "remote:": NewFs: couldn't initialise SFTP: EOF"

CloudCredentials.png (47.1 KB) CloudCredentials.png David Nierhoff, 12/25/2018 11:59 AM
CloudTask.png (104 KB) CloudTask.png David Nierhoff, 12/25/2018 11:59 AM
46377
46386

History

#1 Updated by William Grzybowski almost 2 years ago

  • Status changed from Unscreened to Closed
  • Target version changed from Backlog to N/A
  • Reason for Closing set to Behaves as Intended

Hello,

The error message seems quite clear about what the problem is. Your serve seems to support a single algorithm which is not supported by FreeNAS client. I suggest you to enable more in your server.

Let me know if we are missing anything.

#2 Updated by David Nierhoff almost 2 years ago

Found the error....the user was not allowed to SSH to the server, just plain FTP...

Also available in: Atom PDF