Project

General

Profile

Bug #65994

Unable to upgrade 11.1-U6->11.2

Added by Tibor Gálffy 23 days ago. Updated 6 days ago.

Status:
Screened
Priority:
No priority
Assignee:
Ryan Moeller
Category:
OS
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

Dear Developer,
Upgrade (and 1st reboot) went thru without any problem, but after 2nd reboot system was unable tu start (gptzfsboot: error 32 lba 1).
Downloaded and install 11.1-U6 again (I have got backuped config). Splited mirrored boot device in order to have backuped 11.1-u6 system. Downloaded 11.2 image. I try to prepare installation media, but written by Unetbootin has not booted (Invalid or corrupted kernel image). Rufus (v 3.3 and 3.4) caused BSOD when 99.6% of immage was written. My PC has not started with this pendrive attached. Connecting this pendrive caused immediate BSOD. I was able to repair it only with Gparted under Linux creating a new partition table (Gparted reportet corrupter partition table).
Only Image writer was able to write image to pendrive, but after booting I got just a blinking "\".
It is an HP N54L Microserver with 5x3TiB disks in raidz2.
The simmilar issue I had a few weeks ago, I tried to upgrade to the beta version:
https://www.facebook.com/groups/118037613554/permalink/10156713699418555/


Related issues

Has duplicate FreeNAS - Bug #66513: RE Bug #65994 Unable to Upgrade vom 11.1 to 11.2 HP N54 L same issueClosed

History

#1 Updated by Tibor Gálffy 22 days ago

Sorry, I forgot:
Boot device: pair of mirrored Sandisk Ultra Fit SDCZ43 32GB USB 3.0
As installation media I used several 8GB USB2.0 flash disks, all of them has same issue.
Image I wrote under Win7 64 bit, corrupted flash drive repaired with Gparted, an old Ubuntu live installation CD (v. 12.04).
Hardware:
HP N54L Microserver AMD Turion(tm) II Neo N54L Dual-Core Processor
Memory: KINGSTON KVR1333D3E9SK2/16G, DDR3 2x8GB 1333MHz ECC CL9
Disks: 4x 3.0 TB WD Greem + 1x3.Tb WD Red

#2 Updated by William Grzybowski 20 days ago

  • Assignee changed from Release Council to Alexander Motin

#4 Updated by Christoph Borsbach 16 days ago

Hey all,
I just wanted to chime in that I noticed the same behavior:
- Upgrade 11.1-U6 --> 11.2-U1
- All is well for the first reboot.
- The error described ((gptzfsboot: error 32 lba 1)) appeared for me on the second reboot, days later.
- I have not examined the USB-Stick in question very closely, but an attempt to do an "upgrade installation" on it failed. (as in: Attempt to boot gives the same error: (gptzfsboot: error 32 lba 1))
- For the moment I reinstalled FreeNAS on another USB Stick.

Let me know if I can test anything.

My Hardware is similar to the OP:
HP N54L Microserver AMD Turion(tm) II Neo N54L Dual-Core Processor
16GB Sandisk USB2 Stick as Bootdevice
Various HDDs

#5 Updated by Alexander Motin 10 days ago

  • Assignee changed from Alexander Motin to Ryan Moeller

#6 Updated by Alexander Motin 8 days ago

  • Has duplicate Bug #66513: RE Bug #65994 Unable to Upgrade vom 11.1 to 11.2 HP N54 L same issue added

#7 Updated by Ryan Moeller 6 days ago

  • Status changed from Unscreened to Screened

Also available in: Atom PDF