Project

General

Profile

Bug #6629

CTL doesn't support MCS

Added by Gino Latilla almost 6 years ago. Updated about 4 years ago.

Status:
Closed: Not To Be Fixed
Priority:
Nice to have
Assignee:
Alexander Motin
Category:
OS
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

I've installed Freenas 9.3 as update from 9.2, no change to hardware (server, client, network).

In 9.2 I use iscsi with mpio client, 4 x 1Gb network card, and I can set the maximum number of connection in iscsi settings. It work fine over 4 network card, balance the load and maximize throughput as a 4Gb card (sure with offload and performance losses).

With 9.3 I don't see option to set maximum number of connection and the connection free counter from client say me I have only one connection allowed.

The connection is direct from client to server, one subnet for network card, the portal have allocated the multiple ip compliance the configuration.

connection_iscsi.JPG (143 KB) connection_iscsi.JPG Gino Latilla, 11/12/2014 10:00 AM
1482

History

#1 Updated by Jordan Hubbard almost 6 years ago

  • Category set to 89
  • Assignee set to Alexander Motin
  • Target version set to 9.3-RELEASE

#2 Updated by Alexander Motin almost 6 years ago

  • Status changed from Unscreened to Screened

What you are talking, I think, is a number of connections per session. That is actually not an MPIO, but alternative technology called MCS (or MC/S). The new iSCSI target indeed does not support MCS (at least at this point). But you may be able to setup MPIO by configuring several sessions if your initiator supports that.

What is your initiator? In case it is Windows, Windows supports MPIO starting from Windows 8/2008R2/2012. You just need to install additional OS optional feature, since it is not installed by default.

#3 Updated by Gino Latilla almost 6 years ago

1482

I think you're right. I attached the screenshot of the operation and it was to add connection per different subnet. I can configure multiple session for the client but it seems to not work very good. The client OS is windows 8 but the multipath I/O feature is not available, I see now they call MCS like MPIO but it is available only in the server version. If you like and it make sense without instability, you can add MCS support like feature, sure now is not a bug. Thank you.

#4 Updated by Alexander Motin almost 6 years ago

It seems not exactly trivial to implement MCS correctly. That is why we had no plans to implement it, assuming that users may just switch to more universal MPIO technology instead. Unfortunately I have no Windows 8 to check MPIO there. Are you sure that it is not supported?

#5 Updated by Jordan Hubbard almost 6 years ago

  • Target version changed from 9.3-RELEASE to 111

Changing milestone since this is evidently not about MPIO.

#6 Updated by Josh Paetzel over 5 years ago

  • Subject changed from In 9.3 iscsi maximum connection is limited to 1 to CTL doesn't support MCS

Editing the bug title to fit the actual problem.

#7 Updated by Jordan Hubbard over 4 years ago

  • Status changed from Screened to Closed: Not To Be Fixed

BRB: MCS is just too old and the implementation would significantly complicate the CTL code. MPIO is the future.

#8 Avatar?id=14398&size=24x24 Updated by Kris Moore about 4 years ago

  • Target version changed from 111 to N/A

Also available in: Atom PDF