Project

General

Profile

Bug #66621

Freenas 11.2 Lan Speed too slow

Added by Yasin ilkbahar 11 months ago. Updated 10 months ago.

Status:
Closed
Priority:
No priority
Assignee:
Alexander Motin
Category:
OS
Target version:
Severity:
New
Reason for Closing:
Cannot Reproduce
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

I've installed freenas 11.2 on the following HW Components:
- MSI MAG Z390M Mortar with I219V-Lan ( Gigabit )
- Intel I3 8100 => In the boot mod I see a line with: This intel cpu is not supported
My general problem is the NIC speed. I've made an iperf3 test and I got only transferspeeds between 1-2 MBs. In some forums I've read the change of the LAN-Cable should solve this problem. I've bought a CAT6 Cable and the result is the same. I think the problem is in your OS.

History

#1 Updated by Yasin ilkbahar 11 months ago

  • File debug-freenas-20181231140659.txz added
  • Private changed from No to Yes

#2 Updated by Dru Lavigne 11 months ago

  • Assignee changed from Release Council to Alexander Motin

#3 Updated by Yasin ilkbahar 11 months ago

Yasin ilkbahar wrote:

I've installed freenas 11.2 on the following HW Components:
- MSI MAG Z390M Mortar with I219V-Lan ( Gigabit )
- Intel I3 8100 => In the boot mod I see a line with: This intel cpu is not supported
My general problem is the NIC speed. I've made an iperf3 test and I got only transferspeeds between 1-2 MBs. In some forums I've read the change of the LAN-Cable should solve this problem. I've bought a CAT6 Cable and the result is the same. I think the problem is in your OS.

Could this an driver issue?

#4 Updated by Yasin ilkbahar 11 months ago

  • Private changed from Yes to No

#5 Updated by Dru Lavigne 11 months ago

  • Private changed from No to Yes

#7 Updated by Alexander Motin 10 months ago

  • Status changed from Unscreened to Blocked
  • Reason for Blocked set to Need additional information from Author

I'm sorry, but I see nothing bad in the provided debug. Sharing NIC with plugins and VMs may slightly reduce its performance due to disabling some CPU offloads, but it should in no case make it as bad as 1-2MB/s you are saying. The driver for Intel NICs for FreeBSD we are using is provided by Intel, and we haven't modified it.

The messages about unsupported CPU is just a result of this system being very new, and performance profiling code and some other drivers does not know it and chipset. But it should not otherwise affect operation if all devices you need are detected and functioning.

What is on the other side of your iperf test? Is that system good enough to not be a problem? Is the network in between is good enough? I suppose there is no some WiFi in between?

You may for experiment try to update FreeNAS to 11.3-nightly. I see no changes to the driver there, but who knows.

#8 Updated by Alexander Motin 10 months ago

  • Status changed from Blocked to Closed
  • Target version changed from Backlog to N/A
  • Reason for Closing set to Cannot Reproduce
  • Reason for Blocked deleted (Need additional information from Author)

Closing this on lack of ideas.

#9 Updated by Dru Lavigne 10 months ago

  • File deleted (debug-freenas-20181231140659.txz)

#10 Updated by Dru Lavigne 10 months ago

  • Private changed from Yes to No

Also available in: Atom PDF