Project

General

Profile

Bug #67602

Fix bug that prevented S3 service from starting

Added by Peter Zeilstra 10 months ago. Updated 8 months ago.

Status:
Done
Priority:
No priority
Assignee:
Waqar Ahmed
Category:
Services
Target version:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
No
Needs Doc:
No
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

When I start the S3 service I receive an error message saying S3 service fails to start.


Related issues

Related to FreeNAS - Bug #65544: Do not start S3 service at boot if 'Start Automatically' is not checkedDone
Has duplicate FreeNAS - Bug #67593: S3 Service fails to startClosed
Has duplicate FreeNAS - Bug #69112: FreeNAS 11.2-RELEASE-U1 S3 service failed to start.Closed
Copied to FreeNAS - Bug #68871: S3 Service fails to startDone

History

#1 Updated by Peter Zeilstra 10 months ago

Pressed save button twice so the bug is now double registred, sorry for that.

#2 Updated by Dru Lavigne 10 months ago

  • Has duplicate Bug #67593: S3 Service fails to start added

#3 Updated by Dru Lavigne 10 months ago

  • Private changed from No to Yes
  • Reason for Blocked set to Need additional information from Author

Peter: please attach a debug (System -> Advanced -> Save debug) to this ticket.

#4 Updated by Peter Zeilstra 10 months ago

  • File debug-PNAS-20190104144044.tgz added

Debug attached.

#5 Updated by Peter Zeilstra 10 months ago

  • File minio.txt added

#6 Updated by Dru Lavigne 10 months ago

  • Assignee changed from Release Council to William Grzybowski
  • Reason for Blocked deleted (Need additional information from Author)

#7 Updated by William Grzybowski 10 months ago

  • Assignee changed from William Grzybowski to Waqar Ahmed
  • Target version changed from Backlog to 11.2-U2

#8 Updated by Waqar Ahmed 10 months ago

  • Status changed from Unscreened to In Progress

#9 Updated by Waqar Ahmed 9 months ago

An update: This has been most likely fixed in another ticket which was related to another issue with minio not starting. Will be updating this ticket as soon as I can confirm this in latest 11.2 nightlies.

#10 Updated by Peter Zeilstra 9 months ago

Waqar Ahmed wrote:

An update: This has been most likely fixed in another ticket which was related to another issue with minio not starting. Will be updating this ticket as soon as I can confirm this in latest 11.2 nightlies.

Peter:

Cheers. Which directory is Minio located in as a service?

#11 Updated by Waqar Ahmed 9 months ago

  • Copied to Bug #68871: S3 Service fails to start added

#12 Updated by Dru Lavigne 9 months ago

  • File deleted (debug-PNAS-20190104144044.tgz)

#13 Updated by Dru Lavigne 9 months ago

  • File deleted (minio.txt)

#14 Updated by Dru Lavigne 9 months ago

  • Subject changed from S3 Service fails to start to Fix bug that prevented S3 service from starting
  • Private changed from Yes to No
  • Needs Doc changed from Yes to No
  • Needs Merging changed from Yes to No

#15 Updated by Waqar Ahmed 9 months ago

  • Status changed from In Progress to Ready for Testing

#16 Updated by Dru Lavigne 9 months ago

  • Has duplicate Bug #69112: FreeNAS 11.2-RELEASE-U1 S3 service failed to start. added

#19 Updated by Waqar Ahmed 9 months ago

  • Related to Bug #65544: Do not start S3 service at boot if 'Start Automatically' is not checked added

#21 Updated by Bonnie Follweiler 8 months ago

  • Status changed from Ready for Testing to Passed Testing
  • Needs QA changed from Yes to No

Test Passed in FreeNAS-11.2-U2-INTERNAL84

#22 Updated by Dru Lavigne 8 months ago

  • Status changed from Passed Testing to Done

Also available in: Atom PDF