Project

General

Profile

Bug #67672

Relax the TCP reassembly queue length limit to improve performance

Added by Ryan Moeller 6 months ago. Updated 6 months ago.

Status:
Closed
Priority:
No priority
Assignee:
Ryan Moeller
Category:
OS
Target version:
Seen in:
Severity:
Medium
Reason for Closing:
Duplicate Issue
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

(For tracking this fix in TrueNAS 11.2)

*Original ticket description:

See discussion on forums at

https://forums.freenas.org/index.php?threads/11-1u6-update-transfer-aborts-on-smb-share-mac-client.69553/
https://forums.freenas.org/index.php?threads/network-issues-after-upgrading-to-11-1-u6.69506/

Two different reports of erratic network issues between FreeNAS and MacOS clients after upgrading to U6, observed in SMB and SCP timeouts and/or network performance dropping to zero, sometimes recovering before dropping to zero again.

Symptoms verified on MacOS 10.13.6 and 10.12.6.

Disappear after rollback to FreeNAS to 11.1-U5, everything else equal.


Related issues

Is duplicate of FreeNAS - Bug #43558: Relax the TCP reassembly queue length limit to improve performanceDone

History

#1 Updated by Ryan Moeller 6 months ago

  • Copied from Bug #43558: Relax the TCP reassembly queue length limit to improve performance added

#2 Updated by Ryan Moeller 6 months ago

#3 Updated by Ryan Moeller 6 months ago

  • Status changed from In Progress to Ready for Testing
  • Needs Merging changed from Yes to No

#5 Updated by Dru Lavigne 6 months ago

  • Status changed from Ready for Testing to Closed
  • Target version changed from TrueNAS 11.2-U3 to N/A
  • Reason for Closing set to Duplicate Issue

#7 Updated by Dru Lavigne 6 months ago

  • Copied from deleted (Bug #43558: Relax the TCP reassembly queue length limit to improve performance)

#8 Updated by Dru Lavigne 6 months ago

  • Is duplicate of Bug #43558: Relax the TCP reassembly queue length limit to improve performance added

Also available in: Atom PDF