Project

General

Profile

Bug #67717

new UI stop working, legacy UI working when there is no other browser with the new ui open

Added by Alexander Morales Sevilla 9 months ago. Updated 7 months ago.

Status:
Closed
Priority:
No priority
Assignee:
William Grzybowski
Category:
Middleware
Target version:
Severity:
New
Reason for Closing:
Reason for Blocked:
Waiting for feedback
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

hello

the new UI stop working fews hours ago, the sistem is a new fresh install, the system was working perfectly with the new UI but the new UI stop workin without have changed any configuration, the console is showing the next error

Jan 4 10:52:19 fidunas uwsgi: [sentry.errors:674] Sentry responded with an API error: RateLimited(None)
Jan 4 10:52:19 fidunas uwsgi: [sentry.errors.uncaught:702] ['timeout: timed out', ' File "django/core/handlers/exception.py", line 42, in inner', ' File "django/core/handlers/base.py", line 244, in legacy_get_response', ' File "freenasUI/freeadmin/middleware.py", line 296, in process_request', ' File "freenasUI/middleware/auth.py", line 8, in authenticate', ' File "freenasUI/middleware/client.py", line 20, in enter', ' File "middlewared/client/client.py", line 320, in init', ' File "middlewared/client/client.py", line 313, in init', ' File "middlewared/client/client.py", line 170, in connect', ' File "ws4py/client/_init__.py", line 215, in connect']
Jan 4 10:52:29 fidunas uwsgi: [sentry.errors:674] Sentry responded with an API error: RateLimited(None)
Jan 4 10:52:29 fidunas uwsgi: [sentry.errors.uncaught:702] ['timeout: timed out', ' File "django/core/handlers/exception.py", line 42, in inner', ' File "django/core/handlers/base.py", line 244, in legacy_get_response', ' File "freenasUI/freeadmin/middleware.py", line 296, in process_request', ' File "freenasUI/middleware/auth.py", line 8, in authenticate', ' File "freenasUI/middleware/client.py", line 20, in enter', ' File "middlewared/client/client.py", line 320, in init', ' File "middlewared/client/client.py", line 313, in init', ' File "middlewared/client/client.py", line 170, in connect', ' File "ws4py/client/_init__.py", line 215, in connect']
Jan 4 10:52:39 fidunas uwsgi: [sentry.errors:674] Sentry responded with an API error: RateLimited(None)
Jan 4 10:52:39 fidunas uwsgi: [sentry.errors.uncaught:702] ['timeout: timed out', ' File "django/core/handlers/exception.py", line 42, in inner', ' File "django/core/handlers/base.py", line 244, in legacy_get_response', ' File "freenasUI/freeadmin/middleware.py", line 296, in process_request', ' File "freenasUI/middleware/auth.py", line 8, in authenticate', ' File "freenasUI/middleware/client.py", line 20, in enter', ' File "middlewared/client/client.py", line 320, in init', ' File "middlewared/client/client.py", line 313, in init', ' File "middlewared/client/client.py", line 170, in connect', ' File "ws4py/client/_init__.py", line 215, in connect']
Jan 4 10:53:00 fidunas uwsgi: [sentry.errors:674] Sentry responded with an API error: RateLimited(None)
Jan 4 10:53:00 fidunas uwsgi: [sentry.errors.uncaught:702] ['timeout: timed out', ' File "django/core/handlers/exception.py", line 42, in inner', ' File "django/core/handlers/base.py", line 244, in legacy_get_response', ' File "freenasUI/freeadmin/middleware.py", line 296, in process_request', ' File "freenasUI/middleware/auth.py", line 8, in authenticate', ' File "freenasUI/middleware/client.py", line 20, in enter', ' File "middlewared/client/client.py", line 320, in init', ' File "middlewared/client/client.py", line 313, in init', ' File "middlewared/client/client.py", line 170, in connect', ' File "ws4py/client/_init__.py", line 215, in connect']
Jan 4 10:53:11 fidunas uwsgi: [sentry.errors:674] Sentry responded with an API error: RateLimited(None)
Jan 4 10:53:11 fidunas uwsgi: [sentry.errors.uncaught:702] ['timeout: timed out', ' File "django/core/handlers/exception.py", line 42, in inner', ' File "django/core/handlers/base.py", line 244, in legacy_get_response', ' File "freenasUI/freeadmin/middleware.py", line 296, in process_request', ' File "freenasUI/middleware/auth.py", line 8, in authenticate', ' File "freenasUI/middleware/client.py", line 20, in enter', ' File "middlewared/client/client.py", line 320, in init', ' File "middlewared/client/client.py", line 313, in init', ' File "middlewared/client/client.py", line 170, in connect', ' File "ws4py/client/_init__.py", line 215, in connect']
Jan 4 10:53:32 fidunas uwsgi: [sentry.errors:674] Sentry responded with an API error: RateLimited(None)
Jan 4 10:53:32 fidunas uwsgi: [sentry.errors.uncaught:702] ['timeout: timed out', ' File "django/core/handlers/exception.py", line 42, in inner', ' File "django/core/handlers/base.py", line 244, in legacy_get_response', ' File "freenasUI/freeadmin/middleware.py", line 296, in process_request', ' File "freenasUI/middleware/auth.py", line 8, in authenticate', ' File "freenasUI/middleware/client.py", line 20, in enter', ' File "middlewared/client/client.py", line 320, in init', ' File "middlewared/client/client.py", line 313, in init', ' File "middlewared/client/client.py", line 170, in connect', ' File "ws4py/client/_init__.py", line 215, in connect']

at the moment I'm using the legacy UI but I understand that is not recomended, that's why I hope you could help me with this issue.

actual state:
1: login page take too long to show, while appear show a message that says "Connecting to NAS... Make sure the NAS system is powered on and connected to the network."
2: after few minutes of the message, the login appear, and let enter to the UI, but no option load the information, dashboard not load, storage not load, any information load on the UI
3: all storage and share are working correctly, the new webui is the only issue

legacy_ui_start_working_again_if_close_all_windows_with_net_ui.png (94.4 KB) legacy_ui_start_working_again_if_close_all_windows_with_net_ui.png Alexander Morales Sevilla, 01/04/2019 10:10 AM
legacy ui fail if there other windows with the new UI.png (130 KB) legacy ui fail if there other windows with the new UI.png Alexander Morales Sevilla, 01/04/2019 10:10 AM
UI_not_load_info.png (62.6 KB) UI_not_load_info.png Alexander Morales Sevilla, 01/04/2019 10:10 AM
login_error.png (531 KB) login_error.png Alexander Morales Sevilla, 01/04/2019 10:10 AM
UI_not_load_pool_info.png (42.8 KB) UI_not_load_pool_info.png Alexander Morales Sevilla, 01/04/2019 10:10 AM
47431
47433
47442
47449
47451

History

#1 Updated by Dru Lavigne 9 months ago

  • Category changed from GUI (new) to Middleware
  • Assignee changed from Release Council to William Grzybowski
  • Private changed from No to Yes

#2 Updated by Alexander Morales Sevilla 9 months ago

Good morning

Is there a way to restart the services of the GUI or Middleware for fix the new GUI without restart the server?

#3 Updated by William Grzybowski 9 months ago

  • Status changed from Unscreened to Blocked
  • Reason for Blocked set to Waiting for feedback

Can you try to attach Save Debug (System - Advanced) when you get the UI to work?

#4 Updated by Alexander Morales Sevilla 9 months ago

  • File messages.1 added

William Grzybowski wrote:

Can you try to attach Save Debug (System - Advanced) when you get the UI to work?

Hello, thanks for answer

I attach the syslog message file, from the new UI the option system -> advanced not load

#5 Updated by William Grzybowski 9 months ago

Unfortunately thats not useful, we need full debug.

Can you explain what exactly you were doing before and during when this started happening?

Also can you try rebooting and getting the debug again?

#6 Updated by Alexander Morales Sevilla 8 months ago

  • File debug-fidunas-20190110103833.tgz added

William Grzybowski wrote:

Unfortunately thats not useful, we need full debug.

Can you explain what exactly you were doing before and during when this started happening?

Also can you try rebooting and getting the debug again?

Hello

1. Can you explain what exactly you were doing before and during when this started happening?
Answer: Creating datasets and windows shares

2. Also can you try rebooting and getting the debug again?
Answer: yesterday the UI start working again but without reboot or doing anything, only checked in the morning and it was working again, the debug is attached to this message

#7 Updated by William Grzybowski 8 months ago

Sorry it took me a while to get back at this.

Can you reproduce it at will? Perhaps we could schedule a TeamViewer to debug the issue.

#8 Updated by Alexander Morales Sevilla 8 months ago

William Grzybowski wrote:

Sorry it took me a while to get back at this.

Can you reproduce it at will? Perhaps we could schedule a TeamViewer to debug the issue.

Good morning

Sorry for took this long time to answer, at the moment the system is working correctly, the cause is still indeterminated, but I don't know how to reproduce de issue again, you can contact to mi with team viewer, we can schedule the meeting from my email

#9 Updated by William Grzybowski 7 months ago

  • Status changed from Blocked to Closed
  • Target version changed from Backlog to N/A

Since we dont know a way to reproduce and several changes have been made to mitigate similar issues I am closing this.

Please report back if this happens again after 11.2-U2, due to be released this week.

#10 Updated by Dru Lavigne 7 months ago

  • File deleted (debug-fidunas-20190110103833.tgz)

#11 Updated by Dru Lavigne 7 months ago

  • File deleted (messages.1)

#12 Updated by Dru Lavigne 7 months ago

  • Private changed from Yes to No

Also available in: Atom PDF