Project

General

Profile

Bug #67888

Zvol Creation through GUI Hangs Indefinitely

Added by Ray Sundland 7 months ago. Updated 6 months ago.

Status:
Closed
Priority:
No priority
Assignee:
Vaibhav Chauhan
Category:
GUI (new)
Target version:
Severity:
New
Reason for Closing:
Duplicate Issue
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

Attempting to create a Zvol inside of a dataset through the GUI results in the attempt hanging indefinitely when hitting Save. No error is returned, and no zvol is created.

Creating a Zvol through CLI works fine: zfs create -V 250G mypool/dataset/vol1

It appears this is the case if you do not choose a block size. It would make sense for the "default" block size be "inherit" similar to other GUI wizard screens, or error out when no block size is properly selected. Further, the GUI should specify the requirement to select a Block Size field is required before the form can be submitted.

zvol-hang.jpg (37 KB) zvol-hang.jpg Ray Sundland, 01/05/2019 06:53 PM
vzol-create-edge.jpg (122 KB) vzol-create-edge.jpg Ray Sundland, 01/08/2019 04:46 PM
vzol-create-firefox.jpg (124 KB) vzol-create-firefox.jpg Ray Sundland, 01/08/2019 04:51 PM
zvol-legacyui-chrome.jpg (45.3 KB) zvol-legacyui-chrome.jpg Ray Sundland, 01/08/2019 05:22 PM
112RELEASEU1.png (1.13 MB) 112RELEASEU1.png 112RELEASEU1 Vaibhav Chauhan, 01/09/2019 08:21 AM
freenas_11.2-stable(branch).png (506 KB) freenas_11.2-stable(branch).png freenas/11.2-stable branch Vaibhav Chauhan, 01/09/2019 08:21 AM
47701
48007
48016
48025
48106
48115

Related issues

Is duplicate of FreeNAS - Bug #62028: Set correct values for quotas in edit mode of new UIDone

History

#1 Updated by Ray Sundland 7 months ago

The (?) notes that the Default Block Size it chosen based on the number of disks in the pool, but this does not seem to be the case.

#2 Updated by Dru Lavigne 7 months ago

  • Assignee changed from Release Council to Erin Clark
  • Target version changed from Backlog to 11.2-U2

#3 Updated by Erin Clark 6 months ago

  • Private changed from No to Yes

Is this easily reproducible on your box? If so could you both provide us a debug (Go to system > advanced and click save debug) and could you see if there are any tracebacks in the console (right click > inspect and go to console). I am marking the ticket private so you can upload your debug privately.

#4 Updated by Ray Sundland 6 months ago

  • File debug-nas-20190107190643.tgz added
  • File nas-1546906358807.log added

Reproducible. Debug is attached.

There are some JS errors in console, I have attached that output as well.

#5 Updated by Erin Clark 6 months ago

  • Assignee changed from Erin Clark to Lola Yang

#6 Updated by Erin Clark 6 months ago

We are having a difficult time reproducing this locally, what version are you on? On 11.2-RELEASE it always has the blocksize set for me. What is the blocksize of the parent dataset?

#7 Updated by Ray Sundland 6 months ago

OS Version:
FreeNAS-11.2-RELEASE-U1

(Build Date: Dec 20, 2018 22:41)

#8 Updated by Ray Sundland 6 months ago

48007

I tried doing it in MS Edge too (I know, I know)... but seeing similar JS errors there, too.

#9 Updated by Erin Clark 6 months ago

Can you try another browser like Firefox or Chrome?

#10 Updated by Ray Sundland 6 months ago

48016

Original browser was Chrome... Firefox is the same (latest, see screenshot)... Chrome Incognito also results in the same.

#11 Updated by Erin Clark 6 months ago

So what is the parent's blocksize exactly, it is supposed to set it to Inherit but it looks like it is doing something wrong

#12 Updated by Ray Sundland 6 months ago

The record size of the parent dataset is set to inherit (from the pool), and the pool is set to 128K.

I do notice that 512, 1K, and 2K options are greyed out if I try to change the record size at the pool or dataset level.

Just noticed, if I attempt to create the Zvol at the pool directly (not under a dataset), the Block Size gets automatically set to 16K (not 128K which is the pool's record size) -- which also seems odd if, as you said, it should inherit from the parent.

So with that, I just created a new dataset with a static Record Size (not inheriting from the pool), but then creating the Zvol under the new dataset results in the same JS error, no block size defined, and hangs indefinitely unless the block size is chosen.

#13 Updated by Erin Clark 6 months ago

  • Assignee changed from Lola Yang to Vaibhav Chauhan

#15 Updated by Erin Clark 6 months ago

Have you tried doing this in the old UI to see if it still works there?

#16 Updated by Ray Sundland 6 months ago

48025

The Block Size is properly inherited in the legacy UI (see screenshot), and creation works as expected.

#17 Updated by Vaibhav Chauhan 6 months ago

48106
48115

I am certain that this issue is fixed in freenas/11.2 stable branch as it was part of the fixes that went in after 11.2-RELEASE was released but fix was not part of 11.2-RELEASEU1 release.

Related
https://redmine.ixsystems.com/issues/62028
https://redmine.ixsystems.com/issues/64563

#18 Updated by Ray Sundland 6 months ago

This does look similar in nature. I am running 11.2-STABLE branch but don't see any updates. Is it actually in -STABLE at this point?

#19 Updated by Vaibhav Chauhan 6 months ago

yes fix is part of current STABLE branch, of which future software release would be build upon. you should have this fix in next software release.

#20 Updated by Erin Clark 6 months ago

  • Is duplicate of Bug #62028: Set correct values for quotas in edit mode of new UI added

#21 Updated by Erin Clark 6 months ago

  • Status changed from In Progress to Closed
  • Reason for Closing set to Duplicate Issue

Since this is most likely fixed as of https://redmine.ixsystems.com/issues/62028, I am going to go ahead and close this, please update to the next release that comes out and if you are still having problems reopen the ticket and we will investigate this further.

#22 Updated by Dru Lavigne 6 months ago

  • File deleted (debug-nas-20190107190643.tgz)

#23 Updated by Dru Lavigne 6 months ago

  • File deleted (nas-1546906358807.log)

#24 Updated by Dru Lavigne 6 months ago

  • Target version changed from 11.2-U2 to N/A
  • Private changed from Yes to No

Also available in: Atom PDF