Project

General

Profile

Bug #67924

edit dataset shows wrong size units (eg. MiB instead of GiB)

Added by Pat Fruth 6 months ago. Updated 6 months ago.

Status:
Closed
Priority:
No priority
Assignee:
Vaibhav Chauhan
Category:
GUI (new)
Target version:
Severity:
New
Reason for Closing:
Duplicate Issue
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

I've created a new dataset and set a Quota size of 50 GiB.
Later, when I attempt to edit that dataset, the Quota size is show with unit of 50 MiB.

The edit dataset UI page should correctly reflect the Quota size(s) that were initially defined when the dataset was created.

Screen Shot 2019-01-06 at 9.07.08 AM.png (361 KB) Screen Shot 2019-01-06 at 9.07.08 AM.png Pat Fruth, 01/06/2019 08:09 AM
Screen Shot 2019-01-08 at 2.23.26 PM.png (168 KB) Screen Shot 2019-01-08 at 2.23.26 PM.png cannot reproduce Vaibhav Chauhan, 01/08/2019 11:23 AM
Screen Shot 2019-01-08 at 9.53.55 PM.png (528 KB) Screen Shot 2019-01-08 at 9.53.55 PM.png Pat Fruth, 01/08/2019 09:04 PM
dataset list view.png (10.6 KB) dataset list view.png dataset list view Vaibhav Chauhan, 01/16/2019 06:58 AM
testds2 edit view.png (25.4 KB) testds2 edit view.png testds2 edit view Vaibhav Chauhan, 01/16/2019 06:58 AM
testds2-1 edit view.png (25.6 KB) testds2-1 edit view.png testds2-1 edit view Vaibhav Chauhan, 01/16/2019 06:58 AM
47721
47991
48036
48981
48988
48990

Related issues

Is duplicate of FreeNAS - Bug #62028: Set correct values for quotas in edit mode of new UIDone

History

#1 Updated by Pat Fruth 6 months ago

47721

Adding screen-shot

#2 Updated by Dru Lavigne 6 months ago

  • Category changed from Console to GUI (new)
  • Assignee changed from Release Council to Erin Clark
  • Target version changed from Backlog to 11.2-U3

#3 Updated by Erin Clark 6 months ago

  • Assignee changed from Erin Clark to Vaibhav Chauhan

#4 Updated by Vaibhav Chauhan 6 months ago

47991

I cannot reproduce this issue,

I am running, FreeNAS-11.2-RELEASE and user new user interface when I created test dataset with 50 Gib quota
in edit screen I was able to see that 50 Gib was displayed which is in line with what I originally created. (please refer to the screenshot i have attached)

#5 Updated by Pat Fruth 6 months ago

48036

@Vaibhav Chauhan
In your attempt to reproduce the problem, did you edit a dataset that is a child of another dataset? Or did you edit a dataset that is a direct child of a pool?
I ask because in my further testing, I've found that editing a dataset that is a direct child of a pool, exhibits the problem.
However, editing a dataset which is a child of another dataset does not exhibit the problem.
See the attached screen-shot for a depiction of my above description.

Could you have another look

#6 Updated by Dru Lavigne 6 months ago

  • Status changed from Closed to Unscreened

#7 Updated by Vaibhav Chauhan 6 months ago

  • Status changed from Unscreened to In Progress
  • Reason for Closing deleted (Cannot Reproduce)

thanks for the testing, with new updated steps helped me to reproduce the issue.

#8 Updated by Vaibhav Chauhan 6 months ago

48981
48988
48990

so this problem seems to be fixed in `freenas/11.2-stable` branch of which future freenas software release will be build upon.

I created some sample datasets similar with your configuration and this problem is appear to be fixed

root@freenas:~ # zpool list
....
zpool/d0/testds2                                         256K  50.0G   128K  /mnt/zpool/d0/testds2
zpool/d0/testds2/testds2-1                               128K  5.00G   128K  /mnt/zpool/d0/testds2/testds2-1
....

#10 Updated by Dru Lavigne 6 months ago

  • Is duplicate of Bug #62028: Set correct values for quotas in edit mode of new UI added

#11 Updated by Dru Lavigne 6 months ago

  • Status changed from Ready for Testing to Closed
  • Target version changed from 11.2-U3 to N/A
  • Reason for Closing set to Duplicate Issue

Pat: the fix for this issue will appear in the U2 update, due out in a few weeks (see related ticket for details).

Also available in: Atom PDF