Project

General

Profile

Bug #68250

Avatar?id=43137&size=50x50

New UI not showing interface options

Added by Oded Brilon over 2 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
No priority
Assignee:
-
Category:
GUI (new)
Target version:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No
Tags:

Description

The new UI does not show the interface details. This is due to error 401 coming from the API.
Additionally, when an error such as this occurs, a logout process is being triggered which logs out the user each time an api error occurs (and an invalid JSON object gets returned).

API_Auth_Error.png (236 KB) API_Auth_Error.png Oded Brilon, 01/07/2019 12:28 PM
47856

Related issues

Related to FreeNAS - Feature #52517: Implement network rewrite in new UIClosed

History

#1 Avatar?id=43137&size=24x24 Updated by Oded Brilon over 2 years ago

  • Description updated (diff)

#2 Updated by Dru Lavigne over 2 years ago

  • Assignee changed from Release Council to Anonymous
  • Target version changed from Backlog to 11.2-U3

#4 Updated by Anonymous over 2 years ago

So does this error only happen when it is about to log you out? Can you see the network interface options for example right after you log in?

#5 Avatar?id=43137&size=24x24 Updated by Oded Brilon over 2 years ago

Erin Clark wrote:

So does this error only happen when it is about to log you out? Can you see the network interface options for example right after you log in?

I believe I managed to trace it all the way.
It looks like the root cause of it all is the dashboard trying to report on NVME temps and CPU temps. the output returns null. (not sure why as for example smartctl -a /dev/nvme0 does return the correct temps) and so the trace shows:

TypeError: Cannot read property 'legend' of undefined
TypeError: Cannot read property 'getHours' of undefined

This causes the following error to repeat itself until : {error: 59, type: null, reason: "Maximum number of concurrent calls (20) has exceeded.", trace: null, extra: null}
main.a32bb4e470efadeae848.js:1

until a timeout happens.
I will do some more digging to try and understand the underlying cause.

#6 Updated by Anonymous over 2 years ago

What version of FreeNAS are you currently seeing this on?

#7 Avatar?id=43137&size=24x24 Updated by Oded Brilon over 2 years ago

Erin Clark wrote:

What version of FreeNAS are you currently seeing this on?

11.3 nightly

#8 Updated by Anonymous over 2 years ago

  • Target version changed from 11.2-U3 to 11.3-BETA1

I think this only affects 11.3, I cannot reproduce in 11.2

#9 Updated by Anonymous over 2 years ago

  • Related to Feature #52517: Implement network rewrite in new UI added

#10 Avatar?id=14398&size=24x24 Updated by Kris Moore over 2 years ago

  • Status changed from Unscreened to Closed

Also available in: Atom PDF