Project

General

Profile

Bug #68502

default interface not added to jail bridge

Added by Stephen Cunningham 10 months ago. Updated 10 months ago.

Status:
Closed
Priority:
No priority
Assignee:
Brandon Schneider
Category:
Middleware
Target version:
Severity:
New
Reason for Closing:
User Configuration Error
Reason for Blocked:
Needs QA:
No
Needs Doc:
No
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

All jails have vnet default_interface set to none. FreeNAS adds no interface automatically to the jail bridge. There is no way to manually add the interface to the jail bridge.

This works but of course is not persistent

ifconfig bridge0 addm igb0 up


Related issues

Related to FreeNAS - Bug #62361: Migrate users to 'auto' with iocage vnet_default_interfaceDone

History

#1 Updated by Dru Lavigne 10 months ago

  • Status changed from Unscreened to Blocked
  • Private changed from No to Yes
  • Reason for Blocked set to Need additional information from Author

Stephen: is this on the latest nightly? If so, please reproduce then attach a debug (Systerm -> Advanced -> Save debug) to this ticket.

#2 Updated by Stephen Cunningham 10 months ago

  • File debug-freenas-20190110104145.tgz added

#3 Updated by Dru Lavigne 10 months ago

  • Status changed from Blocked to Unscreened
  • Assignee changed from Release Council to William Grzybowski
  • Reason for Blocked deleted (Need additional information from Author)

#4 Updated by William Grzybowski 10 months ago

  • Status changed from Unscreened to Blocked
  • Reason for Blocked set to Waiting for feedback

Did you manually set them to "none"?

In 11.3 the behavior changed and it will only add to the bridge if you set to "auto"

#5 Updated by Stephen Cunningham 10 months ago

I never changed them to none and the jails were created with.

iocage create -n "plex" -r 11.2-RELEASE ip4_addr="vnet0|10.68.69.3/24" defaultrouter="10.68.69.1" vnet="on" allow_raw_sockets="1" boot="on" 

There is no selection for "auto" in the drop down for interfaces.

#6 Updated by William Grzybowski 10 months ago

  • Status changed from Blocked to Unscreened
  • Assignee changed from William Grzybowski to Brandon Schneider
  • Reason for Blocked deleted (Waiting for feedback)

#7 Updated by Brandon Schneider 10 months ago

  • Status changed from Unscreened to Blocked
  • Reason for Blocked set to Need additional information from Author

Stephen: I can't reproduce this. Looking at your configuration, you likely created these with the Web GUI? There is a bug ticket now for them to add "auto" to the drop down box. Creating from the cli should not show this behavior:

root@freenas[~]# iocage create -n "plex" -r 11.2-RELEASE ip4_addr="vnet0|10.68.69.3/24" defaultrouter="10.68.69.1" vnet="on" allow_raw_sockets="1" boot="on"  ; iocage get vnet_default_interface plex
plex successfully created!
* Starting plex
  + Started OK
  + Using devfs_ruleset: 7
  + Configuring VNET OK
  + Starting services OK
  + Executing poststart OK
auto

Can you try doing this on the cli and show the output:

iocage create -n foo -r 11.2-RELEASE ; iocage get vnet_default_interface foo ; cat /mnt/myVol/iocage/jails/foo/config.json

#8 Updated by Stephen Cunningham 10 months ago

All my jails should be created through the CLI. EDIT:I may have created a jail through the GUI in testing but it's not my normal practice.

This was a test made through the CLI

root@freenas[~]# iocage create -n "test" -r 11.2-RELEASE ip4_addr="vnet0|10.68.69.99/24" defaultrouter="10.68.69.1" vnet="on" allow_raw_sockets="1" boot="on" 
test successfully created!
* Starting test
  + Started OK
  + Using devfs_ruleset: 11
  + Configuring VNET OK
  + Starting services OK
root@freenas[~]#

As requested

root@freenas[~]# iocage create -n foo -r 11.2-RELEASE ; iocage get vnet_default_interface foo ; cat /mnt/myVol/iocage/jails/foo/config.json
foo successfully created!
none
{
    "cloned_release": "11.2-RELEASE",
    "host_hostname": "foo",
    "host_hostuuid": "foo",
    "jail_zfs_dataset": "iocage/jails/foo/data",
    "release": "11.2-RELEASE-p6" 
}#                                                                                                                             root@freenas[~]#

#9 Updated by Stephen Cunningham 10 months ago

Manually editing a single jail config.json to "auto" for default interfaces adds the default interface to bridge0. All the jails have persistent network connectivity with this fix even though the rest of the jails are set to "none".

#10 Updated by Brandon Schneider 10 months ago

  • Status changed from Blocked to Closed
  • Reason for Closing set to User Configuration Error
  • Reason for Blocked deleted (Need additional information from Author)
  • Needs QA changed from Yes to No
  • Needs Doc changed from Yes to No
  • Needs Merging changed from Yes to No

Stephen: Yeah that confirms my suspicions. Technically this is all doing the right thing unless defaults aren't using the right property (I checked they are). So closing this as it's down to users needing to change their jails.

Thanks for reporting back!

#11 Updated by Brandon Schneider 10 months ago

  • Target version changed from Backlog to N/A

#12 Updated by Dru Lavigne 10 months ago

  • Related to Bug #62361: Migrate users to 'auto' with iocage vnet_default_interface added

#13 Updated by Dru Lavigne 10 months ago

  • File deleted (debug-freenas-20190110104145.tgz)

#14 Updated by Dru Lavigne 10 months ago

  • Private changed from Yes to No

Also available in: Atom PDF